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Creating Web Pages with Nvu
Nvu lets you create your own web pages and publish them on the web. You don't have to
know HTML to use Nvu; it is as easy to use as a word processor.

Toolbar buttons let you add lists, tables, images, links to other pages, colors, and font
styles. You can see what your document will look like on the Web as you create it, and you
can easily share your document with other users, no matter what type of browser or
HTML-capable email program they use.

Starting a New Page

Creating a New Page

Nvu is an HTML (Hypertext Markup Language) editor that allows you to create and edit web
pages. Nvu is a WYSIWYG (What You See Is What You Get) editor, so you can display how
your page will look to the reader as you're creating it. It is not necessary for you to know
HTML, since most of the basic HTML functions are available as commands from the
toolbars and menus.

Nvu also lets you edit the HTML source if you want. To view or edit the HTML source code,
open the View menu, and choose HTML Source, or click the <HTML> Source tab in the Edit
Mode toolbar at the bottom of the Nvu window.

To create a web page, use one of the methods described below. Once you've started a
page, you can add and edit text just as you would in a word processor.

To create a new page in Nvu:

Click the New button in Nvu's toolbar.

To start from an HTML file stored on your local drive:

Open the Window menu and choose Nvu. You see the Nvu window.1.
Open the File menu and choose Open File. You see the Open HTML File dialog box.2.
On your local drive, locate the file that you want to edit.3.
Click Open to display the specified file in a Nvu window.4.

To edit a web page:

Open Nvu1.
Click on File  menu and choose Open Web Location. You will see the Open Web
Location dialog box.

2.

Type in the URL of the page to edit (for example, http://www.mozilla.org) and click 
Create button. You will see the page displayed in Nvu.

3.

Tip: In the Nvu window you can quickly open the most recent file you've been working on by
opening the File menu, choosing Recent Pages, and then selecting the file you want from
the list.

[ Return to beginning of section ]

Tabs - Editing Multiple Documents
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Nvu allows you to edit multiple documents at the same time. Rather than to shift from one
window to another for editing more than one document, Nvu offers the feature of Tabs. 
More than one document can be opened at the same time with Nvu in the same window but
in different tabs.

Tabs can be opened using either Ctrl+T or by choosing Create in: New Tab in the New file 
open dialog. Even with multiple tabs open, each is handled independently. Each
document's state is indicated, i.e. if it is modified and needs saving by a red-floppy icon on
the corresponding tab.

[ Return to beginning of section ]

Saving and Browsing Your New Page

You can save Nvu documents in HTML or text-only format. Saving a document in HTML
format preserves the document's formatting, such as text styles (for example, bold or
italic), tables, links, and images. Saving a document in text-only format removes all the
HTML tags but preserves the document's text.

To save a document as an HTML file:

Open the File menu and choose Save or click the Save button on the Composition
toolbar.

If you haven't already given your page a title, Nvu prompts you to do so. Nvu
displays the page title in the browser window's title bar when you view the page in
the browser. The document's page title also appears in your list of bookmarks if you
bookmark the page.

Nvu then prompts you to enter a filename and specify the location where you want to
save the file. Make sure you preserve the .html extension in the filename.

To change the filename or location of an existing HTML file:

Choose Save As and select a different filename or location.

When you save a page in Nvu, all parts of the page (the HTML, images and other files, such
as sound files and style sheets), are saved locally on your hard drive. If you only want to
save the HTML part of the page, you must change the Nvu preference for saving pages.
See Nvu Preferences for more information on changing Nvu's setting for saving pages.

If an image location is absolute (starts with "http://") and you are connected to the Internet,
you will still see that image in the document in Nvu and Navigator. However, if the image
location is relative to the page location (starts with "file:///"), then you won't see the image in
the local version of the document.

To save a document as a text-only file:

Open the File menu and choose Export to Text.1.
Enter the filename and specify the location where you want to save the file.2.

Note: Images do not appear in documents saved in the text-only format.

Tip: You can choose Revert from the File menu to retrieve the most recently saved copy of
the document in which you're working. Keep in mind that your current changes will be lost.

To view your page in a browser window in order to test your links:

Open the File menu and choose Browse Page (or click Browse in the Composition
toolbar). If you have not yet saved your document, Nvu prompts you to enter a page
title, filename, and location. The Nvu window remains open behind the new Navigator
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window.

[ Return to beginning of section ]

Formatting Your Web Pages

Formatting Paragraphs, Headings, and Lists

To apply a format to a paragraph, begin from the Nvu window:

Click to place the insertion point where you want the format to begin, or select the
text you want to format.

1.

Choose a paragraph format using the drop-down list in the Format toolbar:2.
Body Text: Applies the application default font and style for regular text,
without affecting the spacing before or after the text.
Paragraph: Inserts a paragraph tag (use this to begin a new paragraph).
The paragraph includes top and bottom margins.
Heading 1 - Heading 6: Formats the paragraph as a heading. Heading 1
is the highest-level heading, while Heading 6 is the lowest-level heading.
Address: Can be used for a web page "signature" that indicates the author
of the page and the person to contact for more information, for example:
user@example.com

You might want to include the date and a copyright notice. This format
usually appears at the bottom of the web page under a horizontal line.
Navigator displays the address format in italics.

Preformat: This is useful for elements such as code examples, column
data, and mail messages that you want displayed in a fixed-width font. In
normal text, most browsers remove extra spaces, tabs, and paragraph
returns. However, text that uses the Preformatted style is displayed with the
white space intact, preserving the layout of the original text.

To format text as a heading:

Click to place the insertion point anywhere within the text that you want to format.1.
Using the drop-down list in the Format toolbar, choose the level of heading you want,
from 1 (largest) to 6 (smallest). Choose "Heading 1" for your main heading, "Heading
2" for the next level, and so forth.

2.

To apply a list item format:

Click to place the insertion point within the line of text that you want to format.1.
Open the Format menu and choose List.2.
Choose the list style:3.

Bulleted: Each item has a bullet (dot) next to it (as in this list).
Numbered: Items are numbered.
Term and Definition: These two styles work together, creating a
glossary-style appearance. Use the Term tag for the word being defined, and
the Definition tag for the definition. The Term text appears flush left, and the
Definition text appears indented.

Tip: You can quickly apply a list style to a block of text by selecting the text and clicking

the Numbered List  or Bulleted List  buttons on the Format toolbar.

To change the style of bullets or numbers:

Click to place the insertion point within the text of the list item you want to change,
or select one or more items in the list if you want to apply a new style to the entire

1.
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list.
Open the Format menu and choose List Properties.2.
Select a bullet or number style from the drop-down list. For numbered lists, you can
specify a starting number. For bulleted lists, you can change the bullet style.

3.

Tip: You can also double-click on a bullet or number in a list to display the List Properties
dialog box.

To align a paragraph or text in your page, for example, centering or aligning to the left or
right:

Click to place the insertion point within the paragraph or line of text you want to
align.

1.

Open the Format menu and choose Align; then choose an alignment option.2.

Note: You can also use the Format toolbar to align text.

[ Return to beginning of section ]

Working with Lists

To end a list and continue typing body text:

Click to place the insertion point at the end of the last list item and press Enter
(Return on Mac OS) twice to end the list.

To change one or more list items to body text:

Click to place the insertion point within the list item, or select the list items.1.
In a numbered list, click the numbered list button (or in a bulleted list, click the
bulleted list button) in the Format toolbar.

2.

To position indented text below a list item:

Click to place the insertion point within the list item.1.
Press Shift-Enter to create the hanging indent.2.
Type the text you want to indent.3.
Press Shift-Enter to create another indented paragraph, or press Return to create
the next list item.

4.

Tip: You can increase or decrease the indentation of list items by clicking anywhere in a list
item and then clicking the Indent or Outdent button on the Format toolbar. Alternatively,
click anywhere in a list item and press Tab to indent one level. Press Shift+Tab to outdent
one level.

To merge two adjacent lists:

Select the two lists that you want to merge. Be sure to select all of the elements in
both lists. Note that any text in between the two lists will also become part of the
merged list.

1.

Click the bulleted or numbered list button in the Format toolbar to merge the lists.2.

[ Return to beginning of section ]

Changing Text Color, Style, and Font

To change the style, color, or font of selected text:

Select the text you want to format.1.
Open the Format menu and choose one of the following:2.
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Font: Use this to choose a font. If you prefer to use fonts specified by the
reader's browser, select Variable Width or Fixed Width.

Note: Not all fonts installed on your computer appear. Instead of specifying
a font that may not be available to all who view your web page, it's generally
best to select one of the fonts provided in the menu since these fonts work
on every computer. For example, the fonts Helvetica, Arial, Times, and
Courier generally look the same when viewed on different computers. If you
select a different font, it may not look the same when viewed using a
different computer.

Size: Use this to choose a relative font size or select an option to increase
or decrease text size (relative to the surrounding text).
Text Style: Use this to select a style, such as italic, bold, or underline, or
to apply a structured style, for example, Code.
Text Color: Use this to choose a color from the color picker. If you are
familiar with HTML hexadecimal color codes, you can type a specific code or
you can just type a color name (for example, "blue"). You'll find a handy color
code converter here.

To change the background color of the page:

Click anywhere in the page.1.
Click the background color block in the Format toolbar.2.
Choose a background color from the Block Background Color dialog box.3.
Click OK.4.

Tip: To quickly change the color of text to the color last used, select the text, then press
Shift and click on the text color block in the Format toolbar. This is useful when you want to
use one color for separate lines of text.

You can also use an image as a background. See Setting Page Colors and Backgrounds.

[ Return to beginning of section ]

Removing or Discontinuing Text Styles

To remove all text styles (bold, italic, and so on) from selected text:

Select the text.1.
Open the Format menu and choose Remove All Text Styles.2.
Continue typing.3.

To continue typing text with all text styles removed:

Place the insertion point where you want to discontinue the text styles.1.
Open the Format menu and choose Discontinue Text Styles.2.
Continue typing.3.

[ Return to beginning of section ]

Finding and Replacing Text

To find text in the page you're currently working on:

Click to place the insertion point where you want to begin your search.1.
Open the Edit menu and choose Find and Replace. You see the Find and Replace
dialog box.

2.

Type the text you want to locate in the "Find what" field. To narrow the search, check3.
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one or more of the following options:
Match upper/lower case: Use this to specify whether the search is for
case-sensitive text.
Wrap around: Use this to search to the end of the page and then start
again from the top or bottom, depending on whether you are searching
forward or backwards.
Search backwards: Use this to search back from the insertion point to
the beginning of the page.

Click Find Next to begin searching. When Nvu locates the first occurrence of the
text, click Find Next to search for the next occurrence.

4.

Click Close when you are done.5.

To find and replace text in the page you're currently working on:

Click to place the insertion point where you want to begin your search.1.
Open the Edit menu and choose Find and Replace. You see the Find and Replace
dialog box.

2.

Type the text you want to find and then type the replacement text.3.
To narrow the search, check one or more of the following options:

Match upper/lower case: Use this to specify whether the search is for
case-sensitive text. If you don't select this option, the search will find
matching text in both upper and lower case.
Wrap around: Use this to search to the end of the page and then start
again from the top.
Search backwards: Use this to search from the end to the beginning of
the page.

4.

Click Find Next to search for the next occurrence. Nvu selects the next occurrence
of the text.

5.

Click Replace to replace the selected text with the replacement text. Click Replace
and Find to replace the selected text and find the next occurrence. Click Replace All
to replace every occurrence in the document with the replacement text.

6.

Click Close when you are done.7.

[ Return to beginning of section ]

Inserting Horizontal Lines

Horizontal lines are typically used to separate different sections of a document visually. To
insert a horizontal line (also called a rule) in your page, begin from the Nvu window:

Click to place the insertion point where you want the line to appear.1.
Open the Insert menu and choose Horizontal Line.2.

Setting Horizontal Line Properties

You can customize a line's height, length, width, alignment, and shading.

Double-click the line to display the Horizontal Line Properties dialog box.1.
Edit any of these properties:

Width: Enter the width and then choose "% of window" or "pixels." If you
specify width as a percentage, the line's width changes whenever the Nvu
window's or browser window's width changes.
Height: Type a number for the line's height (in pixels).
3-D Shading: Select this to add depth to the line by adding a bevel
shading.
Alignment: Specify where you want to place the line (left, center, or right).

2.

Click Use as Default to use these settings as the default the next time you insert a
horizontal line.

3.
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To edit the properties of a horizontal line manually, click Advanced Edit. See the
section, Advanced Property Editor, for details.

4.

Tip: You can select "Show All Tags" from the View menu to show all the HTML elements in
yellow boxes. Click any yellow box to select everything within that HTML tag or element.
Double-click any yellow box to display the Advanced Property Editor dialog box for that 
HTML tag or element.

[ Return to beginning of section ]

Inserting Special Characters

To insert special characters such as accent marks, copyrights, or currency symbols:

Click to place the insertion point where you want the special character to appear.1.
Open the Insert menu and choose Characters and Symbols. You see the Insert
Character dialog box.

2.

Select a category of characters.
If you choose Accent Uppercase or Accent Lowercase, then open the Letter
drop-down list and select the letter you wish to apply an accent to. (Note: not
all letters have accented forms.) Select Common Symbols to insert special
characters such as copyright symbols or fractions.

3.

From the Character drop-down list, select the character you want to insert.4.
Click Insert.

You can continue typing in your document (or in a mail compose window) while you
keep this dialog box open, in case you want to use it again.

5.

Click Close when you are done inserting special characters.6.

[ Return to beginning of section ]

Inserting HTML Elements and Attributes

If you understand how to work with HTML source code, you can insert additional tags, style
attributes, and JavaScript into your page. If you are not sure how to work with HTML source
code, it's best not to change it. To work with HTML code, use one of these methods:

Place the insertion point where you want to insert the HTML code, or select the text
you want to edit, and then open the Insert menu and choose HTML. In the Insert
HTML dialog box, enter HTML tags and text, and then click Insert.
Select an element such as a table, named anchor, image, link, or horizontal line.
Double-click the element to open the associated properties dialog box for that item.
Click Advanced Edit to open the Advanced Property Editor. You can use the
Advanced Property Editor to add HTML attributes, JavaScript, and CSS to objects.
Open the View menu, and choose HTML Source, or click the <HTML> Source tab in
the Edit Mode toolbar at the bottom of the Nvu window. (If you don't see the Edit
Mode toolbar, open the View menu and choose Show/Hide; then make sure the Edit
Mode Toolbar is checked.)

Using the Advanced Property Editor

To add HTML attributes and JavaScript to objects such as tables, images, and horizontal
lines, you can use the Advanced Property Editor.

Note: Unless you clearly understand how to add, delete, or modify HTML attributes and
their associated values, it's best not to do so.
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If you are not currently viewing the Advanced Property Editor dialog box, follow these
steps:

From the View menu (or the Edit Mode toolbar), choose Show All Tags.1.
Double-click the object that you want to modify to open its Properties dialog box.2.
Click Advanced Edit to open the object's Advanced Property Editor. The Advanced
Property Editor has three tabs, each of which lists the current properties for the
selected object:

HTML Attributes: Click this tab to view or enter additional HTML
attributes.
Inline Style: Click this tab to view or enter additional CSS (cascading
style sheet) properties through the <style> attribute. For more information on
using CSS styles in Nvu, see Nvu Preferences.
JavaScript Events: Click this tab to view or enter JavaScript events.

3.

To edit a property or attribute in any of the three lists, select the attribute you want
to edit. You can then edit the attribute's name or value using the editable Attribute
and Value fields at the bottom of the dialog box. To add a new attribute, type it in the
Attribute field at the bottom of the dialog box. The new attribute is automatically
added when you click in the Value field. To remove an attribute, select it in the list,
and click Remove Attribute.

Note: Required attributes are highlighted in the Attribute list.

4.

Click OK to apply your changes to the Advanced Property Editor dialog box.5.
Click OK again to exit the Properties dialog box.6.

Nvu automatically places quotation marks around any attribute text.

[ Return to beginning of section ]

Validating the HTML

Before you put your document on a web server(i.e. publish it), it is good practice to first
check the document's HTML formatting so as to make sure that it conforms to web
standards. Documents containing validated HTML are less likely to cause problems when
viewed by different browsers. Just visually checking your web pages in your favourite web
browser doesn't ensure that your document will appear correctly when viewed in other web
browsers.

Nvu provides a convenient way for you to check that your document conforms to W3C
(World Wide Web Consortium) HTML standards. Nvu uses the W3C HTML Validation
Service, which checks your document's HTML syntax for compliance with HTML 4.01
standards. This service also provides information on how to correct errors.

Note: You must be connected to the Internet to use this feature.

To validate your document's HTML syntax:

Open the Tools menu, and choose Validate HTML. If you have unsaved changes,
Nvu asks you to save them before proceeding.

1.

Nvu will open another window with results for your page displayed in it after the W3C
Validation Service program parses your html file.

2.

[ Return to beginning of section ]

Choosing the Right Editing Mode

Typically, you won't need to change the editing mode from the default (Normal). However, if
you want to work with the document's HTML source code, you may want to change editing
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modes.

Nvu allows you to quickly switch between four editing modes or views. Each editing mode
allows you to continue working on your document, but displays varying levels of HTML tags
(and tag icons).

Before you choose an editing mode:

Open the View menu, choose Show/Hide, and then make sure there is a checkmark
next to Edit Mode Toolbar.

The Edit Mode toolbar has four tabs:

Normal: Choose this editing mode to see how the document will look online while
you are creating it. Choose this mode to show table borders and named anchor
icons. All other HTML tag icons are hidden.
Show All Tags: Choose this mode to show all HTML tag icons.
<HTML> Source: Choose this mode to view and edit the document as
unformatted HTML source code. When you save the document, the Normal mode
reappears.
Preview: Choose this mode to display and edit the document exactly as it would
appear in a browser window, except that links and JavaScript functions will not be
active.

Note: JavaScript functions, frames, links, Java, embedded objects and animated GIF files
are not active in any of the editing modes. To display these items in their active state, click
the Browse button on the Composition toolbar to load the page into a browser window.

[ Return to beginning of section ]

Using Status Bar for Formatting Your Web Page

Nvu has an innovative feature of editing/applying inline styles and applying class or id tags
to selected text via its status bar. Styling using the status bar is possible in all modes
except <HTML> Source viewing mode.

Select Clicking on "Select" will select the entire text bounded by the style tag.
Remove Tag Clicking on "Remove Tag" will remove the style tag, and in turn all the
styles for that tag will be removed.
Change Tag Using this option, the user can change the tag used for the text with
the least effort. Clicking on "Change Tag" makes the text for the corresponding tag
to be editable in the status bar. Type in the desired tag and press "Enter". The
default properties of the tag will be applied to the text in the web page.
Inline StylesWhile in any of the Normal, HTML Tags, or Preview viewing modes
the tags surrounding the current position of the cursor are shown in the status bar of
Nvu's window. Style properties of any of the tags can be changed by choosing an
option from the context menu. To change inline style properties:

Right click on the tag you wish to edit.1.
Click on "Inline Styles" 2.
Select the properties section you want to edit:

Text Properties
Border Properties
Background Properties
Box Properties
Aural Properties
Extract and create Generic Style

3.

Secting any of the options except the last one will open the corresponding tab
section from CaScadeS CSS editor (more about CaScadeS in Using Style Sheets
section). With the corresponding section open, the user can define his/her own
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styles which will be saved according to W3C CSS coding style.

The Extract and create Generic Style option allows the user to extract the
style information into an style rule and save it in the external/internal style sheet.

Templates offers you two options, "Make Editable" and "Remove Editable Area",
which can be used while working with Templates. For more information on
Templates, see section Working With Templates.
ID shows ID tags(if available) from the current style sheet applied to the document.
To apply a particular tag to the selected text, just click on that ID tag.
Class shows the class tags(if available) from the current style sheet applied to the
document. To apply a class to the selected text just click on that Class tag.
Advanced Properties allows you to use the Advanced Property editor for
adding HTML attributes and Javascript to objects such as tables, images, links,
etc. See the section, Advanced Property Editor, for details.

[ Return to beginning of section ]

Using Style Sheets for Your Web Pages

Using Cascade Style Sheets

Cascade Style Sheets(CSS) can be used to style an HTML document in three ways:

Using inline styles.1.
Using internal style sheet.2.
Using external style sheets.3.

Nvu has an inbuilt style sheet editor called CaScadeS. CaScadeS can be used to produce 
either an internal style sheet or an external one. As opposed to inline styles, internal or
external style sheets help to keep the content and style information separate.

To style the html document you are editing, CaScadeS can be started by clicking on Tools
and choosing CSS Editor. CaScadeS allows two modes of style sheet editing:

Beginner Mode: This mode allows to create rules associated to class selectors
or type element selectors.

1.

Expert Mode: This mode allows to create rules without any restriction.2.

In case there is no style sheet, a new style sheet will be automatically created.

[ Return to beginning of section ]

Creating Style Sheets with Nvu

Using CaScadeS, one can create either internal style sheets or external style sheets. To
create an internal style sheet:

Click on the Style elt. button
(Optional) Fill in Media list and Title information for the style sheet.

1.

Click on Create Stylesheet.2.

To create an external stylesheet:

Click on the Link elt. button1.
Fill in the URL of the stylesheet in the right pane. A new file will be created on the
local filesystem, if it doesnot already exist.

(Optional) Fill in Media list and Title informationfor the style sheet.

2.
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Check the "check to create alternate stylesheet" if this is an alternate one.3.

Tip: Always save the html document before attaching local style sheet. Also, save
document immediately before closing the CSS editor.

Tip: Use Refresh button in the left pane, if stylesheet is not immediately downloaded.

[ Return to beginning of section ]

Creating Rules for Stylesheets

After creating one or more stylesheets for the html document, rules can be created for each
stylesheet individually. To use a particular stylesheet for creating or modifying rules,
highlight the stylesheet in the left pane by clicking with left mouse button. The right pane will
show the detials of the stylesheet in the General Tab. To create new rules:

Click on the Rule button in the left pane.1.
Right pane shows options as to what kind of rule to create. Choose one of:

named style (enter class name below)
style applied to all elements of type (enter type below)
style applied to all elements matching the following selector

2.

Fill in the name of the rule.3.
Click on Create Style Rule button.4.

Rules can be defined using the styling tabs (Text, Background, Border, Box and Aural) in
the right pane. To see all the definitions of a style rule, highlight the rule in the left pane and
click on "General" tab in the right pane. The "General" tab shows all definitions currently
applied to the rule.

[ Return to beginning of section ]

Adding Tables to Your Web Page

Inserting a Table

Tables are useful for organizing text, pictures, and data into formatted rows and columns.
To insert a table:

Click to place the insertion point where you want the table to appear.1.

Click the Table button  on the Composition toolbar. The Insert Table dialog box
appears.

2.

Type the number of rows and columns you want.
(Optional) Enter a size for the table width, and select either percentage of
the window or pixels.

3.

Enter a number for the border thickness (in pixels); enter zero for no border.

Note: Nvu uses a red dotted line to indicate tables with a zero border; the dotted
line disappears when the page is viewed in a browser.

4.

To apply additional table attributes or JavaScript, click Advanced Edit to display the
Advanced Property Editor.

5.

Click OK to confirm your settings and view your new table.6.

To change additional properties for your new table, see Changing a Table's Properties.

Tip: To insert a table within a table, open the Insert menu and choose Table.
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[ Return to beginning of section ]

Changing a Table's Properties

This section describes how to modify properties that apply to an entire table as well as the
rows, columns, or individual cells within a table. If you are not currently viewing the Table
Properties dialog box, follow these steps:

Select the table, or click anywhere inside it.1.

Click the Table button  on the toolbar, or open the Table menu and choose Table
Properties. The Table Properties dialog box contains two tabs: Table and Cells.

2.

Click the Table tab to edit these properties:
Size: Use this to specify the number of rows and columns. Enter the width
of the table and then choose "% of window" or "pixels." If you specify width
as a percentage, the table's width changes whenever the Nvu window's or
browser window's width changes.
Borders and Spacing: Use this to specify, in pixels, the border line
width, the space between cells, and the cell padding (the space between the
contents of the cell and its border).

Note: Nvu uses a dotted outline to display tables with a zero border; the
dotted line disappears when the page is viewed in a browser.

Table Alignment: Use this to align the table within the page. Choose an
option from the drop-down list.
Caption: Choose the caption placement from the drop-down list.
Background Color: Use this to choose a color for the table background,
or leave it as transparent.

3.

To apply additional attributes or JavaScript events, click Advanced Edit to display
the Advanced Property Editor.

4.

Click Apply to preview your changes without closing the dialog box, or click OK to
confirm them.

5.

To view, change, or add properties for one or more cells:

Select the row, column, or cell, then open the Table menu and choose Table
Properties. The Table Properties dialog box appears.

1.

Click the Cells tab to edit the following properties:
Selection: Choose Cell, Row, or Column from the drop-down list. Click
Previous or Next to move through rows, columns, or cells.
Size: Type a number for Height and Width, and then choose "% of table" or
"pixels."
Content Alignment: Select a vertical and horizontal alignment type for
the text or data inside each cell.
Cell Style: Select Header from the drop-down list for column or row
headers (which centers and bolds the text in the cell); otherwise choose
Normal.
Text Wrap: Select "Don't wrap" from the drop-down list to keep text from
wrapping to the next line unless you insert a paragraph break. Otherwise,
choose Wrap.
Background Color: Select a color for the cell background or leave it as
transparent.

Note: To apply additional attributes or JavaScript events, click Advanced
Edit to display the Advanced Property Editor

2.

Click Apply to preview your changes without closing the dialog box, or click OK to
confirm them.

3.
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Tip: To change the text color or background color of one or more selected cells or the entire
table, select the cells or click anywhere in the table and then click the text color or
background color icon in the Format toolbar.

Tip: To change the color of cells to the color last used, select the cell, then press Shift and
click on the background color picker. This is useful when you want to use one color for
individual cells.

[ Return to beginning of section ]

Adding and Deleting Rows, Columns, and Cells

Nvu allows you to quickly add or delete one or more cells, columns, or rows in a table. In
addition, you can set options that allow you to maintain the original rectangular structure or
layout of the table while you perform editing tasks.

To add a cell, row, or column to your table:

Click inside the table where you want to add a cell (or cells).1.
Open the Table menu and then choose Insert.2.
Choose one of the cell groupings. (You can also insert a new table within a table
cell.)

3.

To delete a cell, row, or column:

Click a row, column, or cell to place the insertion point. Or, select neighboring cells
to delete more than one row at a time. To select neighboring cells, drag over the
cells you want to select. To select individual cells in a table, hold down the Ctrl key
(Windows, Linux or Unix) or the Command key (Mac OS) and click on the cells you
want to select.

1.

Open the Table menu and choose Delete.2.
Choose the item you want to delete.3.

To join (or merge) a cell with the cell on its right:

Click inside the cell on the left, open the Table menu, and choose Join with Cell to
the Right.

To join (or merge) adjacent cells:

Select adjacent cells by dragging over them.
Open the Table menu, and choose Join Selected Cells.

To split a joined cell back into two or more cells:

Click inside the joined cell, open the Table menu, and then choose Split Cell. Nvu
puts the entire contents of the joined cell into the first of the two cells.

Refer to Selecting Table Elements for information on how to select non-adjacent cells, rows,
and columns.

Changing the Default Table Editing Behavior

By default, when you delete one or more cells, Nvu preserves the table's structure by
adding cells at the end of a row, wherever needed. This allows you to delete one or more
cells but still maintain the table's original rectangular layout, or structure. Otherwise,
deleting cells can result in a table with empty spaces, or whose outline appears irregular
due to an uneven number of cells.

To change the default table editing behavior, begin from the Nvu window:
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Open the Edit menu (Mozilla menu on Mac OS X), choose Preferences, and then
choose Nvu.

1.

Under Table Editing, set the following preference:
Make sure that "Maintain table layout when inserting or deleting cells" is
checked to ensure that you don't get an irregularly shaped table.

2.

Click OK.3.

See also Setting General Nvu Preferences.

[ Return to beginning of section ]

Selecting Table Elements

You can use one of two ways to quickly select a table, cell, or group of cells:

Click in the table, open the Table menu, choose Select, and then choose an item
from the submenu. For example, to select a table, click anywhere inside the table,
open the Table menu, choose Select, and then choose Table.
Or, you can use the mouse as a selection tool:

To select a group of adjacent cells: click in a cell, and then drag to select the
cells you want. Drag the mouse left or right to select a row; up or down to
select a column.
To select non-adjacent cells: press Ctrl (Windows, Linux or Unix) or
Command (Mac OS) and then click inside a cell. Keep pressing Ctrl
(Windows, Linux or Unix) or Command (Mac OS) as you click to select
additional cells.
To extend a selection to include adjacent cells: click inside a cell and then
drag over additional cells to extend the selection.
To select one or more adjacent columns or rows: drag up or down to select
the first column or row, and then drag left or right to select additional
adjacent columns or rows. Press Shift and drag to the right to select an
entire row. Press Shift and drag up or down to select an entire column.

[ Return to beginning of section ]

Moving, Copying, and Deleting Tables

To move a table:

Click inside the table.1.
Open the Table menu, choose Select, and then choose Table.2.

To copy or move the table: Use the Edit menu's cut, copy, and paste options.
To delete the table: Open the Table menu again, choose Delete, and then choose
Table.

Converting Text into a Table

To convert text into a table:

Select the text that you want to convert into a table. Keep in mind that Nvu creates a
new table row for each paragraph in the selection.

1.

Open the Table menu and choose Create Table from Selection. You see the Convert
to Table dialog box.

2.

Choose the character Nvu uses to separate the selection into columns, or specify a
different character to use. If you choose Space as the separator for columns,
choose whether or not you want Nvu to ignore multiple space and treat them as one

3.
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space.
Leave "Delete separator character" checked to have Nvu remove the separator
character when it converts the text into a table. If you don't want Nvu to delete the
separator character, uncheck this option.

4.

Click OK.5.

Note: Text formatting is removed when the selected text is converted to a table.

[ Return to beginning of section ]

Adding Pictures (Images) to Your Web Page

Inserting an Image into Your Page

You can insert GIF, JPEG, BMP, and PNG (Portable Network Graphics) images into your
web page. You can also use them to create links. When you insert an image, Nvu saves a
reference to the image in your page.

Note: If you plan to publish your pages to the web, it's best not to use BMP images in your
pages.

Tip: It's best to first save or publish your page before you insert images into it. This allows
Nvu to automatically use relative references to images once you insert them.

To insert an image:

Click to place the insertion point where you want the image to appear.1.

Click the Image button  on the toolbar, or open the Insert menu and choose
Image. You see the Image Properties dialog box.

2.

Type the location and filename of the image file, or click Choose File to search for an
image file on your hard drive or network.

3.

Type a simple description of your image as the alternate text that will appear in
text-only browsers (as well as other browsers) when an image is loading or when
image loading is disabled.

Alternatively, you can choose not to include alternate text.

4.

If needed, click other tabs so you can adjust the settings (for example, alignment) in
the Image Properties dialog box.

5.

Tip: To quickly insert an image: Drag and drop it onto your page.

Tip: To insert a line break after all images in a paragraph, choose Break Below Images from
the Insert menu.

[ Return to beginning of section ]

Editing Image Properties

Once you've inserted an image into your page, you can edit its properties and customize
the layout in your page, such as the height, width, spacing, and text alignment. If you are
not currently viewing the Image Properties dialog box, follow these steps:

To edit the properties for a selected image:

Double-click the image, or select it and click the Image button  on the toolbar to
display the Image Properties dialog box.

1.
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Click the Location tab to edit these properties:
Image Location: Type the filename and location of the image file. Click
Choose File to search for an image file on your hard drive or network.
URL is relative to page location: If checked, Nvu converts the URL
to be relative to the page's location. This is especially useful if you plan to
publish your pages on a web server so that others can view them. Using
relative URLs allows you to keep all your linked files in the same place
relative to each other, regardless of their location on your hard disk or a web
server.

Unchecking this box causes Nvu to convert the URL to a full (absolute) URL.
You typically use absolute URLs when linking to images on other web
servers (not stored locally on your hard disk).

If you have never saved or published the page, you must first save the page
in order to enable this checkbox. (This checkbox is not available if you open
the Image Properties dialog box in a message compose window.)

Alternate Text: Enter text that will display in place of the original image;
for example, a caption or a brief description of the image. It's a good practice
to specify alternate text for readers who use text-only web browsers or who
have image loading turned off.
Don't use alternate text: Choose this option if the image does not
require alternate text or if you don't want to include it.

2.

Click the Dimensions tab to edit these properties:
Actual Size: Select this option to undo any changes you've made to the
dimensions and return the image to its original size.
Custom Size: Select this option and specify the new height and width, in
pixels or as a percentage. This setting doesn't affect the original image file,
just the image inserted in your page.
Constrain: If you change the image size, it's a good idea to select this in
order to maintain the image's aspect ratio (so that it doesn't appear
distorted). If you choose this option, then you only need to change the
height or width, but not both.

3.

Click the Appearance Tab to edit these properties:
Spacing: Specify the amount of space surrounding the image; between the
image and adjoining text. You can also put a solid black border around the
image and specify its width in pixels. Specify zero for no border.
Align Text to Image: If you've placed your image next to any text, select
an alignment icon to indicate how you want text positioned relative to the
image.
Image Map: Click Remove to remove any image map settings.

4.

Click the Link tab to edit these properties:
Enter a web page location: If you want to define a link for this image,
enter the URL of a remote or local page, or select a named anchor or heading
from the drop-down list. Click Choose File to search for an image file on your
hard drive or network.
URL is relative to page location: If checked, Nvu converts the URL
to be relative to the page's location. This is especially useful if you plan to
publish your pages to a web server so that others can view them. Using
relative URLs allows you to keep all your linked files in the same place
relative to each other, regardless of their location on your hard disk or a web
server.

Unchecking this box causes Nvu to convert the URL to a full (absolute) URL.
You typically use absolute URLs when linking to images on other web
servers (not stored locally on your hard disk).

If you have unsaved changes, you must first save the page in order to
enable this checkbox. (This checkbox is not available if you open the Image
Properties dialog box in a message compose window.)

5.
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Show border around linked image: If checked, displays the link
highlight color around the image.

To apply additional attributes or JavaScript events, click Advanced Edit to display
the Advanced Property Editor.

6.

Click OK to confirm your changes.7.

[ Return to beginning of section ]

Working with Table of Contents on Your Web Page

Adding Table of Contents to Your Web Page

For an html document having different sections, e.g. an article with sections and
subsections and headings for each section and subsection, it becomes difficult to navigate
if all the text is in a single file. To enable easy navigation of different sections, a Table of
Contents (TOC) can be generated easily with Nvu. To generate a TOC for an html document:

Use the html heading tags (h1, h2, h3, h4, h5, and h6) to label different levels of
sections and subsections in the document. And save the document.

1.

Click on Insert > Table of Contents  and choose "Insert". The TOC window will
appear.

2.

Select the levels of headings used for differet sections and subsections in the
document.

3.

Click "OK" to build the TOC.4.

The TOC generated by default shows all entries as numbered and they are anchored links to
respective sections. Unchecking the "Number all entries in table of contents" checkbox
results in bulleted section entries. And checking "Make the table of contents read only"
results in sections being simple text without anchors.

[ Return to beginning of section ]

Updating or Removing Table of Contents

In case the document is changed to add more sections or subsections after building the
TOC, it will not contain the new sections or subsections. To add the newly added sections
and subsections, click on "Insert", then "Table of Contents" and choose "Update". The TOC
will be updated to show the new entries.

To remove the TOC altogether, click on "Insert", then "Table of Contents" and choose
"Remove". The TOC will be removed the html source will be cleaned automatically of any
code added when TOC built.

[ Return to beginning of section ]

Working With Templates

HTML templates are useful in cases where the author has to create several pages which
have similar design but different content. With Nvu you can design your own templates and
use them as a basis for your web pages.

Creating a Template

To create a template:
Click on File > New, or click on the arrow besides "New" button and select

1.
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"More Options"
Select Blank Template and click on "Create

Add and format the content which will remain the same in every page with same
methods used to edit normal text in a web page.

2.

For the content which will be different in the web pages, Editable Area can be
inserted by clicking on Insert > Templates > Editable Area. Options available for an
editable area are:

Area is Optional
Area is Repeatable
Area is Movable

3.

Save the file as an .mzt Template file.4.

Tip: You can Remove an editable area or make an area editable using the status bar. For
details refer Using Status Bar for Formatting Your Web Page.

[ Return to beginning of section ]

Using a Template

To use a Template for authoring web pages:

Click on File > Open or use keyboard shortcut "Ctrl+N"1.
Select the option "A New Document based on a Template" and choose the template
to use by clicking on "Choose File"

2.

Click on Create3.
Edit the content in the editable areas.4.
Save the file as an html document.5.

Tip: Click on Edit > Detach From Template to detach a document from its template.

Tip: Transformation of existing document into a template and vice-versa can be achieved
by checking(unchecking) the "Templates" option in Format > Page Title and Properties.

[ Return to beginning of section ]

Setting Page Properties

Setting Page Properties and Meta Tags

Use the Page Properties dialog box to enter properties such as the title, author, and
description of the document you're currently working on. This information is useful if you
plan to use the page on a web site, since search engines use this type of information to
index your page. You can view this information from the browser window by opening the
View menu and choosing Page Info.

Open the Format menu and choose Page Title and Properties.1.
Edit any of the following properties:2.

Title: Type the text you want to appear as the window title when someone
views the page through a browser. This is how most web search tools locate
web pages, so choose a title that conveys what your page is about.
Author: Type the name of the person who created the document. This
information is helpful to readers who locate the document by using a web
search tool to search on name.

Tip: If you enter the Author name in Nvu's preferences, then
you won't have to enter it each time you create a new page.

Description: Enter a brief description of the document's contents.
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[ Return to beginning of section ]

Setting Page Colors and Backgrounds

You can change the background color or specify a background image for the page you're
currently working on. These choices affect the way text and links in your page appear to
people viewing the page through a browser.

To set the colors and background for the current page, begin from the Nvu window:

Open the Format menu and choose Page Colors and Background.1.
Edit any of the following properties:2.

Reader's default colors: Select this if you want your page to use the 
color settings from the viewer's browser for text and links.
Use custom colors: Select this if you want to specify the colors of text
and links. For each element, select a color from the drop-down list. Sample
output for each type of link appears in the pane on the right.
Background image: Select this if you want the background of your page
to be an image. Type the name of the image file or click Choose File to locate
the image file on your hard drive or network.

Note: Background images are tiled and override background color
selections.

URL is relative to page location: If checked, Nvu converts the URL
to be relative to the page's location. This is especially useful if you plan to
publish your pages on a web server so that others can view them.

Using relative URLs allows you to keep all your linked files in the same place
relative to each other, regardless of their location on your hard disk or a web
server.

Deselecting this option causes Nvu to convert the URL to a full (absolute)
URL. You typically use absolute URLs when linking to images on other web
servers (not stored locally on your hard disk).

If you have unsaved changes, you must first save the page in order to
enable this checkbox.

Note: To apply additional attributes or JavaScript events, click Advanced Edit to display
the Advanced Property Editor.

You can also set the default page background and colors for every new page you create in 
Nvu.

[ Return to beginning of section ]

Creating Links in Nvu

Creating Links Within the Same Page

To create a link within the same page, for example a link that the reader can use to jump
from one section to another, you must create an anchor (target location), and then create a
link that points to the anchor. Anchors are also called named anchors.

Click to place the insertion point at the beginning of a line where you want to create
an anchor, or select some text.

1.
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Click on anchor button  or open the Insert menu and choose Named Anchor.
You see the Named Anchor Properties dialog box.

2.

Type a unique name for the anchor in the Anchor Name field (up to 30 characters). If
you include spaces, they will be converted to underscores ( _ ). If you selected
some text in step 1, this box already contains a name.

3.

Click OK. An anchor icon appears in your document to mark the anchor's location:4.

To create the link on which readers can click to jump to the anchor:

Select the text or image that you want to link to the anchor.1.
Click the Link button or open the Insert menu and choose Link. You see the Link
Properties dialog box.

If you're creating a link to an HTML file on your computer, click Choose File
to locate it.
If you're creating a link to a named anchor (target), select it from the list of
the anchors currently available in the page.
If you're creating a link to a level heading (for example, Heading 1 - Heading
6), select it from the list of headings currently available in the page.

2.

Click OK.3.

Note: To test the link you just created, open the File menu and choose Browse Page, then
click the link.

Tip: If you did not first create named anchors, you can use the Link dialog box to create
links to headings that already occur in the page.

[ Return to beginning of section ]

Creating Links to Other Pages

You can create links from your page to local pages on your own computer or on your
workplace's network, or to remote pages on the Internet.

Tip: It's best to first save or publish your page before you create links to other pages. This
allows Nvu to automatically use relative references for links once you create them.

To create a link to another page:

Click to place the insertion point where you want to create a link, or select the text or
image that you want to link to the anchor.

1.

Click the Link button. You see the Link Properties dialog box.2.
Define your link:

Link text: If you've already selected an image file or text before clicking
the Link button, the selected text or file will be entered here. Otherwise, you
must enter the text that you want to use as the link.
Link Location: Type the local path and filename or remote URL of the
page you want to link to. If you're not sure of the path and filename for a local
file, click Choose File to look for it on your hard disk or network. For remote
URLs, you can copy the URL from the browser location field. Alternatively,
you can select a named anchor or a heading in the current page that you
want to link to.
URL is relative to page location: If checked, Nvu converts the URL
to be relative to the page's location. This is especially useful if you plan to
publish your pages to a web server so that others can view them. Using
relative URLs allows you to keep all your linked files in the same place
relative to each other, regardless of their location on your hard disk or a web
server.

Deselecting this option causes Nvu to convert the URL to a full (absolute)

3.
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URL. You typically use absolute URLs when linking to pages on other web
servers (not stored locally on your hard disk).

If you have unsaved changes, you must first save the page in order to
enable this checkbox.

To apply additional attributes or JavaScript events, click Advanced Edit to display
the Advanced Property Editor.

4.

Click OK.5.
To test the link you just created, click the Browse button and then click the link to
make sure it works as expected.

6.

Tip: You can copy a link quickly by clicking and dragging the link from another window and
then dropping it onto your page. For example, you can click and drag a link from a web page,
bookmark, or Mail window and drop it onto your page. You can also right-click (Control+click
on Mac OS) a link on a web page and choose Copy Link Location from the menu. Then you
can paste the link location into the Link Location field in the Link Properties dialog box.

[ Return to beginning of section ]

Adding XFN Information Within Your Links

While creating links on your web page to other people's web pages, Nvu provides the
feature of including XFN (XHTML Friends Network) information. The XFN is a simple way to
represent human relationships using hyperlinks. To add XFN information:

Right click on the link in which you want to add the XFN information.1.
Select "Link Properties".2.
In the "Link Properties" dialog window, click on "More Properties".3.
Select the corresponding entries under "Friendship" section to be added as XFN
information.

4.

Click on "OK".5.
Click on "Save" to save changes/addition in document.6.

Note: Some XFN properties are radio-button type i.e. pick at most one, others are check
boxes i.e. pick as many.

[ Return to beginning of section ]

Using Images as Links

You can make images, such as JPEG, GIF, or PNG files, behave like links in your pages.
When the reader clicks a linked image, the browser window displays the page that the image
is linked to.

Select an image on your page.1.

Click the Link button  on the toolbar, or open the Insert menu and choose Link.2.
Use the Link Properties dialog box to link the image to a named anchor or heading
within the page, or to a separate local or remote page.

3.

Tip: Drag and drop a linked image from the Navigator window into a Nvu window to copy
both the image and the link.

Note: To remove the blue border on images used as links, open the Link Properties dialog
box, click the Link tab, and uncheck "Show border around linked image".

[ Return to beginning of section ]
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Removing or Discontinuing Links

To remove a link:

Select the linked text (normally blue and underlined) or image.1.
Open the Format menu and choose Remove Links.2.

To discontinue a link, so that text you type after the link is not included as part of the link:

Click to place the insertion point where you want the link to end.1.
Open the Format menu and choose Discontinue Link.2.

[ Return to beginning of section ]

Nvu Preferences

This section describes the settings in the Nvu preferences panel. If you are not currently
viewing the panel, follow these steps:

Open the Edit menu (Mozilla menu on Mac OS X) and choose Preferences.1.
Double-click the Nvu category to expand the list.2.

For information on Nvu's publishing settings, see Publishing Settings.

Nvu Preferences

Nvu preferences allow you to specify settings for saving files and for table editing. These
settings apply to every document you create.

If you are not already viewing the Nvu preferences, follow these steps:

Open the Edit menu (Mozilla menu on Mac OS X) and choose Preferences.1.
Click the Nvu category.2.

Maximum number of pages listed: Specify the maximum number of pages
that are listed under Recent Pages in the File menu.
Retain original source formatting: This option preserves line breaks and the
page's original formatting for the HTML source code. Select this if you want to
preserve white space (extra lines, tabs, etc.) that makes the HTML source code
more readable. This preference does not affect how your pages appear in a browser
window.
Reformat HTML source: This option reformats the HTML source code to make it
more readable, by inserting line breaks and indentation. This preference does not
affect how your pages appear in a browser window.
Save images and other associated files when saving pages: If 
checked, all images, JavaScript (JS), Cascading Style Sheet (CSS), and other
associated files are saved in the same location as the document when the
document is saved for the first time or when the document is saved to a new
location. If unchecked, only the HTML file is saved.

For example, when editing a remote page, this setting ensures that all related files
associated with the remote page will be saved locally when you save the page to
your hard disk.

Always show Publish dialog when publishing pages: If checked, Nvu
always displays the Publish Page dialog box when you click the Publish button or
choose Publish from the File menu. If not checked, Nvu only displays the Publish
Page dialog box if it needs more information in order to publish the page.
Maintain table layout when inserting or deleting cells: Select this if you 
want Nvu to always preserve the table's layout (that is, keep it in a rectangular
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shape) by adding cells where needed. If you deselect this option, when you delete
one or more cells, Nvu removes the cell border as well, which can result in a table
with empty spaces, or an outline that appears irregular due to an uneven number of
cells.
Use CSS styles instead of HTML elements and attributes: Enables the 
use of Cascading Style Sheet (CSS) formatting in your Nvu documents. With this
preference enabled, Nvu generates HTML 4.01 formatting with CSS inline styles for
elements.

If this preference is not enabled, Nvu generates HTML 4.01 formatting, but does not
use CSS styles.

Compared to HTML, HTML with CSS formatting is more portable, more maintainable,
and more compatible when viewed with different browsers. If you enable this
preference and then edit a document created without CSS, Nvu replaces the edited
elements with CSS styles.

If you enable CSS styles, you can choose a text highlight color for selected text
using the text highlight color button on the Format toolbar. You can also choose a
color background for any element on the page. (These features are not available if
this preference is not enabled.)

Always open a document in a new tab: Select this if you want to open
documents in new tabs when using the Site Manager. If unchecked, double clicking
on filenames in the Site Manager will open the files in new windows.

[ Return to beginning of section ]

Nvu Preferences - New Page Settings

New page preferences allow you to specify settings for colors and background images that
apply to every document you create.

If you are not already viewing the New Page Settings, follow these steps:

Open the Edit menu (Mozilla menu on Mac OS X) and choose Preferences.1.
Double-click the Nvu category and click New Page Settings.2.

Author: Enter your name. This will add your name to the HTML source code for
each new page you create.
Reader's default colors: Select this if you always want your pages to use the
color settings from the viewer's browser for text and link elements.
Use custom colors: Select this if you always want to specify the colors that are
applied to text and link elements. Then for each element, select a color by clicking
the color button next to each element.
Background image: Type the location and name of an image file, or click Choose
File to locate the image file on your hard disk or network.

Note: Background images are tiled and override background color.

To change the author name for an individual page: Open the Format menu and
choose Page Title and Properties.

To change the page colors and background image for an individual page: Open the
Format menu and choose Page Colors and Background.

Internationalization: Language: Choose the language in which the html
documentsupposed to be written in.

For example if the document is written in Canadian French, selecting
"French/Canada[fr-ca]" will indicate the browser that the document is written in
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Canadian French. And the html source will contain <html lang="fr-ca"> as an 
indicator of document language.

Internationalization: Writing Direction: Choose the direction of writing text
depending on the language you are using in your document. This solves the
problems of users creating html pages in languages with right-to-left direction, for
example, Arabic, Urdu, etc.

To change the Language specification for an individual page: Open the Format menu
and choose Page Title and Properties, and change language in the
Internationalization section.

To change the Writing Direction of an individual page: Open the Format menu and
choose Page Title and Properties, and change language in the Internationalization
section.

[ Return to beginning of section ]

Nvu Preferences - Advanced Settings (Connection)

This section describes how to use the Proxies preferences panel. If you're not already
viewing it, follow these steps:

Open the Edit menu (Nvu menu on Mac OS X) and choose Preferences.1.
Under the Advanced category, click Proxies. (If no subcategories are visible,
double-click Advanced to expand the list.)

2.

The Proxies preferences panel allows you to set up Nvu to use a proxy:

Before you start: Ask your network administrator if you have a proxy configuration file
or for the names and port numbers of the proxy.

Direct connection to the Internet: Choose this if you don't want to use a
proxy.
Manual proxy configuration: Choose this if you don't have a proxy location
(URL).

HTTP Proxy, SSL Proxy, FTP Proxy, Gopher Proxy: Type the 
name or numeric IP address of the proxy server. Type the port in the Ports
field.
SOCKS Host: Type the name or numeric IP address of the proxy server.
Type the port in the Ports field.

SOCKS v4, SOCKS v5: When entering a SOCK Host, select
"SOCKS v4" or "SOCKS v5," depending on what version of SOCKS is
used for the proxy.

No Proxy for: Type the domains and/or IP address that you do not want to
use a proxy for. Separate each entry with a comma. (Example:
.yourcompany.com, .yourcompany.co.nz, 192.168.1.0/24)

Automatic proxy configuration URL: Choose this if you have a proxy
configuration file or URL, then type the configuration URL.

[ Return to beginning of section ]

Nvu Preferences - Advanced Settings (Return Key Behaviour)

The option "Return in a paragraph always creates new paragraph" defines the behaviour of
the return key. Choosing it creates a new paragraph if you hit the "Return" key while typing
in a paragraph. Without this option <br> tags are added for carriage returns.

[ Return to beginning of section ]
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Nvu Preferences - Advanced Settings (Real-time Spellcheck)

Checking the option "Underline misspelled words" will enable the real-time spell checker 
built into Nvu to underline misspelled words, thus giving the user a visual clue to recheck
the spellings.

[ Return to beginning of section ]

Nvu Preferences - Advanced Settings - (Special Characters)

This options allow the user to choose which special characters are coded as entities by
Nvu. Choose one of the option:

Only & < > ' and non-breakable whitespace
The above and Latin-1 letters
All characters having an entity equivalence in the HTML 4.0 specification
Use &#..; notation for all non-ASCII characters

[ Return to beginning of section ]
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