This document is highly enriched in hypertext links and was thought as a fully-searchable, self-contained, annotatable, offline manual (cf. Conventions Used in This Guide).

Given ImageJ’s heavy development this guide will always remain an unfinished draft and should be considered complementary to the remaining ImageJ documentation resources (cf. Getting Help). As such, all ImageJ users and developers are encouraged to contribute to future editions of this manual (see About This Guide).

The latest version of this document can always be obtained from http://imagej.nih.gov/ij/docs/user-guide.pdf. A HTML version is also available online at http://imagej.nih.gov/ij/docs/guide/ or as a downloadable ZIP archive.
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Release Notes For ImageJ 1.44</td>
<td>viii</td>
</tr>
<tr>
<td>Noteworthy</td>
<td>ix</td>
</tr>
<tr>
<td>Macro Listings</td>
<td>x</td>
</tr>
<tr>
<td>Conventions Used in This Guide</td>
<td>xi</td>
</tr>
<tr>
<td><strong>I Getting Started</strong></td>
<td></td>
</tr>
<tr>
<td>1 What is ImageJ?</td>
<td>1</td>
</tr>
<tr>
<td>2 Installation</td>
<td>1</td>
</tr>
<tr>
<td>3 Maintaining ImageJ</td>
<td>2</td>
</tr>
<tr>
<td>4 Getting Help</td>
<td>4</td>
</tr>
<tr>
<td><strong>II Working with ImageJ</strong></td>
<td></td>
</tr>
<tr>
<td>5 Shortcuts and Modifier Keys</td>
<td>6</td>
</tr>
<tr>
<td>6 Finding Commands</td>
<td>7</td>
</tr>
<tr>
<td>7 Undo and Redo</td>
<td>8</td>
</tr>
<tr>
<td>8 Image Types and Image Formats</td>
<td>8</td>
</tr>
<tr>
<td>9 Stacks, Virtual Stacks and Hyperstacks</td>
<td>11</td>
</tr>
<tr>
<td>10 Color Images</td>
<td>13</td>
</tr>
<tr>
<td>11 Selections</td>
<td>16</td>
</tr>
<tr>
<td>12 Settings and Preferences</td>
<td>18</td>
</tr>
<tr>
<td><strong>III Extending ImageJ</strong></td>
<td></td>
</tr>
<tr>
<td>13 Macros</td>
<td>20</td>
</tr>
<tr>
<td>14 Scripts</td>
<td>21</td>
</tr>
<tr>
<td>15 Plugins</td>
<td>22</td>
</tr>
</tbody>
</table>
## Import

23.6 Import  

## Close

23.7 Close [w]  
23.8 Close All  

## Save

23.9 Save [s]  
23.10 Save As  

## Revert

23.11 Revert [r]  

## Page Setup

23.12 Page Setup  

## Print

23.13 Print... [p]  
23.14 Quit  

## Edit

24 Edit  

24.1 Undo [z]  
24.2 Cut [x]  
24.3 Copy [c]  
24.4 Copy to System  
24.5 Paste [v]  
24.6 Paste Control...  
24.7 Clear  
24.8 Clear Outside  
24.9 Fill [f]  
24.10 Draw [d]  
24.11 Invert [I]  
24.12 Selection  
24.13 Options  

## Image

25 Image  

25.1 Type  
25.2 Adjust  
25.3 Show Info... [i]  
25.4 Properties... [P]  
25.5 Color  
25.6 Stacks  
25.7 Hyperstacks  
25.8 Crop [X]  
25.9 Duplicate... [D]  
25.10 Rename  
25.11 Scale... [E]  
25.12 Transform  
25.13 Zoom  
25.14 Overlay  
25.15 Lookup Tables  

## Process

26 Process  

26.1 Smooth [S]  

---

v
Summarized Release Notes For ImageJ 1.44

The TIFF reader displays detailed descriptions when ImageJ is in debug mode . . . 9
Command line scripts can now run ImageJ in batch mode . . . . . . . . . . . . . . 24
Added the Elliptical Selection Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . 29
Added support for measurement of reflex angles . . . . . . . . . . . . . . . . . . . . 32
Improved and redesigned Results table . . . . . . . . . . . . . . . . . . . . . . . . . 37
Overlays are preserved when saving in JPEG or PNG format . . . . . . . . . . . . 52
File►Save As►AVI... no longer caps the frame rate at 60 fps . . . . . . . . . . . . . 52
Improved FITS_Writer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
File►Revert now works with stacks and hyperstacks . . . . . . . . . . . . . . 53
Added the Edit►Selection►Fit Circle command . . . . . . . . . . . . . . . . . . . . 58
Added the Edit►Selection►To Bounding Box command . . . . . . . . . . . . . . . 62
Added the Edit►Selection►Line to Area command . . . . . . . . . . . . . . . . . . 62
Improved handling of DICOM images . . . . . . . . . . . . . . . . . . . . . . . . . 68
Improved Image►Adjust►Color Threshold... command . . . . . . . . . . . . . 76
Improved downsizing when using Image►Adjust►Size... and Image►Scale... [E] . 78
Image►Color►Merge Channels... now preserves LUTs and display ranges . . . . . 80
Improved Image►Stacks►Orthogonal Views [H] command . . . . . . . . . . . . 86
Image►Stacks►Z Project... now works with RGB hyperstacks . . . . . . . . . . . . 87
Image►Stacks►3D Project... now works with hyperstacks and 16/32-bit images . . 88
Improved Image►Stacks►Label... command . . . . . . . . . . . . . . . . . . . . . . 90
Added the Image►Stacks►Tools►Make Substack... command . . . . . . . . . . . . 92
Added the Image►Stacks►Tools►Grouped Z Project... command . . . . . . . . . 92
Added hyperstacks support to the Image►Duplicate... [D] command . . . . . . . 96
Added Undo support to the Image►Scale... [E] command . . . . . . . . . . . . . . 96
Improved Particle Analyzer with support for virtual stacks and RGB images . . . 131
Improved histograms displaying scaled LUTs . . . . . . . . . . . . . . . . . . . . . . 141
ImageJ’s CurveFitter now resolves 6 parameter user-defined equations . . . . . . 148
Added conjunction and exclusive disjunction operations to the ROI Manager . . 151
Compile and Run... adds the Bio-Formats plugin to the Java compiler’s classpath 161

This list is not extensive. Detailed release notes for version 1.44 are available on the ImageJ News web site: http://imagej.nih.gov/ij/notes.html.
Noteworthy

I  Frontmost Window and Windows Activation ............................ 6
II  Image Types: Lossy Compression and Metadata ........................... 11
III Opening Virtual Stacks by Drag & Drop ................................. 13
IV  Toggling Calibrated Units .................................................. 27
V  Opening files: File > Open, File > Import and Drag & Drop .......................... 43
VI  Reducing Memory Requirements When Importing Images ................. 46
VII Warning on JPEG compression ............................................. 50
VIII Drawing Lines Wider Than One–Pixel .................................. 57
IX  Transferring Selections Between Images .................................. 58
X  Converting Composite Selections ............................................ 60
XI  Applying Auto Brightness/Contrast to Entire Stacks ..................... 71
XII Brightness/Contrast of High Bit–Depth Images ........................ 71
XIII Display Range of DICOM Images ........................................ 74
XIV Embedding Color Annotations in Grayscale Images ................... 83
XV  Scrolling Zoomed Images ................................................... 98
XVI Working With HEX Colors ............................................... 100
XVII Creating Binary Masks ..................................................... 110
XVIII Global Calibrations ......................................................... 140
XIX Selecting Multiple ROIs in the ROI Manager ........................... 152
Macro Listings

1. Creating ‘MGB’ images ........................................... 16
2. Creating ‘MGB’ images with the Image Calculator... command. ........... 16
3. Ensuring specific settings at launch. .................................. 19
4. Customizing the Image Popup Menu. ............................... 36
5. Setting File > Open Samples for off-line usage. ....................... 43
6. Obtaining Histogram Lists ........................................ 142
7. Assigning Keyboard Shortcuts to ImageJ Tools ....................... 170
Conventions Used in This Guide

If you are reading this guide on a computer screen you will notice that internal document links are displayed in gray (e.g., Part IV, The ImageJ User Interface), while links to external URLs, such as the ImageJ website, http://imagej.nih.gov/ij/, are displayed in dark blue.

ImageJ commands are typed in sans serif typeface with respective shortcut keys flanked by square brackets (e.g.: Image\⊿Duplicate...[D]). As explained in Shortcuts and Modifier Keys this notation implies shift-modifiers (i.e., [D] means pressing \[Shift\][D], [d] only the D key) and assumes that Require control key for shortcuts in Edit\⊿Options\⊿Misc... is unchecked.

Useful tips and reminders are placed in ‘Noteworthy boxes’ numbered by upper case roman numerals (e.g., I on page 6). The full list of these informational notes is available on page ix.

Filenames, file extensions and directory names are indicated in italic, e.g., the /Applications/ImageJ/macros/ folder.

Macro functions and code snippets are typed in monospaced font, e.g., resetMinAndMax(). Scripts and macros (e.g., Creating ‘MGB’ images on page 16) are typeset with the same syntax markup provided by the The Fiji Script Editor (for syntax highlighting in ImageJ, see Jérôme Mutterer’s IJ_ED plugin). The full list of macro listings is available on page x.

Selected highlights of version 1.44 are listed on page ix and flagged with colored marginal notes. These should be interpreted as:

- **New in IJ 1.44**: A new feature implemented in ImageJ 1.44.
- **Improved in IJ 1.44**: A routine that has been improved since previous versions. Typically, a faster or more precise algorithm, a command with better usability, or a task that has been extended to more image types.
- **Changed in IJ 1.44**: A pre-existing command that has been renamed or moved to a different menu location in ImageJ 1.44.
Part I

Getting Started

1 What is ImageJ?

ImageJ is a public domain Java image processing and analysis program inspired by NIH Image for the Macintosh. It runs, either as an online applet or as a downloadable application, on any computer with a Java 1.5 or later virtual machine. Downloadable distributions are available for Windows, Mac OSX and Linux. It can display, edit, analyze, process, save and print 8-bit, 16-bit and 32-bit images. It can read many image formats including TIFF, GIF, JPEG, BMP, DICOM, FITS and ‘raw’. It supports ‘stacks’ (and hyperstacks), a series of images that share a single window. It is multithreaded, so time-consuming operations such as image file reading can be performed in parallel with other operations.

It can calculate area and pixel value statistics of user-defined selections. It can measure distances and angles. It can create density histograms and line profile plots. It supports standard image processing functions such as contrast manipulation, sharpening, smoothing, edge detection and median filtering.

It does geometric transformations such as scaling, rotation and flips. Image can be zoomed up to 32:1 and down to 1:32. All analysis and processing functions are available at any magnification factor. The program supports any number of windows (images) simultaneously, limited only by available memory.

Spatial calibration is available to provide real world dimensional measurements in units such as millimeters. Density or gray scale calibration is also available.

ImageJ was designed with an open architecture that provides extensibility via Java plugins. Custom acquisition, analysis and processing plugins can be developed using ImageJ’s built in editor and Java compiler. User-written plugins make it possible to solve almost any image processing or analysis problem.

ImageJ is being developed on Mac OSX using its built in editor and Java compiler, plus the BBEdit editor and the Ant build tool. The source code is freely available. The author, Wayne Rasband (wsr@nih.gov), is a Special Volunteer at the National Institute of Mental Health, Bethesda, Maryland, USA.

2 Installation

Detailed information for Linux, Mac OS X, Mac OS 9 and Windows installation of ImageJ is available at http://imagej.nih.gov/ij/docs/install/index.html. Specially useful are the
platform-specific Troubleshooting and Known Problems sections. This web page can also be opened using the Help ⊿ Installation... command.

Other software packages based on ImageJ:

**Fiji**

Fiji (Fiji Is Just ImageJ) was presented publicly for the first time on the ImageJ User and Developer Conference in November 2008. Fiji targets image registration, stitching, segmentation, feature extraction and 3D visualization, among others. It also supports many scripting languages (BeanScript, Clojure, Jython, Python, Ruby). For users, Fiji is easy to install and update, bundles a set of plugins in a coherent menu structure, bundles a Java runtime and Java3D, and has a lot of comprehensive documentation. For developers, Fiji has these benefits: it comes with the complete source, it is properly version controlled, it bundles many useful libraries and it has a comprehensive build system.

**µManager**

µManager is a software package for control of automated microscopes. It lets you execute common microscope image acquisition strategies such as time-lapses, multi-channel imaging, z-stacks, and combinations thereof. µManager works with microscopes from all four major manufacturers, most scientific-grade cameras and many peripherals used in microscope imaging.

**SalsaJ**

SalsaJ is a software dedicated to image handling and analysis in the classroom. It is particularly adapted to professional astronomy images.

**Bio7**

Bio7 is an integrated development environment for ecological modeling with a main focus on individual based modeling and spatially explicit models.

## 3 Maintaining ImageJ

Once installed, updating ImageJ consists only of downloading the latest ij.jar file. This file is installed in the ImageJ folder (on Linux and Windows) or inside the ImageJ.app (on Mac OS X). The easiest to perform this task is to use the built in command Help ⊿ Update ImageJ... Note that the installation packages may not contain the latest bug fixes so straight after a first installation it is recommended to upgrade the ij.jar file.

### Releases and Updates

As mentioned, the Help ⊿ Update ImageJ... command can be used to upgrade (or downgrade) the ij.jar file to other versions, including release updates and daily builds. Release updates are announced frequently and are labeled alphabetically (e.g., v.1.43m). Typically, these releases contain several new features and bug fixes, described in detail on the top of ImageJ News page. Daily builds, on the other hand, are labeled
with numeric sub-indexes (e.g., v.1.43n4) and are often released without documentation. Nevertheless, if available, release notes for daily builds can be found at http://imagej.nih.gov/ij/source/release-notes.html.

When a release cycle ends (v.1.42 ended with 1.42q, v.1.43 with 1.43u, etc.) an installation package is created, downloadable from http://imagej.nih.gov/ij/download.html. Typically, this package bundles a selected list of add-ons (macros, tools, toolsets, scripts and plugins).

Running Help ▼ Update ImageJ..., however, will not update any of the plugins you may have installed\(^1\). Plugins are add-ons that extend ImageJ’s functionality beyond its basic core (cf. Plugins). The 500+ freely available plugins (the official distribution of ImageJ contains only a subset) from independent contributors around the world plays a pivotal role in ImageJ’s success [60].

You can obtain and know more about plugins on ImageJ’s plugins page (Help ▼ Plugins...), ImageJ Information and Documentation Portal, and in all the sites listed on the bottom of ImageJ’s plugins page (http://imagej.nih.gov/ij/plugins/#more). In addition, two ImageJ distributions can also be obtained with a pre-organized collection of plugins.

### ImageJ Distributions

**Fiji**

As mentioned earlier, Fiji is distributed with several plugins and libraries that greatly simplify the use of ImageJ. Furthermore, Fiji ships with a built in convenient updater that knows whether your files are up-to-date, obsolete or locally modified.

**MBF ImageJ**

The MBF ImageJ bundle — also known as ImageJ for Microscopy — is maintained by Tony Collins at MacBiophotonics, McMaster University. This bundle features a vast collection of plugins related to microscopy and is described in an extensively illustrated online manual.

Note that you can use multiple distributions simultaneously, assemble your own ImageJ bundle by gathering the plugins that best serve your needs (probably, someone else at your institute/university already started one?) or create symbolic links to share plugins between different ‘ImageJs’.

**See also:** *Luts, Macros and Tools Updater*, a macro toolset that performs live-updating of macros listed on the ImageJ web site (http://imagej.nih.gov/ij/macros/)

---

\(^1\)Certain plugins, however, provide self-updating mechanisms (e.g., ObjectJ and the LOCI Bio-Formats library).
4 Getting Help

Below is a list of the ImageJ help resources. Specific documentation on advanced uses of ImageJ (macro programming, plugin development, etc.) is discussed in Extending ImageJ.

1. The ImageJ online documentation
   Can be accessed via the Help ▶ Documentation... command.

2. The ImageJ Information and Documentation Portal (ImageJ wiki):

3. The Fiji webpage:

4. The ImageJ for Microscopy manual
   [http://www.macbiophotonics.ca/imagej/](http://www.macbiophotonics.ca/imagej/)

5. Several online documents, most of them listed at:

6. Video tutorials on the ImageJ Documentation Portal and the Fiji YouTube channel:
   [http://www.youtube.com/user/fijichannel](http://www.youtube.com/user/fijichannel)

7. Mailing lists:
   (a) **ImageJ** — [http://imagej.nih.gov/ij/list.html](http://imagej.nih.gov/ij/list.html)
       General user and developer discussion about ImageJ. Can be accessed via the Help ▶ List Archives... command. This list is also mirrored at Nabble and Gmane. You may find it easier to search and browse the list archives on these mirrors. Specially useful are the RSS feeds and the ‘frames and threads’ view provided by Gmane.

   (b) **Fiji users** — [http://groups.google.com/group/fiji-users](http://groups.google.com/group/fiji-users)
       General Fiji user discussion.

   (c) **IJ Macro Support Group** — [http://listes.inra.fr/wws/info/imagejmacro](http://listes.inra.fr/wws/info/imagejmacro)
       The ImageJ macro support group connects a network of ImageJ users who are specifically interested in improving their skills in writing macros and plugins for ImageJ. The membership base includes experienced programmers, and new users who are interested in learning to write their very first macros.

   (d) **Fiji developers** — [http://groups.google.com/group/fiji-devel](http://groups.google.com/group/fiji-devel)
       Fiji developer discussion.

   (e) **ImageJX** — [http://groups.google.com/group/imagejx](http://groups.google.com/group/imagejx)
       Highly technical developer discussion about ImageJ future directions.

   (f) **ImageJDev** — [http://imagejdev.org/mailman/listinfo/imagej-devel](http://imagejdev.org/mailman/listinfo/imagej-devel)
       For communication and coordination of the ImageJDev project.
Using Mailing-lists

If you are having problems with ImageJ, you should inquiry about them in the appropriate list. The ImageJ mailing list is an unmoderated forum subscribed by a knowledgeable worldwide user community with ≈2000 advanced users and developers. To have your questions promptly answered you should consider the following:

1. Read the documentation files (described earlier in this section) before posting. Because there will always be a natural lag between the implementation of key features and their documentation it may be wise to check briefly the ImageJ news website (Help ⊘ ImageJ News...).

2. Look up the mailing list archives (Help ⊘ List Archives...). Most of your questions may already been answered.

3. If you think you are facing a bug try to upgrade to the latest version of ImageJ (Help ⊘ Update ImageJ...). You should also check if you are running the latest version of the Java Virtual Machine for your operating system. Detailed instructions on how to submit a bug report are found at http://imagej.nih.gov/ij/docs/faqs.html#bug.

4. Remember that in most cases you can find answers within your own ImageJ installation without even connecting to the internet since the heuristics for finding commands or writing macros have been significantly improved in later versions (see Finding Commands and Extending ImageJ).

5. As with any other mailing list, you should always follow basic netiquette, namely:

   (a) USE DESCRIPTIVE SUBJECT LINES – Re: Problem with Image > Set Scale command is much more effective than a general Re: Problem.

   (b) STAY ON TOPIC – Do not post off-topic messages, unrelated to the message thread.

   (c) BE CAREFUL WHEN SENDING ATTACHMENTS – Refrain from attaching large files. Use, e.g., a file hosting service instead.

   (d) EDIT REPLIES – You should include only the minimum content that is necessary to provide a logical flow from the question to the answer, i.e., quote only as much as absolutely necessary and relevant.
Part II

Working with ImageJ

For a detailed description of all ImageJ menus and toolbar buttons (most are self-explanatory), have a look at The ImageJ User Interface and ImageJ Commands.

5 Shortcuts and Modifier Keys

There are three modifier keys in ImageJ:

**Control** (Command Key on Apple keyboards) Denoted by ‘Ctrl’ or [Ctrl] in this document. Although a control key is typically present on Apple keyboards, on a Macintosh computer running ImageJ the Command key [Cmd] replaces the functionality of the control key of other operating systems. For sake of simplification, ‘Ctrl’ will always refer to both throughout this guide.

**Shift** Denoted by ‘Shift’ or [Shift] in this document.

**Alt** Denoted by ‘Alt’ or [Alt] in this document. This is also the ‘Option’ or ‘Meta’ key on many keyboards.

You’ll learn more and more shortcut keys as you use ImageJ, because (almost) all shortcuts are listed throughout ImageJ menus. Similarly, in this guide each command has its shortcut key listed on its name (flanked by square brackets). Please note that the notation for these key-bindings is case sensitive, i.e., shift-modifiers are not explicitly mentioned (a capital A means Shift–A) and assumes that Require control key for shortcuts in Edit>Options>Misc... is unchecked (i.e., except when using The ImageJ Editor, you won’t have to hold down the Control key to use menu shortcuts). For example, the command Edit>Invert [I] can be evoked by [Shift] I or [Ctrl] Shift I if Require control key for shortcuts is checked. The full list of ImageJ shortcuts (see Keyboard Shortcuts) can be retrieved at any time using the Plugins>Utilities>List Shortcuts... command.

I Frontmost Window and Windows Activation

In ImageJ, all operations are performed on the active (frontmost) image (which has its title bar highlighted). If a window is already open it will activate when its opening command is re-run, e.g., if the B&C window is already opened, pressing its keyboard shortcut ([Shift] C) will activate it. In addition, pressing [Enter] on any image will bring the ImageJ window to the foreground.
6 Finding Commands

There are two expedite ways of finding your way through the extensive list of ImageJ commands, macros and plugins: Plugins>Utilities>Find Commands... [l] and Plugins>Utilities>Search...

![Finding Commands Image](image)

Command Finder

The quickest way to find a command without having to navigate through all the menus is using the built-in Command Finder [1]: Plugins>Utilities>Find Commands... [l] command.

Evoke the prompt by pressing Enter (as in ‘command Launcher’, ‘Locator’ or ‘List’). If you type part of a command name, the list will only show commands that match that substring. If only a single command matches then that command can be run by pressing Enter. If multiple commands match, click with the mouse to select a command to run. Alternatively pressing the up or down keys will move keyboard focus to the list and the selected command can be run by pressing Enter. Pressing Backspace switches focus back to the prompt. Double-clicking on a command will run that command. Pressing Esc closes the window.

If Show full information is checked the Command Finder will display in which menu (or .jar file) the listed command is located.
Search Command

Plugins▷Utilities▷Search... searches recursively for a particular string (case sensitive or not) contained in the file names or file contents in a chosen folder or in ImageJ/macros folder if Search Macros Folder is checked.

Since most macros (.txt, .ijm), scripts (.js) and plugins source (.java) files contain circumstance information as commented code, you can use this utility to retrieve files not only related to a image processing routine (e.g., background or co-localization) but also topics related to a certain scientific context such as radiogram, cell or histology. Indeed, ImageJ source files contain detailed annotations useful to both developers and regular users that want to know more about ImageJ routines and algorithms.

The results are displayed in the Log window. If the Search Contents option is checked, the line number where the string was found is displayed. In the Log window, double click on a file path to open that file in an editor window. There is an option to search the macros folder and also an option to search the ImageJ source code if it has been downloaded (from imagej.nih.gov/ij/download/src/) and extracted into the ImageJ folder. This command runs the macro Search in ij.jar.

See also: Control Panel... [U], Keyboard Shortcuts and SourceCode Retriever, a macro that searches for a menu entry and tries to retrieve the java source file of the respective plugin

7 Undo and Redo

Probably the first thing you will notice is that ImageJ does not have a undo/redo buffer. Undo (Edit▷Undo [z]) is currently limited to the most recent image editing/filtering operation. With time you will appreciate that this is necessary to minimize memory overhead. If you cannot recover from a mistake, you can always use File▷Revert [r] to reset the image lo its last saved state. For selections, Edit▷Selection▷Restore Selection [E] can be used to recover any misdealt selection.

In ImageJ the equivalent to ‘Redo’ is the Process▷Repeat Command [R], that re-runs the previous used command (skipping Edit▷Undo [z] and File▷Open... commands).

See also: Plugins▷Utilities▷Reset..., Multi Undo plugin

8 Image Types and Image Formats

Digital Images are two-dimensional grids of pixel intensities values with the width and height of the image being defined by the number of pixels in x (rows) and y (columns)
direction. Thus, pixels (picture elements) are the smallest single components of images, holding numeric values – pixel intensities – that range between black and white. The characteristics of this range, i.e., the number of unique intensity (brightness) values that can exist in the image is defined as the bit-depth of the image and specifies the level of precision in which intensities are coded, e.g.: A 2–bit image has \(2^2 = 4\) tones: 00 (black), 01 (gray), 10 (gray), and 11 (white). A 4–bit image has \(2^4 = 16\) tones ranging from 0000 (0) to 1111 (16), etc. In terms of bits per pixel (bpp), the most frequent types of images that ImageJ deals with are:

- **8–bit** Images that can display 256 \((2^8)\) gray levels.
- **16–bit** Images that can display \((2^{16})\) 65,536 gray levels.
- **32–bit** Images that can display \((2^{32})\) 4,294,967,296 gray levels. These are floating point grayscale images. In computing, floating point describes a system for representing numbers that would be too large or too small to be represented as integers. Indeed, in 32–bit images a pixel can have ANY intensity value including NaN (Not a Number).

**RGB Color** Images that can display 256 values in the Red, Green and Blue channel. These are 24–bit \((2^{24})\) images. RGB color images can also be 32–bit color images (24–bit color images with additional eight bits coding alpha blending values, i.e., transparency).

**Native Formats**

Natively (i.e. without the need of third-party plugins) ImageJ opens the following formats: TIFF, GIF, JPEG, PNG, DICOM, BMP, PGM and FITS. Many more formats are supported with the aid of plugins. These are discussed in Non–native Formats.

**TIFF** (Tagged Image File Format) is the ‘default’ format of ImageJ (cf. File > Save [s], II). Images can be 1–bit, 8–bits, 16–bits (unsigned\(^1\)), 32–bit (real) or RGB color. TIFF files with multiple images of the same type and size open as a stack. Tiff tags and information needed to import the file (number of images, offset to first images, gap between images) are printed to the log window when ImageJ is running in Debug Mode (Edit > Options > Misc. . . , see Settings and Preferences). ImageJ opens LZW and PackBits compressed TIFF files. In addition, TIFF files can be opened and saved as ZIP archives.

\(^1\)A numeric variable is signed if it can represent both positive and negative numbers, and unsigned if it can only represent positive numbers.
DICOM (Digital Imaging and Communications in Medicine) is a standard popular in the medical imaging community. Support in ImageJ is limited to uncompressed DICOM files. DICOM files containing multiple images open as a stack. Use \texttt{Image} \texttt{Show Info... [i]} to display the DICOM header information. A DICOM sequence can be opened using \texttt{File} \texttt{Import} \texttt{Image Sequence...} or by dragging and dropping the folder on the ‘ImageJ’ window. Imported sequences are sorted by image number instead of filename and the tags are preserved when DICOM images are saved in TIFF format. ImageJ supports custom DICOM dictionaries, such as the one at http://imagej.nih.gov/ij/download/docs/DICOM_Dictionary.txt. More information can be found here.

FITS (Flexible Image Transport System) image is the format adopted by the astronomical community for data interchange and archival storage. Use \texttt{Image} \texttt{Show Info... [i]} to display the FITS header. More information here.

PGM (Portable GrayMap), PBM (Portable Bitmap) and PPM (Portable PixMap) are simple image formats that use an ASCII header. More information here.

AVI (Audio Video Interleave) is a container format which can contain data encoded in many different ways. ImageJ only supports uncompressed AVIs, various YUV 4:2:2 compressed formats, and PNG or JPEG-encoded individual frames. Note that most MJPG (motion-JPEG) formats are not read correctly. Attempts to open AVIs in other formats will fail.

See also: Non–native Formats, II, VII

Non–native Formats

When opening a file, ImageJ first checks whether it can natively handle the format. If ImageJ does not recognize the type of file it calls for the appropriate reader plugin using \texttt{HandleExtraFileTypes}, a plugin bundled with ImageJ. If that fails, it tries to open the file using the LOCI Bio-Formats library (if present), a remarkable plugin that supports around eighty of the most common file formats used in microscopy. If nevertheless the file cannot be opened, an error message is displayed. Because both these plugins are under active development, it is important that you keep them updated.

In addition and as of this writing, the ImageJ web site lists more than fifty plugins that recognize more ‘exotic’ file formats. The ImageJ Documentation Portal maintains a list of file formats that are supported by ImageJ.

See also: Native Formats, \texttt{File} \texttt{Import...}, II, VII, Acquisition plugins, Input/Output plugins
II  IMAGE TYPES: LOSSY COMPRESSION AND METADATA

Two critical aspects to keep in mind when converting images:

Lossy compression Transcoding an image into a format that uses lossy compression will alter the original data, introducing artifacts (see VII). This is the case, e.g., for JPEG formats (with the exception of some JPEG2000 images that use lossless compression). As such, these types of data are intended for human interpretation only and are not suitable for quantitative analyses.

Metadata In ImageJ, metadata associated with the image, such as scale, gray value calibration and user comments is only supported in tiff and zip (compressed tiff) images. In addition, with IJ 1.43 and later, selections and overlays are also saved in the TIFF header (cf. File ➤ Save [s]). None of the above is saved in other formats (cf. Native Formats).

9  Stacks, Virtual Stacks and Hyperstacks

Stacks

ImageJ can display multiple spatially or temporally related images in a single window. These image sets are called stacks. The images that make up a stack are called slices. In stacks, a pixel (which represents 2D image data in a bitmap image) becomes a voxel (volumetric pixel), i.e., an intensity value on a regular grid in a three dimensional space. All the slices in a stack must be the same size and bit depth. A scrollbar provides the ability to move through the slices and, in ImageJ 1.43, the slider is preceded by a play/pause icon that can be used to start/stop stack animation. Right-clicking on this icon runs the Animation Options… [Alt /] dialog box.

Most ImageJ filters will, as an option, process all the slices in a stack. ImageJ opens multi-image TIFF files as a stack, and saves stacks as multi-image TIFFs. The File ➤ Import ➤ Raw… command opens other multi-image, uncompressed files. A folder of images can be opened as a stack either by dragging and dropping the folder onto the ‘ImageJ’ window or by choosing File ➤ Import ➤ Image Sequence… To create a new stack, simply choose File ➤ New ➤ Image… [n] and set the Slices field to a value greater than one. The Image ➤ Stacks ➤ submenu contains commands for common stack operations.

Virtual Stacks

Virtual stacks are disk resident (as opposed to RAM resident) and are the only way to load image sequences that do not fit in RAM. There are several things to keep in mind when working with virtual stacks:
Stacks and Hyperstacks in ImageJ: File → Open Samples → Mitosis (26MB, 5D stack). Hyperstacks dimensionality can be reduced using the Image → Hyperstacks → Reduce Dimensionality…, Image → Stacks → Z Project… or Image → Hyperstacks → Channels… [Z] commands. The ‘(V)’ on the window titles denotes a virtual image (see Virtual Stacks).

- Virtual stacks are read-only, so changes made to the pixel data are not saved when you switch to a different slice. You can work around this by using macros (e.g., Process Virtual Stack) or the Process → Batch → Virtual Stack… command implemented in ImageJ 1.43.

- You can easily run out of memory using commands like Image → Crop [X] because any stack generated from commands that do not generate virtual stacks will be RAM resident.

- TIFF virtual stacks can usually be accessed faster than JPEG virtual stacks. A JPEG sequence can be converted to TIFF by opening the JPEG images as a virtual stack and using File → Save As → Image Sequence… to save in TIFF format.

ImageJ appends a ‘(V)’ to the window title of virtual stacks and hyperstacks (see Hyperstacks). Several built-in ImageJ commands in the File → Import → submenu have the ability to open virtual stacks, namely: TIFF Virtual Stack…, Image Sequence…, Raw…, Stack From List…, AVI… (cf. Virtual Stack Opener). In addition, since ImageJ 1.43, TIFF stacks with a .tif extension open as virtual stacks when dragged and dropped on the toolbar icon (cf. III).

See also: Image5D, LOCI Bio-Formats and RegisterVirtualStackSlices plugins, Process Virtual Stack and VirtualStackFromList macros.
III Opening Virtual Stacks by Drag & Drop

In ImageJ 1.43 and later TIFF stacks with a .tif extension open as virtual stacks when dragged and dropped on the toolbar icon.

Hyperstacks

Hyperstacks are multidimensional images, extending image stacks to four (4D) or five (5D) dimensions: x (width), y (height), z (slices), c (channels or wavelengths) and t (time frames). Hyperstacks are displayed in a window with three labeled scrollbars (see Stacks and Hyperstacks). Similarly to the scrollbar in Stacks, the frame slider (t) has a play/pause icon.

See also: Image ▶ Hyperstacks ▶ submenu

10 Color Images

ImageJ deals with color mainly in three ways: pseudocolor images, RGB images, RGB/HSB stacks, and composite images.

Pseudocolor images

A pseudocolor (or indexed color) image is a single channel gray image (8, 16, 32–bit) that has color assigned to it via a ‘lookup table’ or LUT. This is literally a table of gray values with matching red, green and blue values. So instead of displaying a shadow of gray, the image displays a pixel with a defined amount of each color. Differences in color in the pseudo-colored image reflect differences in intensity of the object rather than differences in color of the specimen that has been imaged.

See also: Image ▶ Lookup Tables ▶ submenu

1This section is partially extracted from the MBF ImageJ online manual at http://www.macbiophotonics.ca/imagej/colour_image_processi.htm.
True color images

As described in Image Types and Image Formats, true color images such as RGB images reflect genuine colors, i.e., the green in an RGB image reflects green color in the specimen. Color images are typically produced by color CCD cameras, in which color filter arrays (Bayer mask) are placed over the image sensor.

Color Spaces and Color Separation

Color spaces describe the gamut of colors that image-handling devices deal with. RGB is the most commonly-used color space. However, processing color information stored in the form of RGB images may not be the most efficient method. There can be significant advantages in processing colors stored in other formats, such as HSB (Hue, Saturation, Brightness)\(^1\).

In the HSB color space, \textit{Hue} describes the attribute of pure color, and therefore distinguishes between colors. \textit{Saturation} characterizes the shade of color, i.e., how much white is added to the pure color. \textit{Brightness} (also know as \textit{Value} – HSV system – or \textit{Lightness} – HSL systems) describes the overall brightness of the color. In terms of digital imaging processing, using the HSB system over the traditional RGB system may be advantageous. E.g., since the Brightness component of an HSB image corresponds to the grayscale version of that image, processing only the brightness channel in routines that require grayscale images is a significant computational gain. You can read more about the HSB color model here.

In ImageJ, conversions between image types are performed using the Image $\Rightarrow$ Type $\Rightarrow$ sub-menu. In addition, the Color Threshold... command implemented in version 1.43 performs segmentation on the HSB, RGB, CIELab and YUV color spaces. Several other plugins related to color processing can be obtained from the ImageJ website.

Conveying Color Information\(^2\)

People see color with significant variations. Indeed, the popular phrase “One picture is worth ten thousand words” may not apply to certain color images, specially those that do not follow the basic principles of Color Universal Design. Citing Masataka Okabe and Kei Ito from the Color Universal Design Organization in Japan:

> Colorblind people can recognize a wide ranges of colors. But certain ranges of colors are hard to distinguish. The frequency of colorblindness is


\(^2\)This section is partially extracted from Masataka Okabe and Kei Ito, \textit{Color Universal Design (CUD) — How to make figures and presentations that are friendly to Colorblind people}, http://jfly.iam.u-tokyo.ac.jp/color/, accessed 2009.01.15
fairly high. One in 12 Caucasian (8%), one in 20 Asian (5%), and one in 25 African (4%) males are so-called ‘red–green’ colorblind.

There are always colorblind people among the audience and readers. There should be more than ten colorblind in a room with 250 people (assuming 50% male and 50% female).

[...] There is a good chance that the paper you submit may go to colorblind reviewers. Supposing that your paper will be reviewed by three white males (which is not unlikely considering the current population in science), the probability that at least one of them is colorblind is whopping 22%!

Red–green images and partial color blindness. Deuteranopia (second panel), protanopia (third panel) are the most common types of partial color blindness (red / green confusion). Tritanopia (blue / orange confusion, fourth panel) is quite rare. Substituting red with magenta (bottom row) is the simplest way to compensate for color vision deficiencies.

One practical point defined by the Color Universal Design is the use of magenta in red–green overlays. Magenta is the equal mixture of red and blue. Colorblind people that have difficulties recognizing the red component can easily recognize the blue hue. The region of double positive becomes white, which is easily distinguishable for colorblind.

In ImageJ, you can simulate color blindness on your images using the Vischeck plugin, or, in Fiji, using the Image > Color > Simulate Color Blindness command.

In ImageJ, RGB images can be easily converted to ‘MGB’ with a simple macro (cf. Extending ImageJ). One possibility of such a macro would make use of the Image > Color > Channels... [Z] tool to recolor the red channel.
Color Composites

In a composite image colors are handled through channels. The advantages with this type of image over plain RGB images are:

1. Each channel is kept separate from the others and can be turned on and off using the 'Channels' tool (Image > Color > Channels... [Z]). This feature allows, e.g., to perform measurements on a specific channel while visualizing multiple.
2. Channels can be 8, 16 or 32-bit and can be displayed with any lookup table
3. More than 3 channels can be merged or kept separate

11 Selections

Although ImageJ can display simultaneously several selections or regions of interest (ROIs), only one selection can be active at a time. Selections can be measured (Analyze >
Measure... [m]), drawn (Edit►Draw [d]), filled (Edit►Fill [f]) or filtered (Process►Filters►submenu), in the case of area selections. In addition, since ImageJ 1.43 it is also possible to create non-destructive image overlays (Image►Overlay►submenu).

Selections can be initially outlined in one of the nine ImageJ default colors (Red, Green, Blue, Magenta, Cyan, Yellow, Orange, Black and White). Once created, selections can be contoured or painted with any other color (cf. Edit►Selection►Properties... [y]). Selection Color can be changed in Edit►Options►Colors... or by double clicking on the Point Tool. It is highlighted in the center of the Point/Multi-point Tool (cf. The ImageJ window).

Three types of area selections In ImageJ. Notice the cursor changes: to an arrow when it is within the selection, to a cross-hair when outside the selection, to a hand when over a selection ‘handler’. Notice also the filled handler in the polygon selection and the absence of point handlers in Composite Selections.

Most of commands that can be useful in defining or drawing selections are available in the Edit►Selection►submenu. Listed below are the most frequent manipulations involving selections:

Deleting Choose any of the selection tools and click outside the selection, or use Edit►Selection►Select None [A]. Use Edit►Selection►Restore Selection [E] to restore a selection back after having deleted it.

Moving Selections can be moved by clicking and dragging as long as the cursor is within the selection and has changed to an ↳. The status bar displays the coordinates of the upper left corner of the selection (or the bounding rectangle for non-rectangular selections) as it is being moved. To move the contents of a selection, rather than the selection itself, Edit►Copy [c], Edit►Paste [v], and then click within the selection and drag.

Adjusting Area selections can be adjusted with the Brush Selection Tool. In addition, vertexes of polygon selections can be adjusted by Alt/Shift-clicking (cf. Polygon Selection Tool).

Nudging Selections can be ‘nudged’ one pixel at a time in any direction using the arrow keys

Managing A selection can be transferred from one image window to another by activating the destination window and using Edit►Selection►Restore Selection
Selections can be saved to disk using File $\rightarrow$ Save As $\rightarrow$ Selection... and restored using File $\rightarrow$ Open... Use the ROI Manager (Analyze $\rightarrow$ Tools $\rightarrow$ ROI Manager...) to work with multiple selections.

**Composite Selections**

Composite selections are non-contiguous ROIs containing more than one cluster of pixels and/or containing internal holes. Composite ROIs are typically originated with the Brush Selection Tool but they can be defined with any other selection tool using key modifiers.

The following modifier keys can be used to create composite selections:

- **Shift** Drawing outside current selection while pressing Shift creates new content. To add a non-square rectangle or ellipse, the Shift key must be released after adding the selection.

- **Alt** Drawing inside current selection while pressing Alt creates a hole removing content from ROI.

Note that some operations may not be performed properly on complex ROIs. In these cases, it may be useful to convert a composite ROI into a polygon using the Edit $\rightarrow$ Selection $\rightarrow$ Enlarge... command, see X.

**See also:** ROI2PolylineROI macro

## 12 Settings and Preferences

ImageJ preferences are automatically saved in a preferences file, the *IJ_prefs.txt* text file. This file is stored in the `~/Library/Preferences/` folder on Mac OS X, in the `~/imagej/` folder on Linux and in the ImageJ folder on Windows. Several macros and plugins also write parameters to this file. If the *IJ_prefs.txt* is erased, ImageJ creates a new one the next time it is opened resetting all parameters to their default values.

Sometimes, it may be useful to override (or restore) certain settings that may have been changed during a working session. For example, the Limit to threshold option (Analyze $\rightarrow$ Set Measurements...) will affect most measurements performed on thresholded images. Thus, it may be wise to check the status of this parameter before each analysis, specially when working on multiple computers.

The `setOption()` macro function can be used to set this and several other ImageJ options (cf. Built-in Macro Functions — `setOption()`). Calling this function from the “AutoRun” macro in the *StartupMacros.txt* file ensures preferences are set each time ImageJ starts.

So, e.g., to make sure that:
1. TIFF tag values are displayed by ImageJ (Debug Mode in Edit ▶ Options ▶ Misc.)
2. Bicubic interpolation is preferred over bilinear (e.g., Edit ▶ Selection ▶ Straighten...)
3. The name of the measured image name is recorded in the first column of the results table (Display Label in Analyze ▶ Set Measurements...)
4. Measurements are not restricted to thresholded pixels (Limit to Threshold in Analyze ▶ Set Measurements...)
5. Binary images are processed assuming white objects on a black background (Black background in Process ▶ Binary ▶ Options...)
6. Background color is black and foreground color is white (Edit ▶ Options ▶ Colors...)

are set properly at startup, the following ‘AutoRun’ macro could be appended to the StartupMacros.txt file:

Listing 3 Ensuring specific settings at launch.

```java
macro "AutoRun" {
  setOption("DebugMode", true);
  setOption("Bicubic", true);
  setOption("Display Label", true);
  setOption("Limit to Threshold", false);
  setOption("BlackBackground", true);
  setBackgroundColor(0,0,0);
  setForegroundColor(255,255,255);
  // run("Colors...", "foreground=white background=black");
}
```

See also: FAQ’s on the ImageJ Documentation Wiki
Part III

Extending ImageJ

ImageJ capabilities can be extended by loadable code modules in the form of macros, scripts or plugins. 300+ macros, 500+ plugins and 20+ scripts are available through the ImageJ web site. Below is a short description of these three type of ImageJ add-ons:

**Macros** The easiest way to execute a series of ImageJ commands. The ImageJ macro language – a Java-like language – contains a set of control structures, operators and built-in functions and can be used to call built-in commands and other macros. Macro code is stored in text files (.txt and .ijm extensions).

**Plugins** Much more powerful, flexible and faster than macros (most of ImageJ’s built-in menu commands are actually plugins) but harder to write and debug. Plugins are written in the Java programming language (.java source files) and compiled to .class files.

**Scripts** ImageJ uses the Mozilla Rhino interpreter to run JavaScripts. Similarly to plugins, scripts have full access to all ImageJ and Java APIs but do not need to be compiled (scripts and macros run interpretively). On the other hand, scripts lack the simplicity of macro language and ‘feel’ less integrated in ImageJ.

13 Macros

A macro is a simple program that automates a series of ImageJ commands. The easiest way to create a macro is to record a sequence of commands using the command recorder (Plugins > Macros > Record...).

A macro is saved as a text file (.txt or .ijm extension) and once installed executed by selecting the macro name in the Plugins > Macros submenu, by pressing a key or, in the case of Macro tools, by clicking on an icon in the ImageJ toolbar. In addition, any macro file placed in the ImageJ/plugins folder with an .ijm extension will be installed in the Plugins menu like any other plugin (before version 1.41 only files with an underscore in the name would be listed).

There are more than 300 example macros, on the ImageJ Web site. To try one, open it in a browser window and drag it directly to the ImageJ Window or, copy it to the clipboard – Ctrl A, switch to ImageJ, and run File > New > System Clipboard [V] – Ctrl Shift V, pasting the macro into a new editor window (cf. The ImageJ Editor). Run it using the editor’s Macros > Run Macro command – Ctrl F. Most of the example macros are also available in the macros folder, inside the ImageJ folder.
Macro Programming

The ImageJ community has created excellent tutorials on macro programming. These resources are indispensable guides to the ImageJ macro language:

1. *The ImageJ Macro Language — Programmer’s Reference Guide* by Jérôme Mutterer and Wayne Rasband. This booklet compiles most of the documentation dispersed throughout the web related to ImageJ’s macro programming. It provides an up to date printable manual for the ImageJ macro language:  

2. The Built-in Macro Functions webpage (Help » Macro Functions . . .), the indispensable guide to the built-in functions that can be called from the ImageJ macro language. It is thoroughly documented and constantly updated:  

3. Tutorials on the Fiji webpage:  

   http://imagejdocu.tudor.lu/

See also: Scripts, Plugins

14 Scripts

ImageJ 1.41 added support for JavaScript scripting. ImageJ uses the Mozilla Rhino interpreter built into Java 1.6 for Linux and Windows to run JavaScript. Mac users, and users of earlier versions of Java, must download JavaScript.jar into the plugins folder. This JAR file is available at rsb.info.nih.gov/ij/download/tools/JavaScript.jar. It is also included with the Mac version of ImageJ 1.41 and later, in the ImageJ/plugins/tools folder.

Example JavaScript programs are available at rsb.info.nih.gov/ij/macros/js/. Since ImageJ 1.43 thread safe JavaScript code can be generated using the Recorder (Plugins » Macros » Record . . .). Scripts can be opened in the editor as any other macro (cf. Macros). Scripts with the extension .js can be opened using the Macros » Run Macro command otherwise Macros » Evaluate JavaScript ([Ctrl] [E]) must be used.

JavaScript Programming

Resources on ImageJ JavaScript scripting include:
1. The ImageJ web site, with growing documentation:

2. Tutorials on the Fiji webpage:

**Advantages and disadvantages of JavaScript in ImageJ.** A thorough comparison between different scripting languages is available on the Fiji webpage.

<table>
<thead>
<tr>
<th>JavaScript Advantages</th>
<th>JavaScript Disadvantages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full access to ImageJ and Java APIs</td>
<td>Slower, especially starting up</td>
</tr>
<tr>
<td>Richer language (objects, &quot;?&quot; operator, break, continue, etc.)</td>
<td>No equivalent of macro sets</td>
</tr>
<tr>
<td>Extensive documentation</td>
<td>Cannot use most of ImageJ’s 360+ built in macro functions</td>
</tr>
<tr>
<td>Standardized</td>
<td>Requires knowledge of complex ImageJ and Java APIs</td>
</tr>
<tr>
<td></td>
<td>No support for “batch mode”</td>
</tr>
<tr>
<td></td>
<td>Cannot create tools and toolbar menus</td>
</tr>
<tr>
<td></td>
<td>Not compatible with Function Finder and CodeBar¹</td>
</tr>
<tr>
<td></td>
<td>No debugger</td>
</tr>
</tbody>
</table>

¹CodeBar is a convenient ‘ActionBar’ that retrieves snippets and common tasks frequently used in macro writing. ‘ActionBars’ provide one or many easy to use button bar(s) that extend ImageJ’s graphical user interface. You can read more about the ActionBar plugin at the ImageJ Documentation Portal.

## Plugins

Plugins are a much more powerful concept than macros and scripts and most of ImageJ’s built-in menu commands are in fact implemented as plugins. Quoting Werner Bailer [85]:

> Plugins are implemented as Java classes, which means that you can use all features of the Java language, access the full ImageJ API and use all standard and third-party Java APIs in a plugin. This opens a wide range of possibilities of what can be done in a plugin.

> The most common uses of plugins are filters performing some analysis or processing on an image or image stack and I/O plugins for reading/writing
not natively supported formats from/to file or other devices. But as you can
see when looking at the plugins listed on the ImageJ plugins page, there are
many other things you can do with plugins, such as rendering graphics or
creating extensions of the ImageJ graphical user interface.

Plugins in the plugins folder are listed at the bottom of the Plugins menu. Only .class
and .jar files in the plugins folder with at least one underscore in their name will be
installed. Note that, with IJ 1.44d an later, ImageJ no longer automatically installs, at
startup, plugins in JAR file directories that start with a lower case letter.

Developing ImageJ Plugins

More information on how to develop ImageJ plugins can be obtained on the following
documents:

1. Developer Resources Page on the ImageJ website (Help▷Dev. Resources...):
2. Dedicated tutorials on Fiji’s webpage:
3. Dedicated tutorials on the ImageJ Documentation Portal:
   http://imagejdocu.tudor.lu/

16 Scripting in Other Languages

Support for other languages is possible in ImageJ using Fiji and its powerful editor. Fiji
adds extra support for BeanShell, Clojure, Python and Ruby. The following documents
will introduce you to the advanced scripting capabilities of Fiji:

1. The extensive tutorial on scripting Fiji with Jython by Albert Cardona:
   http://www.ini.uzh.ch/~acardona/fiji-tutorial/
2. Dedicated tutorials on the Fiji webpage:

The Fiji Script Editor

Fiji features a powerful script editor that is an invaluable help when writing scripts in
any of Fiji’s supported languages, including the ImageJ macro language. The editor
features full undo support, syntax highlighting, tabs, bookmarks and several other tools
that simplify scripting workflows in ImageJ. For more information see the Fiji website at
17 Running ImageJ From the Command Line

ImageJ recognizes the following command line options:

"file-name"  Opens a file. Examples:
blobs.tif
/Users/wayne/images/blobs.tif
e81*.tif

-iijpath path  Specifies the path to the directory containing the plugins directory. Example:
-ijpath /Applications/ImageJ

-port  Specifies the port ImageJ uses to determine if another instance is running. Examples:
-port1 (use default port address + 1)
-port2 (use default port address + 2)
-port0 (do not check for another instance)

-macro path [arg]  Runs a macro or script, passing it an optional argument, which can be retrieved using getArgument(). Examples:
-macro analyze.ijm
-macro analyze /Users/wayne/images/stack1
-batch path [arg]  Runs a macro or script in batch (no GUI) mode, passing it an optional argument. ImageJ exits when the macro finishes.

eval "macro code"  Evaluates macro code. Examples:
  -eval "print('Hello, world');"
  -eval "return getVersion();"

-run command  Runs an ImageJ menu command. Example:
  -run "About ImageJ..."

debug  Runs ImageJ in debug mode

See also: ImageJ Documentation Portal: Command line, Running ImageJ in headless mode, Linux installation

18 ImageJ Interoperability

Several packages exist that allow ImageJ to interact with other applications/environments:

MIJ — A Java package to exchange images from MATLAB to ImageJ  This package, written by Daniel Sage and Dimiter Prodanov, offers static methods to exchange images between ImageJ and MATLAB. MIJ also allows MATLAB to access all built-in functions of ImageJ as well as third-party ImageJ plugins. More information is available on the MIJ website: http://bigwww.epfl.ch/sage/soft/mij/.


CellProfiler  CellProfiler [76] (http://www.cellprofiler.org/) contains an ImageJ module that allows ImageJ plug-ins to be run in a CellProfiler pipeline (RunImageJ).
Part IV

The ImageJ User Interface

ImageJ Window

Unlike most image processing programs, ImageJ does not have a main work area. ImageJ’s main window is actually quite parsimonious containing only a menu bar (at the top of the screen on the Mac), a Toolbar, a Status bar and a Progress bar. Images, histograms, profiles, widgets, etc. are displayed in additional windows. Measurement results are displayed in The Results Table. Most windows can be dragged around the screen and resized.

The ImageJ window (version 1.44i).

1 Rectangular Selection Tool and Round Rectangular Selection Tool
2 Oval Selection Tool, Elliptical Selection Tool and Brush Selection Tool
3 Polygon Selection Tool
4 Freehand Selection Tool
5 Straight Line Selection Tool, Segmented Line Selection Tool, Freehand Selection Tool and Arrow Tool
6 Angle Tool
7 Point Tool and Multi-point Tool
8 Wand Tool
9 Text Tool
10 Magnifying Glass
11 Scrolling Tool
12 Color Picker
A–H Custom Macro Tools loaded from StartupMacros.txt, /macros/tools/ or /macros/toolsets/
13 Macro Toolset Switcher

Toolbar

The ImageJ toolbar contains tools for making selections, drawings, zooming and scrolling, etc. In addition, the right-side of the toolbar contains seven slots that can host any of the 60+ tools and 15+ tool sets available on the ImageJ website (cf. Macro Tools).

All ImageJ tools share common features:

- The ▼ on the bottom right corner of some icons in the toolbar depicts a contextual menu that can be accessed by right-clicking on the tool icon.
– If an ‘Options’ dialog is available for a particular tool, it can be accessed by double clicking on the tool icon (e.g., Wand Tool).

**Status bar**

When the cursor is over an image, pixel intensities and coordinates are displayed in the status bar. After running a filter, elapsed time and processing rate (in pixels/second) is also displayed. When clicking on the status bar the ImageJ version, the Java version, memory in use, memory available and percent memory used will be displayed. As selections are created or resized, selection properties (e.g., location, width, etc.) are displayed on the status bar.

In addition, clicking on ImageJ’s status bar, forces the Java garbage collector to run, which may help to reclaim unused memory (cf. **Edit** ▶ **Options** ▶ **Memory & Threads...**).

See also: **Plugins** ▶ **Utilities** ▶ **ImageJ Properties...**, **Help** ▶ **About ImageJ...**

**IV Toggling Calibrated Units**

If a spatial scale has been defined (cf. **Image** ▶ **Properties...** [P], or **Analyze** ▶ **Set Scale...**), selection properties are displayed in the Status bar in calibrated units. Resizing or moving while holding down Alt forces this information to be displayed in pixels.

**Progress bar**

The progress bar, located to the right of the status bar, shows the progress of time-consuming operations. It will not appear if the operation requires less than approximately one second.
19  Tools

19.1 Rectangular Selection Tool

Location, width, height, and aspect ratio are displayed in the status bar during drawing. The following modifier keys apply to the Rectangular Tool:

- **Shift**: Selection is constrained to a square
- **Alt**: Width/height are changed with arrow keys one pixel at a time
- **Ctrl**: Selection is resized around the center
- **Ctrl** + **Alt**: Current aspect ratio is maintained while resizing

See also: Round Rectangular Selection Tool, Specify…, IV, XIV

19.2 Round Rectangular Selection Tool

This tool shares the same toolbar slot and the same modifier keys with the Rectangular Selection Tool. Corner arc size can be adjusted by double clicking on its icon. Because its an annotation tool the round rectangle is displayed in foreground color instead of selection color (see Point Tool, Color Picker… [K]).

See also: Rectangular Selection Tool, XIV

19.3 Oval Selection Tool

Location, width, height, and aspect ratio are displayed in the status bar during drawing. The following modifier keys apply to the Oval Tool:

- **Shift**: Selection becomes circular
- **Alt**: Width/height are changed with arrow keys one pixel at a time
- **Ctrl**: Selection is resized around the center
- **Ctrl** + **Alt**: Current aspect ratio is maintained while resizing

See also: Elliptical Selection Tool, Specify…, IV, XIV
19.4 Elliptical Selection Tool

Ellipse properties are adjusted by dragging the four handlers on its antipodal points [3]. To rotate or resize, drag the handlers on its major axis (transverse diameter). To adjust eccentricity, drag the handlers on its minor axis (conjugate diameter).

See also: Oval Selection Tool, XIV

19.5 Brush Selection Tool

Adjusts the shape of any area selection using a circular ‘brush’ [4]. Clicking inside the area selection and dragging along its boundary will expand the boundary outwards. Clicking outside the area selection and dragging along its boundary will shrink the boundary inwards. Brush diameter can be adjusted by double clicking on the tool icon. Location, width, height, and aspect ratio are displayed in the status bar during drawing.

The following modifier keys apply to the Brush Tool:

- **Shift**: Brush is always added to the selection
- **Alt**: Brush is always subtracted from selection

See also: Composite Selections, IV

19.6 Polygon Selection Tool

Creates irregularly shaped selections defined by a series of line segments. To create a polygon selection, click repeatedly with the mouse to create line segments. When finished, click in the small box at the starting point (or double click), and ImageJ automatically draws the last segment. The vertex points that define a polygon selection can be moved and modifier keys can be used to delete or add new vertexes to the polygon.

The following modifier keys apply to the Polygon Tool:

- **Shift**: Clicking on a point with with the Shift key pressed adds a new point
- **Alt**: Clicking on a point with with the Alt key pressed removes it

See also: Segmented Line Selection Tool, Enlarge..., IV, XIV

19.7 Freehand Selection Tool

As with the polygon selection tool, ImageJ automatically draws the last segment. Location and intensity of starting pixel are displayed in the status bar during drawing.

See also: Freehand Line Selection Tool, Polygon Selection Tool, Enlarge..., IV, XIV
19.8 Wand Tool

Creates a selection by tracing objects of uniform color or thresholded objects. To trace an object, either click inside near the right edge, or outside to the left of the object. To automatically outline and measure objects have a look, e.g., at the WandAutoMeasureTool macro.

To visualize what happens, imagine a turtle that starts moving to the right from where you click looking for an edge. Once it finds the edge, it follows it until it returns to the starting point. Note that the wand tool may not reliably trace some objects, especially one pixel wide lines, unless they are thresholded (highlighted in red) using Image > Adjust > Threshold... [T].

Double clicking on the wand tool icon (or running Edit > Options > Wand Tool... ) opens the configuration dialog box in which three modes (4–connected, 8–connected or ‘Legacy’) plus a tolerance value can be set [5].

The Wand Tool. 4/8–connected particles can be traced within an intensity range.

**Tolerance** The wand takes the pixel value where you click as an initial value. It then selects a contiguous area under the condition that all pixel values in that area must be in the range $\text{initial value} - \text{tolerance}$ to $\text{initial value} + \text{tolerance}$.

**4–connected** Only the four neighbors of a pixel are considered neighbors. E.g., the wand does not follow a one-pixel wide diagonal line because the pixels of that line are not four-connected.

**8–connected** Each pixel is considered to have eight neighbors. So the wand follows a diagonal line if you click onto it. On the other hand, if you have an area of constant value dissected by a one-pixel wide diagonal line, the 8–connected wand will ‘jump over the line’ and include the other part of that area.

**Legacy** In this mode no neighbor is checked and no tolerance is used. This is the default mode of the Wand Tool in ImageJ 1.42 and earlier.
19.9 Line Selection Tools

Use these tools to create line selections. Double click on any line tool to specify the line width by opening the Image ▶ Adjust ▶ Line Width... widget. The three line selection tools share the same toolbar slot. To switch to a different tool, right click on the current line tool and select the desired tool from the drop-down menu. Length and to do are displayed in the status bar.

19.9.1 Straight Line Selection Tool

The following modifier keys apply to the Straight Line Tool:

- **Shift** Forces the line to be horizontal or vertical
- **Alt** Keeps the line length fixed while moving either end of the line
- **Shift** Forces the two points that define the line to have integer coordinate values when creating a line on a zoomed image
- **Ctrl** While moving either end of the line rotates/resizes it about its center

See also: Calibration Bar..., Set Scale..., IV, XIV

19.9.2 Segmented Line Selection Tool

Works exactly as described for the Polygon Selection Tool: Create a segmented line selection by repeatedly clicking with the mouse. Each click will define a new line segment. Double click when finished, or click in the small box at the starting point. The points that define a segmented line selection can be moved or deleted, and new points can be added.

The following modifier keys apply to the Segmented Line Tool:

- **Shift** Clicking on an existing point with the Shift key down adds a point
- **Alt** Clicking on an existing point with the Alt key down deletes it

See also: Polygon Selection Tool, Freehand Selection Tool, IV, XIV

19.9.3 Freehand Line Selection Tool

Select this tool and drag with the mouse to create a freehand line selection.

See also: Freehand Selection Tool, IV, XIV

19.10 Arrow Tool
Double clicking on the tool icon opens the *Options* prompt depicted on the left. Because it is an annotation tool, changing *Color* will change foreground color and not selection color (*see* Point Tool, Color Picker... [K]). *Width* and *Size* (in pixels) can be adjusted by dragging the respective sliders or by direct input. Apart from the six arrow styles listed here, a ‘*Headless*’ option is also available.

As with other tools, add arrows to a non-destructive overlay using Image □ Overlay □ Add Selection... [b] or Edit □ Draw [d] to permanently draw an arrow (see XIV).

**19.11 Angle Tool**

This tool allows you to measure an angle defined by three points. Double click on the angle tool icon to enable the measurement of reflex angles. The angle is displayed in the status bar while the selection is being created or adjusted. Press [m] (Analyze □ Measure... [m]) to record the angle in the The Results Table.

**19.12 Point Tool**

Use this tool to create a point selection, to count objects or to record pixel coordinates. The following modifier keys apply to the Point Tool:

![Image of Point Tool configuration dialog]

**Shift**

Shift-clicking will add more points. Point count is displayed on the Status bar.

**Alt**

Alt-clicking on a point will delete it. Alt-clicking and dragging with the rectangular or oval selection tool will delete multiple points.

Double clicking on the point tool icon (or running Edit □ Options □ Point Tool...) displays its configuration dialog box.

**Mark Width** If greater than zero, a mark of the specified diameter will be permanently drawn in the current foreground color (cf. Color Picker... [K]). Note that marks modify the image (it may be wise to work with a copy) and color marks are only available with RGB images (*see* XIV).
**Auto-Measure** If checked, clicking on the image records the pixel location and intensity. Note that if *Mark Width* is not zero, every time a point selection is measured a mark will be painted (cf. Measure... [m]). If unchecked, Edit→Draw [d] can be used to paint the mark (*Mark Width* diameter) at the location of each point.

**Auto-Next Slice** If checked, ImageJ will automatically advance to the next stack slice. Note that this feature will only allow one point per slice.

**Add to ROI Manager** If checked, points will be automatically added to the ROI Manager...

**Label Points** If checked, each point selection will be displayed with an accompanying numeric label.

**Selection Color** Specifies the selection color, chosen from one of the nine ImageJ default colors: Red, Green, Blue, Magenta, Cyan, Yellow, Orange, Black and White. Note that the selection color is highlighted in the center of the Point/MultiPoint Tool (cf. Selections).

See also: Multi-point Tool, Cell Counter plugin

### 19.13 Multi-point Tool

The Multi-point Tool selects multiple points behaving as the Point Tool when [Shift] is pressed, *Label Points* is checked and *Auto-Measure* and *Auto-Next Slice* are deselected. As described for the Point Tool, [Alt] can also be used to remove points. Similarly, when using Edit→Draw [d] marks are painted with the diameter of *Mark Width*.

Double clicking on the tool icon runs the Image→Overlay→Add Selection... [b] command.

See also: Point Tool, Cell Counter plugin

### 19.14 Text Tool

Use this tool to add text to images. It creates a rectangular selection containing one or more lines of text. Use the keyboard to add characters to the text and the backspace key to delete characters. Use Image→Overlay→Add Selection... [b] to add the text non-destructively to the overlay. Use Edit→Draw [d] to permanently draw the text on the image. Use Edit→Options→Fonts..., or double click on the text tool, to specify the typeface, size and style.

See also: TextDemo macro
19.15 Magnifying Glass

Click on the image with this tool to zoom in. Right-click (or Alt-click) to zoom out. The current magnification is shown in the image’s title bar. Double click on the magnifying glass icon to revert to the image’s original magnification. There are 21 possible magnification levels: 3.1, 4.2, 6.3, 8.3, 12.5, 16.7, 25, 33.3, 50, 75, 100, 150, 200, 300, 400, 600, 800, 1200, 1600, 2400 and 3200 percent.

The following modifier keys apply to the Magnifying Glass Tool:

- **Shift**: When zooming in will prevent the window from being enlarged.
- **Alt**: Will zoom out (right-click behavior)

**See also:** Zoom▷, XV

19.16 Scrolling Tool

Allows you to scroll through an image that is larger than its window. When using other tools (except the text tool), you can temporarily switch to this tool by holding down the space bar (see XV).

19.17 Color Picker

Sets the foreground drawing color by ‘picking up’ colors from any open image. Colors can also be ‘picked up’ from the Color Picker (CP) window (Image▷Colors▷Color Picker… [K]) window using any tool. In the icon, the ‘eye dropper’ is drawn in the current foreground color while the frame around it is drawn in the current background color. Edit▷Draw [d] and Edit▷Fill [f] use the foreground color. Edit▷Clear, Clear Outside and Cut [x] use the background color. Double clicking on the tool icon will display the Color Picker window.

The following modifier key applies to the Color Picker Tool:

- **Alt**: Alt-clicking with the Color Picker Tool on an image will change the background color

**See also:** Image Types and Image Formats, XIV
19.18 Macro Toolset Switcher

Use this drop-down menu to switch to alternative macro tool sets located in the ImageJ/macros/toolsets folder, or to revert to the default ImageJ/macros/StartupMacros.txt toolset [35]. Macro toolsets can be obtained at http://imagej.nih.gov/ij/macros/toolsets/ or created, e.g., using Toolset Creator.

The following modifier key applies to the Macro Toolset Switcher:

- **Shift** - Shift-clicking on the Toolset Switcher will open the selected toolset file on the drop-down menu.

19.19 Macro Tools

The tools on the right side of the toolbar (all slots between Color Picker and Macro Toolset Switcher) are defined by macros in the StartupMacros.txt file (ImageJ/macros folder), which can be opened using the Plugins ⊃ Macros ⊃ Startup Macros... command. These tools can be customized by editing the StartupMacros.txt file, or replaced entirely using the Macro Toolset Switcher menu. The macro language documentation at http://imagej.nih.gov/ij/developer/macro/macros.html#tools has more information about macro tools.

**See also:** Macro Toolset Switcher, Luts Macros and Tools Updater macro

Macro Toolsets distributed with ImageJ 1.43 [35]. While the StartupMacros.txt file is located in the ImageJ/macros/ directory, all other toolsets must be located in the ImageJ/macros/toolsets subfolder. Note that you can use Toolset Creator to create Menu Tools for running plugins, macros and scripts.

20 Contextual Menu

As mentioned earlier macros and macro tools in the StartupMacros.txt are automatically installed in the Plugins ⊃ Macros ⊃ submenu and in the toolbar when ImageJ starts up.
In addition, the StartupMacros.txt file also installs the contextual (popup) menu displayed when right-clicking on an image. Other macros and toolsets (e.g., Magic Montage) may also replace the default menu with specialized ones. In this case, re-installing the StartupMacros (using the Macro Toolset Switcher) will revert the contextual menu to its default.

The menu that is displayed when a user right-clicks (or ctrl-clicks) on an image window can be customized through installation of the "Popup Menu" macro. Any menu has a name and a list of menu items. The newMenu(name, items) macro function allows the creation of a new menu. This menu passes the chosen item as a simple string to the "Popup Menu" macro. From this point you can decide what to do, according to what item was chosen.

So, e.g., to add the ability to run the Process⇒Subtract Background... command from the contextual menu one can simply add that command to the list of items defining the PopUp Menu. Note that "-" defines menu separators:

```
/* The "Popup Menu" macro defines the menu that is displayed when right clicking (or ctrl-clicking) on an image. It is part of the startup macros (StartupMacros.txt) and several other macro toolsets */

var pmCmds = newMenu("Popup Menu", newArray("Help...", "Rename...", "Duplicate...", "Original Scale", "Paste Control...", ","Record...", ","Capture Screen", ","Monitor Memory...", ","Startup Macros...", ","Search ...", ","Find Maxima...", ","Subtract Background..."));

macro "Popup Menu" {
    cmd = getArgument();
    if (cmd=="Help...")
        showMessage("About Popup Menu", 
            "To customize this menu, edit the line that starts with
             "var pmCmds" in ImageJ/macros/StartupMacros.txt.");
    else
        run(cmd);
}
```

The ImageJ Macro Language — Programmer’s Reference Guide explains how this menu can be customized:
Most of ImageJ analyses are printed to the Results table. Table commands are organized in four menus: File, Edit, Font and Results. A contextual menu listing the majority of these commands can be accessed by right-clicking anywhere in the Results window.

The ImageJ Results table (version 1.44k). Columns width can be adjusted by clicking on and dragging the vertical lines that separate the column headings. Selected lines can be deleted by pressing the backspace key. The arrow keys can be used to vertically scroll the window.

File ➤ Save As... ➤ Exports the measurements as a tab-delimited or comma-delimited text file as defined in Results ➤ Options...

File ➤ Rename... ➤ Renames the table. Because ImageJ outputs measurements exclusively to the Results table, renaming the table will freeze its contents.

File ➤ Duplicate... ➤ Creates a new table containing a copy of the data. Note that ImageJ will not output measurements to duplicated tables.

Font ➤ This menu contains commands to adjust font size.

Results ➤ Clear Results... ➤ Alias for the Analyze ➤ Clear Results command.

Results ➤ Summarize ➤ Alias for the Analyze ➤ Summarize command.

Results ➤ Distribution... ➤ Alias for the Analyze ➤ Distribution... command.

Results ➤ Set Measurements... ➤ Alias for the Analyze ➤ Set Measurements... command.
Results » Options... Opens the Edit » Options » Input/Output... dialog in which is possible to specify if column headers and row numbers should be saved or copied from ImageJ tables (including the Summarize table, cf. Analyze » Analyze Particles...). In addition, it allows to specify the file extension to be used when saving data. Custom extensions (e.g., .csv, .xls or .ods) allow ImageJ tables to be imported seamlessly by spreadsheet applications. ImageJ tables are saved in CSV format if File extension for tables is .csv.

See also: Plugins » New » Table...

22 The ImageJ Editor

Macros», Scripts and Plugins can be opened and executed in the ImageJ editor. The editor commands are organized in five menus: File », Edit », Font », Macros » and Debug ».

File » Basic file operations (Open, Save, Print, etc.) are listed in this menu.

Edit » Similarly to any other text editor this menu contains commands related to text handling as well as commands for locating text. Specially useful are:

Go to Line... [l], Ctrl [l] This dialog box enables you to quickly go to a specified line of code.

Zap Gremlins This command finds and deletes the extraneous non-visible, non-printing characters that sometimes appear when cutting and pasting from other sources, such as email messages that may contain extraneous control characters, or any non-ASCII characters.

Copy to Image Info This command will copy the selected text (or the entire contents of the editor if no selection is present) to the image header, being available through the Image » Show Info... [i] command. Note that the copied text will substitute any other information present in the file header and will only be available in images saved as TIFF (see II).

Font » This menu contains commands to adjust font size and type.

Macros » This menu contains commands that allow you to run, install or evaluate macro code:

Run Macro [r], Ctrl [r] Runs the macro or the selected line(s) of code.

Evaluate Line [y], Ctrl [y] Runs the line of code that contains the insertion point.

Abort Macro Exits the macro

Install Macros [i], Ctrl [i] Adds the macro(s) contained in the editor to Plugins » Macros » submenu (Plugins » Macros » Install... command).
The ImageJ editor (version 1.43n).

Function Finder... [F], [Ctrl][Shift][F] [2] Retrieves macro functions in the same way Command Finder retrieves commands. Functions are read from the 'functions.html' file stored in the macros folder (a local copy of http://imagej.nih.gov/ij/developer/macro/functions.html). This file is deleted by Help > Update ImageJ... command every time ImageJ is updated to a release version (i.e., not a daily build), forcing Function Finder to download a fresh copy the next time it is launched.

Evaluate JavaScript [j], [Ctrl][J] Runs JavaScript code in the editor window. Note that Run Macro runs JavaScript code if the title of the file ends with '.js'.

Debug ⊿ This menu contains seven commands related to the macro debugging. You can debug a macro using the commands in the Debug menu. You start a debugging session initiating Debug Macro. You can then single step through the macro code by repeatedly running Step.

Debug Macro [d], [Ctrl][D] Starts running the macro in debug mode and opens the ‘Debug’ window, which initially displays the memory usage, number of open images, and the active image’s title. The macro stops running at the first executable line of code, which is highlighted. Use one of the following commands to continue execution.

Step [e], [Ctrl][E] Executes the highlighted statement and advances to the next. The variable names and values in the ‘Debug’ window are updated.
**Trace [t], [Ctrl] T**  Runs the macro, displaying variable names and values in the ‘Debug’ window as they are encountered.

**Fast Trace [T], [Ctrl] Shift T**  Same as above, but faster.

**Run**  Runs the macro to completion at normal speed (similarly to Macros > Run Macro).

**Run to Insertion Point, [Ctrl] Shift E**  Runs the macro to a statement that was previously defined by clicking the mouse on an executable line of code.

**Abort**  Exits debug mode.
Part V

ImageJ Commands

23 File

As in any other image processing software, basic file operations are listed in this menu. Most are self-explanatory.

23.1 New

Contains commands for creating new images, stacks, hyperstacks or text windows.

See also: Plugins ▷ New

23.1.1 Image... [n]

Creates a new image window or stack. A dialog box allows you to specify the image title, type, dimensions and initial content.

Name is the title that will be used for the Window. Type is the image type: 8–bit grayscale, 16–bit grayscale (unsigned), 32–bit (float) grayscale or RGB color. Fill With (White, Black or Ramp) specifies how the image is initialized. Width and Height specify the image dimensions in pixels. Set Slices to a value greater than one to create a stack.

See also: Hyperstack... , Image Types and Image Formats

23.1.2 Hyperstack...

Alias for the Image ▷ Hyperstacks ▷ New Hyperstack... command.

23.1.3 Text Window [N]

Creates a new text window with the title ‘Untitled.txt’.

See also: Plugins ▷ New ▷ Text Window... , Macro, Table...
23.1.4  Internal Clipboard

Opens the contents of the internal ImageJ clipboard.

See also: Edit > Copy [c], Cut [x], Paste Control...

23.1.5  System Clipboard [V]

Opens the contents of the operating system clipboard.

See also: Edit > Copy to System, Cut [x], Paste Control...

23.2  Open...

Opens an image and displays it in a separate window. Image files must be in TIFF, GIF, JPEG, DICOM, BMP, PGM or FITS format, or in a format supported by a reader plugin. Also opens:

- ImageJ and NIH Image lookup tables (.lut extension).
- Results tables (in tab-delimited text format) (.xls or .csv extension)
- Selections (.roi or .zip extension)
- Text files (.txt, .ijm, .js and .java extensions)
- ...

See also: File > Import >, Image Types and Image Formats, Virtual Stacks, V

23.3  Open Next [O]

Closes the current image and opens the next image (if any) in its directory. Holding Alt opens the previous image (if any) in its directory.
V OPENING FILES: FILE⇒OPEN, FILE⇒IMPORT AND DRAG & DROP

While the File⇒Open... command opens formats natively supported by ImageJ (images and non-images files), the File⇒Import⇒submenu provides access to plugins for additional file types (e.g., reading ‘raw’ files, images in ASCII format or loading images over the network). Most of ImageJ’s Input/Output plugins are installed on this submenu.

Note that almost every format known to ImageJ can be opened by dragging and dropping the file into the ImageJ Window. E.g., in the illustration below a remote macro file is opened by dragging its URL directly from a Web browser.

23.4 Open Samples⇒

Opens example images hosted on the ImageJ Web site. These sample images are useful for creating, testing and debugging macros since routines can be applied to the same image, regardless of where the macro is run. Among all, probably the most used is blobs.gif: Open Samples⇒Blobs (25K) [B].

Sample images can be downloaded from http://imagej.nih.gov/ij/images/ or, in bulk, from http://imagej.nih.gov/ij/download/sample-images.zip. The ‘AutoRun’ macro in the StartupMacros.txt file can be used to change the default path of sample images, allowing a complete off-line usage of the File⇒Open Samples⇒submenu:

Listing 5 Setting File⇒Open Samples⇒for off-line usage.

```
/* This macro calls the Prefs.setImageURL() method to change the default path of Sample Images (http://imagej.nih.gov/ij/images/) to a local subfolder of ImageJ's directory named "samples". Note that Fiji provides this feature by default. */

macro "AutoRun" {
  fldr = getDirectory("imagej") + "samples";
  path = replace(fldr, " ", "%20");
  call("ij.Prefs.setImageURL", "file://" + path + "/");
}
```

23.5 Open Recent⇒

The submenu shows a list of the 15 recently opened files. Click on a filename to open it.
23.6 Import

This submenu lists the installed image reader plugins.

See also: Non-native Formats, Acquisition plugins, Input/Output plugins, Virtual-StackFromList macro, V

23.6.1 Image Sequence...

Opens a series of images in a folder as a stack. Images must all be the same size and type. They can be in TIFF, JPEG, DICOM, BMP, GIF, FITS or PGM format, or in a format supported by the HandleExtraFileTypes plugin. There are two dialog boxes: one to select the folder and one to specify options. In the first dialog, select any of the images in the folder and click ‘Open’. Use the second (depicted on the left) to specify which images to open, to reduce the image size, to convert to a different type, or to open the images as a virtual (disk-resident) stack. The parameters are:

Number of Images Specifies how many images to open.

Starting Image If set to $n$, import will start with the $n^{th}$ image in the folder.

Increment If set to ‘2’ every other image will be opened, if set to ‘3’ every third image will be opened, etc.

File Name Contains Enter a string into this field and ImageJ will only open files whose name contains that string.
**Enter Pattern** Regular expressions (regex) can be typed here for advanced filtering (cf. Basic syntax of regular-expressions)

**Scale Images** Setting a value less than 100% will reduce memory requirements. E.g., entering 50 reduces the amount of memory needed to open a stack by 75%.

**Convert to RGB** Allows a mixture of RGB and grayscale images to be opened.

**Sort Names Numerically** When checked, the stack will be opened in numeric file name order (e.g., ‘name1.tif’, ‘name2.tif’, ‘name10.tif’) instead of alphanumeric order (e.g., ‘name1.tif’, ‘name10.tif’, ‘name2.tif’). DICOM files in the same series (tag# 0020,0011) are always sorted by the image number (tag# 0020,0013). The List Stack Tags macro, part of the ListDicomTags macro set, lists the values of the image number and image series tags.

**Use Virtual Stack** When checked, images are opened as a read-only virtual (disk-resident) stack using a version of the Virtual Stack Opener plugin. This allows image sequences too big to fit in RAM to be opened, but access time is slower and changes are lost when switching to a different image in the stack (cf. Virtual Stacks).


Information – width×height×depth (size) – of the stack that will be created is displayed at the bottom on the dialog box, and is updated dynamically.

**See also:** OpenSeriesUsingFilter macro

**Regular-expressions basic syntax summary.** For more information on regex filtering see http://download.oracle.com/javase/tutorial/essential/regex/.

<table>
<thead>
<tr>
<th>Regex Syntax (Character Classes)</th>
<th>Example</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>[]</td>
<td>[aA]</td>
<td>Either lower or upper case A</td>
</tr>
<tr>
<td>-</td>
<td>[0-9]</td>
<td>Any digit (from 0 through 9)</td>
</tr>
<tr>
<td>.</td>
<td>[0-9].</td>
<td>A digit plus any other character</td>
</tr>
<tr>
<td>*</td>
<td>.*</td>
<td>Any character sequence</td>
</tr>
<tr>
<td>?</td>
<td>[0-9]?</td>
<td>An optional digit</td>
</tr>
<tr>
<td>+</td>
<td>[0-9]+</td>
<td>At least a digit</td>
</tr>
<tr>
<td>-</td>
<td>[^0-9]</td>
<td>Any character that is not a digit</td>
</tr>
<tr>
<td>&amp;&amp;</td>
<td>[0-9&amp;&amp;[^3]]</td>
<td>A digit that is not 3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[0-9]</td>
</tr>
</tbody>
</table>
VI Reducing Memory Requirements When Importing Images

Since ImageJ 1.44d, the File > Import > Image Sequence... command no longer features the Convert to 8-bit grayscale checkbox, an option that could reduce memory requirements by 50% for 16-bit images and by 75% for 32-bit and RGB images. As a replacement, use the Use virtual stack option and then convert to 8-bit using File > Type > 8-bit.

23.6.2 Raw...

Use this command to import images that are not in a file format directly supported by ImageJ. You will need to know certain information about the layout of the image file, including the size of the image, and the offset to the beginning of the image data.

Interleaved RGB images have pixels stored contiguously (rgbrgbrgb...) in a single image plane. Planar RGB images have the red, green and blue image data stored in separate 8-bit sample planes. ImageJ saves RGB images (both TIFF and raw) in interleaved format.

**Image Type** There are fourteen choices depicted above. 16-bit signed integer images are converted to unsigned by adding 32,768. 1-bit Bitmap images are converted to 8-bit.

**Image Width** The number of pixel in each row of image data.

**Image Height** The number of rows in the image.

**Offset to First Image** The number of bytes in the file before the first byte of image data.

**Number of Images** The number of images stored in the file. If this value is greater than the actual number of images the resulting stack will get truncated to the actual size.

**Gap Between Images** The number of bytes from the end of one image to the beginning of the next. Set this value to width×height×bytes-per-pixel×n to skip n images for each image read.
**White is Zero** Should be checked if black pixels are represented using numbers that are less than the numbers used for white pixels. If your images look like photographic negatives, changing this field should fix the problem.

**Little-Endian Byte Order** Probably needs to be checked when importing 16–bit or 32–bit grayscale images from little-endian machines such as Intel based PCs.

**Open All Files in Folder** If checked, ImageJ will import all the images in the folder as a stack. The images must all be the same size and type.

**Use Virtual Stack** Images are imported as virtual stacks.


**See also:** Image Types and Image Formats

**23.6.3 LUT...**

Opens an ImageJ or NIH Image lookup table, or a raw lookup table. The raw LUT file must be 768 bytes long and contain 256 reds, 256 blues and 256 greens. If no image is open, a $256 \times 32$ ramp image is created to display the LUT. Note that lookup tables with file names ending in `.lut` can also be opened using File→Open... or drag and drop.

**23.6.4 Text Image...**

Opens a tab-delimited text file as a 32–bit real image (see Text Images). The image’s width and height are determined by scanning the file and counting the number of words and lines. For text files with integer values no larger than 255, use Image→Type→8–bit to convert to 8–bits. Before converting, disable Scale When Converting in Edit→Options→Conversions... to prevent the image from being scaled to 0–255.

**See also:** OpenTextImagesAsStack macro, Save As→Text Image...

**23.6.5 Text File...**

Opens a text file. Note that text files can also be opened using File→Open... or drag and drop.
23.6.6 URL...

Downloads and displays known formats to ImageJ specified by a URL. Other URLs ending with ‘/’ or ‘.html’ are opened in the user’s default browser. The Input URL is saved in the ImageJ preferences file and retrieved across IJ restarts.

With IJ 1.44g and later, it is possible to open zip archives, using a URL, that contain multiple DICOM images. Some example URLs are:

- `file:///Macintosh HD/images/Nanoprobes.tif`
- `file:///D:\images\neuron.tif`

23.6.7 Results...

Opens an ImageJ Results table, or any tab or comma-delimited text file. `.csv` and `.xls` files can also be opened by drag and drop.

23.6.8 Stack From List...

Opens a stack, or virtual stack, from a text file containing a list of image file paths. The images can be in different folders but they must all be the same size and type. The `Virtual Stack From List` macro demonstrates how to generate a list of images and then use that list to open the images as a virtual stack.

23.6.9 TIFF Virtual Stack...

Opens a TIFF file as a virtual stack.

23.6.10 AVI...

Uses a built-in version of the AVI reader plugin to open an AVI file (JPEG or PNG compressed, or uncompressed) as a stack or virtual stack (one slice per video frame). AVI files can also be opened using `File > Open...` or drag and drop but macros must use this command to gain access to the dialog box options.
Since version 1.41b an improved version of the plugin [7] retrieves animation speed from image frame rate, adds support for YUV formats, the ability to specify the starting and ending frame, an option to convert to 8-bit grayscale, an option to open the movie as a virtual stack, along with many bug fixes. Nevertheless, ImageJ only supports a restricted number of AVI formats (cf. plugin source code).

23.7 Close [w]
Closes the active image.

23.8 Close All
Closes all open images. An alert is displayed if there are unsaved changes.

23.9 Save [s]
Saves the active image in TIFF format, the ‘default’ format of ImageJ (cf. II). To save only a selected area, create a rectangular selection and use the Image ▶ Duplicate... [D] command. Note that Save [s] and File ▶ Save As ▶ Tiff... are redundant commands.

23.10 Save As ▶
Use this submenu to save the active image in TIFF, GIF, JPEG, or ‘raw’ format. Can also be used to save measurement results, lookup tables, selections, and selection XY coordinates.

23.10.1 Tiff...
Saves the active image or stack in TIFF format in redundancy with File ▶ Save [s]. TIFF is the only format (other than ‘raw’) that supports all ImageJ data types (8-bit, 16-bit, 32-bit float and RGB) and the only format that saves spatial and density calibration. In addition, with IJ 1.43 and later, selections and overlays are also saved in the TIFF header.

By default, 16-bit and 32-bit images are saved using big-endian byte order. Check Save TIFF and Raw in Intel Byte Order in the Edit ▶ Options ▶ Input/Output... dialog box to save using little-endian byte order.

See also: Native Formats, II, VII
23.10.2 Gif...

Saves the active image in GIF format. RGB images must first be converted to 8-bit color using using Image\(\rightarrow\)Type\(\rightarrow\)8-bit Color. The value to be used as the transparent index (0–255) can be set in the Edit\(\rightarrow\)Options\(\rightarrow\)Input/Output... dialog box. Stacks are saved as animated GIFs. Use Image\(\rightarrow\)Stacks\(\rightarrow\)Tools\(\rightarrow\)Animation Options... [Alt/] (or right-click on the on the play/pause icon that precedes the stack slider) to set the frame rate.

23.10.3 Jpeg...

Saves the active image in JPEG format. Edit JPEG Quality Edit\(\rightarrow\)Options\(\rightarrow\)Input/Output... dialog box to specify the JPEG compression level (0–100). This value is shown on the title of the save dialog prompt. Lower values produce smaller files but poorer quality. Larger values produce larger files but better quality. Color sub-sampling is disabled when the value is set to 100, reducing the likelihood of color artifacts. By default, the DPI in the JPEG header is set to 72. For a higher value, use a unit of inch in the Analyze\(\rightarrow\)Set Scale... dialog. E.g., setting Distance in Pixels to 300, Known Distance to 1 and Unit of Length to ‘inch’ will set the DPI to 300.

Since IJ1.43 and later, overlays are embedded when saving in Jpeg format (cf. Flatten [F]).

See also: II, VII

VII Warning on JPEG compression

The JPEG format uses lossy compression that can result in artifacts. You should never used this format on images to be segmented or measured.

23.10.4 Text Image...

Saves the active image as a spreadsheet compatible tab-delimited text file. For calibrated images and floating-point images, the Decimal Places field in Analyze\(\rightarrow\)Set Measurements... determines the number of digits to the right of the decimal point. For RGB images, each pixel is converted to grayscale using the formula gray = (red+green+blue)/3 or the formula gray = 0.299 × red + 0.587 × green + 0.114 × blue if Weighted RGB to Grayscale Conversion is checked in Edit\(\rightarrow\)Options\(\rightarrow\)Conversions...

See also: Import\(\rightarrow\)Text Image...
23.10.5 Zip...

Saves the active image or stack as a TIFF file inside a compressed ZIP archive.

23.10.6 Raw Data...

Saves the active image or stack as raw pixel data without a header. 8-bit images are saved as unsigned bytes, unsigned 16-bit images are saved as unsigned shorts and signed 16-bit images (e.g., File > Open Samples > CT (420K, 16-bit DICOM)) are saved as signed shorts. 32-bit images are saved as floats and RGB images are saved in three bytes per pixel (24-bits interleaved) format. 16-bit and 32-bit (float) images are saved using big-endian byte order unless Export Raw in Intel Byte Order is checked in the Edit > Options > Input/Output... dialog box.
23.10.7 Image Sequence...

Saves a Stack or a hyperstack as an image sequence.

**Format** Specifies the output format that can be set to either BMP, FITS, GIF, JPEG, PGM, PNG, Raw, Text Image, TIFF, or Zip (cf. Image Types and Image Formats). In IJ 1.44 and later, overlays are embedded when saving in JPEG or PNG format.

**Name** Specifies the leading string that will be common to all numeric filenames.

**Start At** (Stacks only) Specifies the starting number of the sequence.

**Digits (1–8)** The number digits of the incremental sequence. Filenames are padded with leading zeroes.

**Use slice labels as filenames** (Stacks only) If checked, each slice will be saved with its own label and no numeric sequence will be used.

With hyperstacks, images are saved using ‘Name_t d_z d c d’ in which d is the incremental number of specified Digits; t, the frame; z, the slice and c, the channel, so e.g., for the depicted snapshot the first image would be saved as ‘mitosis_t001_z001_c001.tif’.

23.10.8 AVI...

Exports a stack or hyperstack as an AVI file [7].

**Compression** JPEG, PNG or Uncompressed. With IJ 1.44 and later, overlays are embedded when saving in JPEG or PNG format. The default compression is JPEG.

**Frame** Specifies the frame frequency. The proposed value is read from Image>/Stacks>/Tools>/Animation Options... [Alt /] and Image>/Properties... [P], as long as the unit of Frame Interval is ‘sec’.

See also: File>/Import>/AVI...
23.10.9 PNG...

Saves the active image in PNG (Portable Network Graphics) format. All image types, except RGB, are saved as 8–bit PNGs. 16–bit images are saved as 16–bit PNGs. With 8–bit images, the value to be used as the transparent index (0–255, -1 for “none”) can be set in the Edit>Options>Input/Output... dialog box. With IJ 1.44 and later, overlays are embedded when saving in PNG format.

23.10.10 FITS...

Saves the active image in FITS (Flexible Image Transport System) format [8].

23.10.11 LUT...

Saves the active image’s lookup table to a file. The 768 byte file consists of 256 red values, 256 green values and 256 blue values.

23.10.12 Results...

Exports the contents of the ‘Results’ window as a tab-delimited or comma-delimited (.csv) text file. Prior to ImageJ 1.44b this command used to be named ‘Measurements...’.

23.10.13 Selection...

Saves the current area selection boundary to a file. Use File>Open... to restore the selection. Since IJ 1.43 active selections are saved in the TIFF header by default (cf. File>Save As>Tiff...).

23.10.14 XY Coordinates...

Exports the XY coordinates of the line selection or area selection boundary as a two column, tab-delimited text file. Coordinates of rectangular, oval and straight line selections cannot be exported. Use the Path Writer plugin to save coordinates at evenly spaced one pixel intervals.

23.11 Revert [r]

Reloads the active image, stack or hyperstack from disk, reverting it to its last saved state. It is actually a shortcut for closing the window without saving, and then reopening it.

See also: Undo and Redo
23.12 Page Setup...

The Page Setup dialog allows you to control the size of printed output, plus other printing options:

**Scale** Values less than 100% reduce the size of printed images and values greater than 100% increase the size. 100% corresponds to 72 pixels per inch (ppi), about the unzoomed screen size of the image. The size of the printed image is determined by the Scale value and the width and height of the image in pixels. Spatial calibration is ignored.

**Draw border** If checked, ImageJ will print a one pixel wide black border around the image.

**Center on page** If checked, the image will be printed in the center of the page instead of in the upper left corner.

**Print title** If checked, the title of the image will be printed at the top of the page.

**Selection only** If checked, current selection will be printed instead of the entire image.

**Rotate 90°** If checked, the image will be rotated 90° to the left before being printed.

**Print actual size** Considers the DPI information in the image header (typically 72, cf. Jpeg...). For a higher value, use a unit of inch in the Analyze->Set Scale... dialog. E.g., setting Distance in Pixels to 300, Known Distance to 1 and Unit of Length to ‘inch’ will set the DPI to 300.

23.13 Print... [p]

Prints the active image. The size of the printed image will normally be slightly less its size on the screen (unzoomed). Use the Page Setup... dialog to increase or decrease the size of printed images. Images larger than the page are scaled to fit. With IJ 1.44 and later, overlays are embedded when printing.

23.14 Quit

Prompts you to save all unsaved images and then exits. You can also exit ImageJ by clicking on the close button in its window’s title bar.
24 Edit

24.1 Undo [z]
Described in Undo and Redo.

24.2 Cut [x]
Copies the contents of the current image selection to the internal clipboard and fills it with the current background color.

See also: Edit Copy to System, Paste Control...

24.3 Copy [c]
Copies the contents of the current image selection to the internal clipboard. If there is no selection, copies the entire active image. The amount of image data copied is shown in the status bar.

See also: File Internal Clipboard, Paste Control...

24.4 Copy to System
Copies the contents of the current image selection to the system clipboard.

See also: File New System Clipboard [V], Copy [c], Paste Control...

24.5 Paste [v]
Inserts the contents of the internal clipboard (or from the system clipboard if the internal clipboard is empty) into the active image. The pasted image is automatically selected, allowing it to be dragged with the mouse. Click outside the selection to terminate the paste. Select Edit Undo [z] to abort the paste operation.

See also: Paste Control...
24.6 Paste Control...

After pasting, use the Paste Control pop-up menu to control how the image currently being pasted is transferred to the destination image.

Except for Blend and Transparent, the Paste Control transfer modes are the same as those listed in the description of Process > Image Calculator.... The Blend mode is the same as the Image Calculator Average mode. In Transparent mode, white/black pixels are transparent and all other pixels are copied unchanged.

See also: Image > Overlay > Add Image...

24.7 Clear

Erases the contents of the selection to the current background color. [Backspace] and [Del] keys are shortcuts to this command. With stacks, a dialog is displayed offering the option to clear the selection in all stack images. Clear by pressing [Backspace] to avoid this dialog.

See also: Clear Outside, Fill [f], Color Picker

24.8 Clear Outside

Erases the area outside the current image selection to the background color.

See also: Clear, Fill [f], Color Picker

24.9 Fill [f]

Fills the current selection with the current foreground color. With stacks, a dialog is displayed offering the option to fill the selection in all stack images. Fill the selection by pressing [F] to avoid this dialog.

See also: Clear, Draw [d], Color Picker

56
24.10 Draw [d]

Outlines the current selection using the current foreground color and line width. The foreground and background colors can also be set using the Edit>Options>Colors... command. Use the Edit>Options>Line Width... command, or double click on the line tool, to change the line width.

With stacks, a dialog is displayed offering the option to draw the selection in all stack images. Draw the selection by pressing $D$ to avoid this dialog.

See also: Analyze>Label, Color Picker, XIV, VIII

VIII Drawing Lines Wider Than One–Pixel

If the line width is an even number, the selection boundary is at the center of the line. If the line width is odd (1, 3, ...), the center of the line drawn is displaced from the selection edge by $1/2$ pixel to the bottom right. Thus the line center (the line in case of \textit{linewidth} = 1) is inside the selection at the top and left borders, but outside at the bottom and right borders. Rectangular selections (but not polygonal selections or traced selections that happen to be rectangular) are an exception to this rule: For rectangular selections, one–pixel wide outlines are always drawn inside the rectangle. Thicker lines are drawn as for the other selection types.

24.11 Invert [I]

Creates a reversed image, similar to a photographic negative, of the entire image or selection.

See also: Image>Lookup Tables>Invert LUT

24.12 Selection

24.12.1 Select All [a]

Creates a rectangular selection that is the same size as the image.

24.12.2 Select None [A]

Deactivates the selection in the active image.
ROI manipulations using the Edit > Selection > submenu commands.

24.12.3 Restore Selection [E]

Restores the previous selection to its original position. A selection is saved when you:

- Delete the selection by clicking outside of it
- Draw a new selection
- De-activate the image containing the selection
- Close the image containing the selection
- Use a command that deletes or modifies the selection

See also: Analyze > Tools > ROI Manager...

IX Transferring Selections Between Images

You can transfer a selection from one image to another by activating the image with the selection, activating the destination image, then pressing Shift E (the keyboard shortcut for Edit > Selection > Restore Selection [E]).

24.12.4 Fit Spline

Fits a cubic spline curve to a polygon or polyline selection.

24.12.5 Fit Circle

Fits a circle to a multipoint (with at least 3 points) or area selection [9]. Composite selections are not supported. With open shapes (lines and points), the fitting algorithm (Newton-based Pratt fit) described in Pratt V, “Direct least-squares fitting of algebraic surfaces”, Computer Graphics, Vol. 21, pp 145–152 (1987) is used. With closed shapes, the command creates a circle with the same area and centroid of the selection.
24.12.6  Fit Ellipse

Replaces an area selection with the best fit ellipse. The ellipse will have the same area, orientation and centroid as the original selection. The same fitting algorithm is used to measure the major and minor axis lengths and angle when Fit Ellipse is selected in Analyze ▶ Set Measurements...

See also: DrawEllipse macro

24.12.7  Convex Hull

Replaces a polygon of freehand selection with its convex hull, which can be thought of as a rubber band wrapped tightly around the points that define the selection.

See also: Fit Ellipse, ConvexitySolidarity macro, Convex_Hull_Plus plugin

24.12.8  Make Inverse

Creates an inverse selection. What is ‘inside’ the selection will be ‘outside’, and vice versa.

24.12.9  Create Mask

Creates a new 8–bit image called ‘Mask’ whose pixels have a value of 255 inside the selection and 0 outside. By default, this image has an inverting LUT, so black is 255 and white is 0 unless Black Background in Process ▶ Binary ▶ Options... is checked.

See also: Process ▶ Binary ▶ Convert to Mask, XVII

24.12.10  Create Selection

Creates a selection from a thresholded image or a binary mask [10].

24.12.11  Properties... [y]

Opens a dialog box that allows user to assign a contour color (Stroke Color) and a contour width (Width) to the active selection or a filling color. Note that selections can be either filled or contoured, but not both.

The nine default selection colors (black, blue, cyan, green, magenta, orange, red, white, yellow) can be typed as text. Any other color must be typed in hex notation (see Working With HEX Colors).
Similarly to the Analyze ▶ Tools ▶ ROI Manager..., selections can also be named using this command.

SEE ALSO: Selections, Image ▶ Overlay ▶ Add Selection... [b], XVI

24.12.12 Rotate...

Rotates the selection by the specified number of degrees (negative number indicate counter-clockwise rotation). This command runs the RotateSelection macro in ij.jar.

SEE ALSO: FlipSelection macro

24.12.13 Enlarge...

Grows an area selection by a specified number of pixels. Enter a negative value to shrink the selection. This command runs the EnlargeSelection macro in ij.jar. ShrinkSelection is a variation of this macro that does not shrink from the image edges.

X Converting Composite Selections

Enter zero in the Edit ▶ Selection ▶ Enlarge... dialog box to convert a composite selection into a polygon selection. Note, however, that the conversion may fail if the composite ROI is composed of more than one piece and/or contains internal holes.

24.12.14 Make Band...

Takes an area selection and creates a band with a thickness of the specified number of pixels. If you imagine the band as a doughnut shape, then the original selection corresponds to the hole (i.e. the band is made by growing out the original selection). This command runs the MakeSelectionBand macro in ij.jar.
24.12.15 Specify...  

Opens a dialog that allows you to define a rectangular or elliptical selection. *Width* and *Height* are the dimensions of the selection. *X Coordinate* and *Y Coordinate* define the position of the selection. Check *Oval* to create an elliptical selection. If *Centered* is checked, the selection is positioned so *X Coordinate* and *Y Coordinate* define the center of the selection, otherwise they define the upper left corner.

24.12.16 Straighten...

This command straightens a curved object in an image. The curved object must first be outlined using the segmented line tool. Use the *Image* > *Adjust* > *Line Width...* widget, opened by double clicking on the line tool icon, to adjust the width of the line selection. Check *Spline Fit* in the Line Width widget to fit a cubic spline curve to the points that define the line. With IJ 1.44k and later, it is not necessary to check the status of the *Spline Fit* checkbox since *Edit* > *Selection* > *Straighten...* will assess if the line has already been prepared for straightening by a `run("Fit Spline", "straighten")` call.

Drag the points along the line selection to reposition them. Alt-click on a point to delete it. Shift-click on a point to duplicate it. Press `[Shift]` + `[E]` (Edit > Selection > Restore Selection [E]) to restore accidentally deleted lines.

Straighten... also works with straight line selections. In this case, the object defined by the line selection is rotated to be horizontal.
24.12.17 To Bounding Box

Converts a non-rectangular selection to the smallest rectangle that completely contains it.

24.12.18 Line to Area

Converts a line selection to an area (traced) ROI. Straight lines must be wider than one pixel.

24.12.19 Add to Manager [t]

Adds the current selection to the ROI Manager (Analyze▸Tools▸ROI Manager…). If there is no selection the ROI Manager is open.

24.13 Options

Use commands in this submenu to change various ImageJ user preference settings.

24.13.1 Line Width…

Displays a dialog box that allows the width of lines generated by the Edit▸Draw [d] command to be changed. This legacy command has been superseded by the Image▸Adjust▸Line Width… widget.

24.13.2 Input/Output…

JPEG quality (0–100) Specifies the compression level used by File▸Save As▸Jpeg… Requesting a higher degree of compression (a lower value) will result in smaller files, but poorer image quality. Note that lossy JPEG compression creates serious artifacts, see II.

GIF and PNG transparent index Specifies the transparent color used for images saved in GIF and PNG formats. Use -1 for “none”. Note that PNG and GIF transparency only works with 8-bit images.
**File extension for tables** Sets the default extension to be used when saving tables (see The Results Table). Files with .txt and .xls extensions are saved in tab-delimited format and files with .csv extensions are saved in comma-delimited format.

**Use JFileChooser to open/save** Enables versions of File→Open and File→Save As that use the Java JFileChooser instead of the native OS file open and save dialogs. The main advantage of JFileChooser is the ability to open multiple files by shift-clicking to select multiple contiguous files and control-clicking to select more than one individual file. On the other hand, it is slower, uses more memory, and does not behave like the file open and save dialogs used in other applications.

**Save TIFF and raw in intel byte order** Specifies the byte order used when saving 16-bit and 32-bit images using File→Save As→Raw Data..., or File→Save As→Image Sequence... when Raw is chosen as the format. Check this option to export images using the order used by Intel x86 based processors (little-endian). This Wikipedia article has more information.

**Results Table Options** Specifies if column headers and row numbers should be saved or copied from ImageJ tables such as the Results and Summarize windows (see The Results Table).

24.13.3 Fonts...

Opens a small window with three pop-up menus for specifying the type face, size, style and antialiasing (Smooth checkbox) of the font used by the Text Tool.

![Fonts Dialog](image)

24.13.4 Profile Plot Options...

Use this dialog to control how plots generated by ImageJ are displayed (Image→Stacks→Plot Z-axis Profile..., Analyze→Plot Profile [k], Analyze→Calibrate..., Analyze→Tools→Curve Fitting..., etc.).
Plot Width and Plot Height Specify the length (in pixels) of the X-axis (Plot Width) and Y-axis (Plot Height).

Fixed y-axis Scale If checked, the Y-axis range is fixed and the specified Minimum Y and Maximum Y values are used, otherwise, plots are scaled based on the minimum and maximum gray values.

Do not Save x–values If checked, ‘List’, ‘Save...’ and ‘Copy...’ buttons will appear in profile plot windows.

Auto–close If checked, profile plot windows will be automatically closed when ‘List’, ‘Save’ and ‘Copy’ are clicked on.

Vertical Profile If checked, row average plots of rectangular areas (or line selections wider than 1 pixel) will be generated instead of the default column average plots. Note that evoking Plot Profile [k] with Alt [B] will generate vertical profiles.

List values If checked, the list of values will be automatically opened. If Auto–close is also checked, the plot is closed and only the list of values remains open.

Interpolate line profiles If checked, profile values will be interpolated along the line selection.

Draw grid lines If checked, gray grid lines will be drawn in the plot.


24.13.5 Arrow Tool... See Arrow Tool.

24.13.6 Point Tool... See Point Tool.

24.13.7 Wand Tool... See Wand Tool.
24.13.8 Colors...

Displays a dialog box that allows you to set *Foreground Color*, *Background Color* and *Selection Color*.

**See also:** Color Picker, Image ▶ Color ▶ Color Picker... [K], Point Tool

24.13.9 Appearance...

This dialog contains options that control how images are displayed, an option to display better looking toolbar icons, and an option to set the menu font size.

*Interpolate zoomed images* Uses interpolation instead of pixel replication when displaying zoomed images.

*Open Images at 100%* Newly open images are displayed using 100% magnification (1 image pixel = 1 screen pixel).

*Black Canvas* Causes the image canvas (white by default) to be rendered in black. This is useful when looking at X-ray images in order to avoid high contrasting intensities at the image edges.

*No image border* Displays images without the default one pixel wide black border.

*Use inverting lookup table* Causes newly opened 8–bit images to have inverted pixel values, where white=0 and black=255. This is done by both inverting the pixel values and inverting the LUT. Use the Image ▶ Lookup Tables ▶ Invert LUT command to invert an image without changing the pixel values.

*Double Buffer Selections* Reduces flicker when working with complex selections but it also increases memory usage and slows screen updates. It is not needed on Mac OS X, which has built in double buffering.

*Antialiased tool icons* Smooths and darken the tool icons in the ImageJ window. This option is enabled by default on all operating systems. On Windows XP, enable Clear Type sub-pixel anti-aliasing to improve the quality of text in menus.

*Menu font size* Specifies the size of the ImageJ window menu font. Use a size of 0 (zero) to use Java’s default menu font size. Changing the font size requires the restarting of ImageJ. This option is ignored on Mac OS X.

24.13.10 Conversions...

Use this dialog to set options that control how images are converted from one type to another.

**Scale When Converting** ImageJ will scale from min–max to 0–255 when converting from 16–bit or 32–bit to 8–bit or to scale from min–max to 0–65535 when converting from 32–bit to 16–bit. Note that *Scale When Converting* is always checked after ImageJ is restarted.

**Weighted RGB Conversions (0.30, 0.59, 0.11)** When checked, the formula $\text{gray} = 0.299 \times \text{red} + 0.587 \times \text{green} + 0.114 \times \text{blue}$ is used to convert RGB images to grayscale. If it is not checked, the formula $\text{gray} = (\text{red} + \text{green} + \text{blue})/3$ is used. The default weighting factors (0.299, 0.587, 0.114), which are based on human perception, are the ones used to convert from RGB to YUV, the color encoding system used for analog television. The weighting factors can be modified using the `setRGBWeights()` macro function.

24.13.11 Memory & Threads...

Use this dialog to specify the maximum amount of memory available to ImageJ and the number of threads used by filters when processing stacks. Java applications such as ImageJ will only use the memory allocated to them (typically 640MB) but this dialog allows the user to allocate more than the default.

Note that specifying more than 75% of real RAM could result in virtual RAM being used, which may cause ImageJ to become slow and unstable. Also note that this dialog cannot be used to set the memory allocation if ImageJ is run from the command line or by double clicking on `ij.jar`.

**Maximum Memory** 64-bit OS and a 64–bit version of Java are required to use more than \(\approx 1700\) MB of memory. Windows users must be running a 64–bit version of Windows and must install a 64–bit version of Java. Mac users must be running OS X 10.5 or later and may need to use the Java Preferences utility (in `/Applications/Utilities/Java`) to select a 64–bit version of Java. They may also need to switch to the ImageJ64 application. Linux users need to be running 64–bit versions of Linux and Java. The title of the Memory & Threads dialog box changes to Memory (64–bit) when ImageJ is running on a properly configured 64–bit system.
**Parallel Threads for Stacks** Defaults to the number of available processors determines the number of parallel threads used by commands in the Process\(\text{\textbullet~}\)Filters\(\text{\textbullet~}\) and the Process\(\text{\textbullet~}\)Math\(\text{\textbullet~}\) submenus when processing stacks.

**Run garbage collector on status bar click** If checked, forces the Java garbage collector to run every time the user clicks on the ImageJ status bar, which may help to reclaim unused memory (cf. Status bar).


See also: FAQ’s on the ImageJ Documentation Wiki

**24.13.12 Proxy Settings...**

Use this dialog to modify the proxy settings of the Java Virtual Machine. This may be required for ImageJ to connect to the internet in certain machines running behind HTTP proxies, that otherwise, e.g., wouldn’t be able to open the example images (File\(\text{\textbullet~}\)Open Samples\(\text{\textbullet~}\) submenu). Settings are saved in the ImageJ preferences file (IJ_Prefs.txt).

**24.13.13 Compiler...**

Displays a dialog box with options for the Plugins\(\text{\textbullet~}\)Compile and Run... command.

- **Target** Specifies the Java version of the class files. Plugins compiled with a Target of 1.6 will not run on earlier versions of Java. A Target of 1.4 should be used to create plugins capable of running on all ImageJ versions. Target cannot be set higher than the version of Java ImageJ is currently running on.

- **Generate Debugging Info (javac -g)** If checked, information needed by Java debuggers will be included in the class files.

24.13.14 DICOM...

This dialog sets options related to the handling of DICOM images. Namely, if ImageJ should open DICOM images as 32-bit float, if voxel depth should be calculated (based on the distance between the first and last slices) and if coronal/transverse sections should be mirrored when using the **Image** ➤ **Stacks** ➤ **Orthogonal Views** [H] command.

**See also:** Image Types and Image Formats

24.13.15 Misc...

Displays a dialog box containing miscellaneous options.

**Divide by zero value** Specifies the value used when **Process** ➤ **Image Calculator**... detects a divide by zero while dividing one 32-bit real image by another. The default is infinity. In addition to numeric values, ‘infinity’ (positive or negative infinity), ‘max’ (largest positive value) and ‘NaN’ (Not-a-Number) can be entered as the **Divide by zero value**.

**Use pointer cursor** If checked, ImageJ will use an arrow cursor instead of the default cross-hair that is sometimes difficult to see on grayscale images in areas of medium brightness. This option can also be used to work around a bug on Windows where the text cursor is sometimes used in place of the cross-hair.

**Hide "Process Stack?" dialog** If checked, ImageJ will suppress the dialog that asks ‘Process all xx slices?’ (only the current slice will be processed).

**Require control / command key for shortcuts** If checked, requires the Control key (Command key on Macs) to be pressed when using keyboard shortcuts for menu commands.

**Move isolated plugins to Misc. menu** This option can reduce the size of the Plugins menu, preventing it from running off the bottom of the screen. When this option is enabled, plugins that attempt install themselves in a submenu with only one command are instead installed in the **Plugins** ➤ **Miscellaneous** submenu. An example of such a plugin is TurboReg, which normally creates a **Plugins** ➤ **TurboReg** submenu that contains only one command.

**Run single instance listener** If checked, ImageJ will use sockets to prevent multiple instances from being launched. On Windows, this avoids the problem where
another copy of ImageJ starts each time an image is dragged and dropped on the ImageJ icon. It also prevents multiple instances when running ImageJ from the command line. Note that you may get a security alert the first time ImageJ starts with this option enabled. ImageJ does not require external socket access so it is okay to deny it access in the security alert.

**Debug mode** If checked, causes ImageJ to display debugging messages in the ‘Log’ window. Close the ‘Log’ window to disable display of debugging messages.

25  **Image**

25.1  **Type**

Use this submenu to determine the type of the active image or to convert it to another type. An attempt to perform an unsupported conversion causes a dialog box to be displayed that lists the possible conversions.

<table>
<thead>
<tr>
<th>Supported conversions in ImageJ (Image Type submenu).</th>
<th>8-bit</th>
<th>16-bit</th>
<th>32-bit</th>
<th>8-bit color</th>
<th>RGB color</th>
<th>RGB stack</th>
<th>HSB stack</th>
</tr>
</thead>
<tbody>
<tr>
<td>8-bit</td>
<td>...</td>
<td>I, S</td>
<td>I, S</td>
<td>I, S</td>
<td>I, S</td>
<td>I, S</td>
<td>I, S</td>
</tr>
<tr>
<td>16-bit</td>
<td>I, S</td>
<td>...</td>
<td>I, S</td>
<td>I, S</td>
<td>I, S</td>
<td>I, S</td>
<td>I, S</td>
</tr>
<tr>
<td>32-bit</td>
<td>I, S</td>
<td>I, S</td>
<td>...</td>
<td>I, S</td>
<td>I, S</td>
<td>I, S</td>
<td>I, S</td>
</tr>
<tr>
<td>8-bit color</td>
<td>I, S</td>
<td>...</td>
<td>...</td>
<td>I</td>
<td>I, S</td>
<td>I, S</td>
<td>I, S</td>
</tr>
<tr>
<td>RGB color</td>
<td>I, S</td>
<td>I, S</td>
<td>...</td>
<td>I, S</td>
<td>I, S</td>
<td>I, S</td>
<td>I, S</td>
</tr>
<tr>
<td>RGB stack</td>
<td></td>
<td></td>
<td></td>
<td>I</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>HSB stack</td>
<td></td>
<td></td>
<td></td>
<td>I</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

I: Single images only; S: Stacks

**8-bit** Converts to 8-bit grayscale. ImageJ converts 16-bit and 32-bit images and stacks to 8-bits by linearly scaling from min–max to 0–255, where min and max are the two values displayed in the **Image Adjust** Brightness/Contrast... [C]. **Image Show Info... [i]** displays these two values as Display range. Note that this scaling is not done if Scale When Converting is not checked in **Edit** Options Conversions... RGB images are converted to grayscale using the formula gray = (red + green + blue)/3 or gray = 0.299 \times red + 0.587 \times green + 0.114 \times blue if Weighted RGB Conversions is checked in **Edit** Options Conversions...

**16-bit** Converts to unsigned 16-bit grayscale.

**32-bit** Converts to signed 32-bit floating-point grayscale.

**8-bit Color** Converts to 8-bit indexed color using Heckbert’s median-cut color quantization algorithm. A dialog box allows the number of colors (2–256) to be specified. The active image must be RGB color.

**RGB Color** Converts to 32-bit RGB color.

**RGB Stack** Converts to a 3-slice (red, green, blue) stack. The active image must be RGB color.
**HSB Stack** Converts to a 3–slice (hue, saturation and brightness) stack. The active image must be RGB color.

### 25.2 Adjust

This submenu contains commands that adjust brightness/contrast, threshold levels and image size.

#### XI Applying Auto Brightness/Contrast to Entire Stacks

The **Process** > *Enhance Contrast* command can be used to adjust the brightness and contrast of each slice in a stack, according to either the optimal for each individual slice (if **Use Stack Histogram** is unchecked) or the overall stack (if **Use Stack Histogram** is checked). The default behavior of the B&C tool (**Image** > **Adjust** > *Brightness/Contrast...* [C]) is to use the overall stack histogram.

#### XII Brightness/Contrast of High Bit–Depth Images

When displayed, the intensity of each pixel that is written in the image file is converted into the grayness of that pixel on the screen. How these intensities are interpreted is specified by the image type. From the ImageJ website:

16–bit and 32–bit grayscale images are not directly displayable on computer monitors, which typically can show only display 256 shades of gray. Therefore, the data are mapped to 8–bit by windowing. The window defines the range of gray values that are displayed: values below the window are made black, while values above the window are white. The window is defined by minimum and maximum values that can be modified using **Image** > **Adjust** > *Brightness/Contrast...* [C].

It may happen that the initial windowing performed by ImageJ on these high bit–depth (or HDR) images is suboptimal. Please note that windowing does not affect image data (cf. the HDRexplorerTool).

#### 25.2.1 Brightness/Contrast... [C]

Use this tool to interactively alter the brightness and contrast of the active image. With 8–bit images, brightness and contrast are changed by updating the image’s lookup table (LUT), so pixel values are unchanged. With 16–bit and 32–bit images, the display is updated by changing the mapping from pixel values to 8–bit display values, so pixel
brightness and contrast of RGB images are changed by modifying the pixel values.

**Histogram** The line graph at the top of the window, which is superimposed on the image’s histogram, shows how pixel values are mapped to 8-bit (0–255) display values. The two numbers under the plot are the minimum and maximum displayed pixel values. These two values define the display range, or ‘window’. ImageJ displays images by linearly mapping pixel values in the display range to display values in the range 0–255. Pixels with a value less than the minimum are displayed as black and those with a value greater than the maximum are displayed as white.

**Minimum and Maximum sliders** Control the lower and upper limits of the display range. Holding down Shift will simultaneously adjust all channels of a composite image (e.g., File Open Samples HeLa Cells (1.3 M, 48-bit RGB)).

**Brightness slider** Increases or decreases image brightness by moving the display range. Holding down Shift will simultaneously adjust all channels of a composite image.

**Contrast slider** Increases or decreases contrast by varying the width of the display range. The narrower the display range, the higher the contrast. Holding down Shift will simultaneously adjust all channels of a composite image.

**Auto** ImageJ will automatically optimize brightness and contrast based on an analysis of the image’s histogram. Create a selection, and the entire image will be optimized based on an analysis of the selection. The optimization is done by allowing a small percentage of pixels in the image to become saturated (displayed as black or white). Each additional click on Auto increases the number of saturated pixels and thus the amount of optimization. A run("Enhance Contrast", "saturated=0.35") macro call is generated if the command recorder is running.

**Reset** Restores the original brightness and contrast settings. The display range is set to the full pixel value range of the image. A resetMinAndMax() macro call is generated if the command recorder is running. Holding down Shift restores original settings in all channels of a composite image.

**Set** Allows to enter the minimum and maximum display range values in a dialog box. A setMinAndMax() macro call is generated if the command recorder is running. Check Propagate to all open images to apply these values to the rest of the images currently open.

A 16-bit image consists of 65536 possible gray levels. Most of times, however, the relevant image information is contained only within a narrow range of the grayscale. This is the case, e.g., in low light microscopy, in which signal is restricted to the
lower end of the grayscale. The *Set Display Range* dialog allows you to choose how to scale the range of gray levels of 16–bit images.

![Set Display Range dialog](image)

**Automatic** Automatically selects the best range given the intensity values of the image based on the percentage of the total number of pixel values from the lowest to highest pixel value.

- **8–bit (0–255)** Gray level range of 0–255.
- **10–bit (0–1023)** Gray level range of 0–1023.
- **12–bit (0–4095)** Gray level range of 0–4095.
- **15–bit (0–32767)** Gray level range of 0–32767.
- **16–bit (0–65535)** Gray level range of 0–65535.

**Apply** Applies the current display range mapping function to the pixel data. If there is a selection, only pixels within the selection are modified. This option currently only works with 8–bit images and stacks and with RGB stacks. **This is the only B&C option that alters the pixel data of non-RGB images.**

**See also:** Window/Level..., Enhance Contrast, XI, XIII

### 25.2.2 Window/Level...

This command interactively adjusts the *Window* – range of minimum and maximum (*Contrast*) – and *Level* – position of that range in the grayscale intensity space (*Brightness*) – of the active image in a manner closer to that implemented on medical image terminals.

Being redundant with the *Brightness/Contrast...* [C] tool, if the *B&C* window is opened, it will be closed and the *W&L* window will be opened at the same location.
XIII  Display Range of DICOM Images

With DICOM images, ImageJ sets the initial display range based on the Window Center (0028,1050) and Window Width (0028,1051) tags. Click Reset on the W&L (Image ▶ Adjust ▶ Window/Level...) or B&C (Image ▶ Adjust ▶ Brightness/Contrast...) window and the display range will be set to the minimum and maximum pixel values.

As an example, the File ▶ Open Samples ▶ CT (420K, 16-bit DICOM) image has a Window Center of 50 and Window Width of 500, so the display range is set to -200 to 300 (center-width/2 to center+width/2). Click Reset and the display range is set to -719 to 1402. Press H (Analyze ▶ Histogram [h]) and you will see that the minimum pixel value in the image is -719 and the maximum is 1402.

To display the DICOM tags, press I (Image ▶ Show Info... [i]). Press R (File ▶ Revert [r]) to revert to the initial display range.

See also:  Brightness/Contrast... [C]

25.2.3  Color Balance...

This panel makes adjustments to the brightness and contrast of a single color of a standard RGB image (8-bit per color channel). For multi-channels stacks and hyperstacks it adjusts each of the color channels independently. Use the drop-down menu to specify which color/channel will be adjusted (the histogram is drawn for the selected color).

Maximum and Minimum sliders, Auto, Set and Apply work as described for Image ▶ Adjust ▶ Brightness/Contrast... [C]. Similarly to the Window/Level... tool, if the B&C window is opened, it will be closed and the Color window will be opened at the same location.

NB: When switching from one color to another, the changes made to one color will be lost unless Apply is clicked before. Also, note that for 48-bit color images that load as a stack, Brightness/Contrast... [C] works on single stack slices, i.e., colors, and the color settings of the Color panel are ignored.

See also:  Brightness/Contrast... [C], Color ▶ submenu
25.2.4 Threshold... [T]

Use this tool to automatically or interactively set lower and upper threshold values, segmenting grayscale images into features of interest and background. Use Analyze > Measure... [m]) (with Limit to Threshold in Analyze > Set Measurements... checked) to measure the aggregate of the selected features. Use Analyze > Analyze Particles... to measure features individually. Use the Wand Tool to outline a single feature.

**Upper slider** Adjusts the minimum threshold value. Hold [Shift] while adjusting the minimum to move a fixed-width thresholding window across the range of gray values.

**Lower slider** Adjusts the maximum threshold value.

**Method** Allows any of the 16 different automatic thresholding methods to be selected [12]. These methods are described on Fiji’s Auto Threshold website (http://pacific.mpi-cbg.de/wiki/index.php/Auto_Threshold). The Default method is the modified IsoData method used by ImageJ 1.41 and earlier.

**Display** Selects one of three display modes:

- **Red** Displays the thresholded values in red.
- **B&W** Features are displayed in black and background in white. This mode respects the Black background flag set in Process > Binary > Options...
**Over/Under** Displays pixels below the lower threshold value in blue, thresholded pixels in grayscale, and pixels above the upper threshold value in green. These colors can be changed from a macro by calling the `ImageProcessor.setOverColor()` and `setUnderColor()` methods (example).

**Dark background** To be checked when features are lighter than the background. With IJ 1.44i and later, the state of the checkbox is remembered across restarts.

**Auto** Uses the currently selected thresholding method to automatically set the threshold levels based on an analysis of the histogram of the current image or selection.

**Apply** Sets thresholded pixels to black and all other pixels to white. For 32-bit float images **Apply** will also run **Process** > **Math** > **NaN Background**.

**Reset** Disables thresholding and updates the histogram.

**Set** New threshold levels can be entered into this dialog box.

See also: XVI

### 25.2.5 Color Threshold...

Thresholds 24-bit RGB images based on Hue Saturation and Brightness (HSB), Red Green and Blue (RGB), CIE Lab or YUV components. Ranges of the filters can be set manually or based on the pixel value components of a user-defined ROI (experimental). This command, implemented in version 1.43l, is a built-in version of the Threshold Colour plugin [14]. Note that the final thresholded image type is RGB, not 8-bit gray.
Segmentation of DAPI stained nuclei using Image > Adjust > Color Threshold...

**Pass** If checked, values within range are thresholded and displayed (band-pass filter), otherwise, values outside the selected range are thresholded (band-reject filter).

**Thresholding Method** Allows any of the 16 different automatic thresholding methods to be selected (cf. Threshold... [T]).

**Threshold Color** Selects the threshold color: either Red, Black, White or Black & White (cf. Threshold... [T]).

**Color space** Selects the color space: HSB, RGB, CIE Lab or YUV.

**Dark background** To be checked when features are lighter than the background. With IJ 1.44i and later, the state of the checkbox is remembered across restarts.

**Original** Restores the original image and updates the buffer when switching to another image.

**Filtered** Shows the filtered image.

**Select** Creates a ROI selection based on the current settings. The selection is made according to the settings defined in the Process > Binary > Options... dialog.

**Sample** (Experimental) Sets the ranges of the filters based on the pixel value components in a user-defined ROI.

**Stack** Processes the rest of the slices in a stack (if any) using the current settings.
**Macro** Creates a macro based on the current settings which is sent to the Macro Recorder window (Plugins▶Macros▶Record...) , if open.

**Help** Opens Color Threshold...’s built-in help.

See also: 3D Color Inspector/Color Histogram

### 25.2.6 Size...

Scales the active image or selection to a specified Width and Height in pixels.

Check Constrain aspect ratio and ImageJ will adjust either the Height or the Width to maintain the original aspect ratio. When applicable, other dimensions can also be resized: Depth (images) in stacks, Depth (slices) and Time (frames) in hyperstacks.

Check the Average when downsizing checkbox for better results when scaling down images [13].

Two resampling methods are possible: Bilinear and Bicubic interpolation. The implementation of the bicubic method (Catmull-Rom interpolation) is derived from Burger and Burge, 2009 [47].

See also: Image▶Scale... [E]

### 25.2.7 Canvas Size...

Changes the canvas size of an image or stack without scaling the actual image. Width and Height may be either expanded or contracted.

If the canvas size is increased, the border is filled with the current background color, or, if Zero Fill is checked, the border is filled with pixels that have a value of zero. The position of the old image within the new canvas may also be specified.

See also: Size..., Color Picker... [K], XIV
25.2.8 Line Width...

This widget is used to adjust the width of line selections. It is opened more easily by double clicking on the Line Selection Tools icon. Checking Spline Fit fits a cubic spline curve to the points that define the line.

See also: Edit ▶ Options ▶ Line Width..., Edit ▶ Selection ▶ Fit Spline

25.3 Show Info... [i]

Opens a text window containing information about the active image (including the pixel or voxel size, since IJ1.44k). For DICOM and FITS images, also displays file header information. Use the popup menu (right-click in the Info window) to save the information to a text file or copy it to the system clipboard.

See also: Image ▶ Properties... [P]

25.4 Properties... [P]

Use this command to display and set various properties of the current image or stack.

The number of Channels (c), Slices (z) and Frames (t) in the image can be changed as long as the product of c, z, and t is equal to the number of images in the stack.

The Unit of Length (a string describing the measuring unit), Pixel Width, Pixel Height and Voxel Depth (all in the Unit of Length unit) can be set.

Width, Height and Depth are automatically converted if Unit of Length is changed from one known unit (‘nm’, ‘um’, ‘µm’, ‘micron’, ‘mm’, ‘cm’, ‘meter’, ‘km’ or ‘inch’) to another.

With t-series stacks, the Frame Interval in seconds (reciprocal of the frame rate) can be viewed and set. Since IJ1.43, setting the Frame Interval sets the frame rate used by Animation Options... [Alt /] as long as the unit used is ‘sec’.
Origin (always in pixels) is the reference point (0, 0) of the image coordinate system (see also Analyze\textsuperscript{\textgreater} Set Measurements…).

Check Global to make the current settings global (i.e., apply to all images opened during the current session, cf. XVIII).

See also: Image\textsuperscript{\textgreater} Show Info… [i], Image\textsuperscript{\textgreater} Scale… [E], Analyze\textsuperscript{\textgreater} Set Scale…

25.5 Color\textsuperscript{\textgreater}

This submenu contains commands that deal with color images.

25.5.1 Split Channels

Splits an RGB image (or stack) into three 8–bit grayscale images containing the red, green and blue components of the original. The window names have an appended \textit{(red)}, \textit{(green)} and \textit{(blue)}. With composite images and / or hyperstacks (e.g., File\textsuperscript{\textgreater} Open Samples\textsuperscript{\textgreater} Organ of Corti (2.8M, 4D stack)) this command splits the stack into separate channels.

See also: Merge Channels…

25.5.2 Merge Channels…

Merges 1–4 grayscale images or stacks into an RGB image or stack. Select *None* to keep a channel empty (filled with 0).

Check Keep Source Images if you wish to keep the originals. Check Create Composite to convert 2–4 grayscale images or stacks into a composite image or hyperstack (see Color Composites). With IJ1.44n and later, LUTs and display ranges are preserved if Create Composite is chosen.

See also: Channels… [Z]

25.5.3 Channels Tool… [Z]

Alias for Image\textsuperscript{\textgreater} Hyperstacks\textsuperscript{\textgreater} Channels… [Z].

25.5.4 Stack to RGB

Converts a two or three slice stack into an RGB image, assuming that the slices are in R, G, B order. The stack must be 8–bit or 16–bit grayscale. Also converts composite images (e.g., File\textsuperscript{\textgreater} Open Samples\textsuperscript{\textgreater} HeLa Cells (1.3M, 48-bit RGB)) into RGB.
25.5.5 Make Composite

Converts in place an RGB image, a 2–7 image stack or a 2–7 channel hyperstack into a composite color image. Use the Channels... [Z] tool ([Shift] [Z]) to enable and disable the channels of a composite image. Use Brightness/Contrast... [C] ([Shift] [C]) to adjust the brightness and contrast of the current channel.

25.5.6 Show LUT

Displays a plot of the active image’s lookup table (LUT). The lookup table, or color table, describes the color that is displayed for each of the 256 possible pixel values. For 16 and 32-bit images, the range of displayed pixel values is mapped to 0–255. A bar under the plot displays the color representation of the pixel values. Note that RGB color images do not use a lookup table. Use the List... radio button to export the LUT as a CSV file.

See also: Edit LUT...

25.5.7 Edit LUT...

Opens the ImageJ LUT (Lookup Table) Editor. A lookup table in ImageJ has up to 256 entries. The entry index, and the three values (red, green and blue) associated with it, are displayed in the ImageJ status bar as you move the cursor over the LUT Editor window. Click on an entry to edit the red, green and blue values for that entry using a Color Selector window (cf. Color Picker... [K]).

See also: Show LUT

25.5.8 Color Picker... [K]

The Color Picker tool [11] enables the user to select foreground and background colors, which affect Edit>Fill [f], Edit>DRAW [d] and other color drawing commands. It displays current foreground and background colors in the selection boxes at the bottom of the window. It has two modes: Foreground and Background. To change modes, click on the
desired selection box. Clicking on the Foreground/Background Switcher button sets the current foreground to the background and vice versa. The Black/White Reset button sets the foreground to black and the background to white.

The color palette is based on HSB (Hue, Saturation and Brightness) color model. Hue increases as you go down the palette while saturation and brightness values are split horizontally. The left half of the palette varies only in brightness while the right half varies only in saturation. At the center of the color ramp are enlarged red, green, blue, cyan, magenta, and yellow colors for quick selection. To the left of the color palette is a grayscale ramp that goes from pure black to pure white.

Double clicking on a color brings up one of the Color Selectors, shown on the right in the illustration. Use the sliders to specify the RGB values of the foreground or background color. To get precise colors, manually change the values in the text boxes. The title of the Color Selector window (Foreground Color or Background Color) indicates the current selection mode.

See also: XIV, Draw [d], Fill [f], Clear, Clear Outside, Image Types and Image Formats

25.6 Stacks

This submenu contains commands that work with stacks.

25.6.1 Add Slice

Inserts a blank slice after the currently displayed slice. Holding [Alt] inserts a blank slice before the current slice.
Embedding Color Annotations in Grayscale Images

Color marks are only available with color images or grayscale images that have been converted to RGB. For non-RGB images, background/foreground color will be painted in equivalent gray levels, e.g.: In a 8-bit image, if the foreground color is red (RGB: 255, 0, 0) intensity of drawn selections will be $(255 + 0 + 0)/3 = 85$. Although this issue can be overcome by converting the image into RGB (Image Type submenu), the easiest way to embed true color selections in grayscale images is to use the Image Overlay Add Selection... [b] command followed by Image Overlay Flatten [F].

25.6.2 Delete Slice

Deletes the currently displayed slice.

25.6.3 Next Slice [>]

Displays the slice that follows the currently displayed slice. Holding $\text{Alt } [>]$ will skip nine slices forward.

See also: Arrow Keys

25.6.4 Previous Slice [<]

Displays the slice that precedes the currently displayed slice. Holding $\text{Alt } [<]$ will skip nine slices backward.

See also: Arrow Keys

25.6.5 Set Slice...

Displays a specified slice. The user must enter a slice number greater than or equal to one and less than or equal to the number of slices in the stack.

25.6.6 Images To Stack

Creates a new stack from images currently displayed in separate windows.
Method If images differ in size, a drop-down menu allows to choose a conversion method:

Copy (center / top-left) Stack will have the width of the widest open image and the height of the highest open image. Smaller images will then be copied (either to the center or to the upper left corner) of the slice. Borders are filled with pixels that have a value of zero.

Scale (smallest / largest) Stack will have the dimensions of the smallest / largest open image. Other images are scaled to the new slice dimensions. Bicubic interpolation is used if Bicubic interpolation is checked (cf. Image Size... and Image Scale... [E]).

Name Specifies the title of the stack to be created.

Title Contains Enter a string into this field and ImageJ will only convert to stack images whose name contains that string.

Bicubic Interpolation If checked, bicubic interpolation (cf. Adjust Size...) will be used if any of the Scale methods was previously chosen.

Use Title as Labels If checked, image titles (without extension) will be used as stack labels.

Keep Source Images If checked, original images are kept.

25.6.7 Stack To Images

Converts the slices in the current stack to separate image windows.

25.6.8 Make Montage

Produces a single image which contains the images from a stack displayed in a grid format. This can be useful for visual comparisons of a series of images stored in a stack and to create ‘panel figures’. With hyperstacks – that are not directly supported –, instructions are displayed that explain how to create c, z or t montages. A dialog box allows you to specify the magnification level at which the images are copied, and to select the layout of the resulting grid.
**Label Slices**  If checked, images are be labeled in the panel. If no slice metadata exists (the `setMetadata("Label", string)` macro function can be used to customize slice labels) images are labeled with slice numbers. Note that the Label... command can also be used to draw labels in stack slices.

**Use Foreground Color**  If checked, borders and labels are drawn in the foreground color and blank areas of the panel are filled with the background color.

---

**See also:**  Stacks▷Tools▷Montage to Stack... command, RC Montage plugin, Magic Montage — a macro toolset to reorder and manipulate images in the montage (a video tutorial can be found [here](#))

---

### 25.6.9  Reslice... [/]

Reconstructs one or more orthogonal slices through the image volume represented by the current stack or hyperstack [15].

The estimated size of the output stack and the amount of available memory are displayed at the bottom of the dialog. Increase *Output spacing* to reduce the size of the output stack.

A dialog allows you to specify the spacing of the reconstructed slices.

**Output spacing**  Determines the number of orthogonal slices that will be reconstructed. Increasing *Output spacing* reduces the size of the output stack.
**Start at** Determines the image edge (top, left, bottom or right) from which reconstruction starts. Start at is replaced by **Slice count** if there is a line selection. With lines selections, a stack is created by shifting (by **Output spacing**) the line down and to the left to generate additional slices for the output stack. In this case, the size of the output stack in determined by **Slice count**.

**Flip vertically** If checked, each slice in the output stack will be flipped vertically.

**Rotate 90 degrees** If checked, each slice in the output stack will be rotated 90°.

**Avoid interpolation** If checked, no interpolation will be done.


See also: Dynamic Reslice and Radial Reslice plugins

### 25.6.10 Orthogonal Views [H]

Provides an orthogonal view display of the current stack or hyperstack [16]. E.g., if a stack displays sagittal sections, coronal (YZ projection image) and transverse (XZ projection image) will be displayed through the data-set.

The two extra planar views are displayed in ‘sticky’ panels next to original image and can be toggled using `Shift` `H`, the command shortcut.

The intersection point of the three views follows the location of the mouse click and can be controlled by clicking and dragging in either the XY, XZ or YZ view. XY and XZ coordinates are displayed in the title of the projection panels. The mouse wheel changes the screen plane in all three views.

Voxel dimensions can be adjusted in **Image** ➤ **Properties...** [P].

See also: 3D Project... and 3D Viewer [9], Volume Viewer, Stack Slicer Display3_TP plugins, **Edit** ➤ **Options** ➤ DICOM...
25.6.11 Z Project...

Projects an image stack along the axis perpendicular to image plane (the so-called z axis) [15]. Five different projection types are supported. With ImageJ 1.44l and later, the preferred projection method is stored in the preferences file.

**Average Intensity** projection outputs an image wherein each pixel stores average intensity over all images in stack at corresponding pixel location.

**Average Intensity** projection outputs an image wherein each pixel stores average intensity over all images in stack at corresponding pixel location.

**Maximum Intensity** projection (MIP) creates an output image each of whose pixels contains the maximum value over all images in the stack at the particular pixel location.

**Sum Slices** projection creates a real image that is the sum of the slices in the stack.

**Standard Deviation** projection creates a real image containing the standard deviation of the slices.

**Median** projection outputs an image wherein each pixel stores median intensity over all images in stack at corresponding pixel location.

See also: Grouped Z Project..., 3D Project..., Plot Z-axis Profile...
25.6.12 3D Project...

This command creates a sequence of projections of a rotating volume (stack or hyperstack) onto a plane using nearest-point (surface), brightest-point, or mean-value projection or a weighted combination of nearest point projection with either of the other two methods (partial opacity) [17]. The user may choose to rotate the volume about any of the three orthogonal axes (x, y, or z), make portions of the volume transparent (using thresholding), or add a greater degree of visual realism by employing depth cues.

Each frame in the animation sequence is the result of projecting from a different viewing angle. To visualize this, imagine a field of parallel rays passing through a volume containing one or more solid objects and striking a screen oriented normal to the directions of the rays.

Each ray projects a value onto the screen, or projection plane, based on the values of points along its path. Three methods are available for calculating the projections onto this plane: nearest-point, brightest-point, and mean-value. The choice of projection method and the settings of various visualization parameters determine how both surface and interior structures will appear.

**Projection Method** Select Nearest Point projection to produce an image of the surfaces visible from the current viewing angle. At each point in the projection plane, a ray passes normal to the plane through the volume. The value of the nearest non transparent point which the ray encounters is stored in the projection image. Brightest Point projection examines points along the rays, projecting the brightest point encountered along each ray. This will display the brightest objects, such as bone in a CT (computed tomographic) study. Mean Value projection, a modification of brightest–point projection, sums the values of all transparent points along each ray and projects their mean value. It produces images with softer edges and lower contrast, but can be useful when attempting to visualize objects contained within a structure of greater brightness (e.g. a skull).

**Slice Spacing** The interval, in pixels, between the slices that make up the volume. ImageJ projects the volume onto the viewing plane at each Rotation Angle Increment, beginning with the volume rotated by Initial Angle and ending once the volume has been rotated by Total Rotation.

**Lower/Upper Transparency Bound** Determine the transparency of structures in the volume. Projection calculations disregard points having values less than the
lower threshold or greater than the upper threshold. Setting these thresholds permits making background points (those not belonging to any structure) invisible. By setting appropriate thresholds, you can strip away layers having reasonably uniform and unique intensity values and highlight (or make invisible) inner structures. Note that you can also use Image > Adjust > Threshold... [T] to set the transparency bounds.

**Opacity** Can be used to reveal hidden spatial relationships, specially on overlapping objects of different colors and dimensions. The (surface) Opacity parameter permits the display of weighted combinations of nearest-point projection with either of the other two methods, often giving the observer the ability to view inner structures through translucent outer surfaces. To enable this feature, set Opacity to a value greater than zero and select either Mean Value or Brightest Point projection.

**Surface / Interior Depth-Cueing** Depth cues can contribute to the three-dimensional quality of projection images by giving perspective to projected structures. The depth-cueing parameters determine whether projected points originating near the viewer appear brighter, while points further away are dimmed linearly with distance. The trade-off for this increased realism is that data points shown in a depth-cued image no longer possess accurate densitometric values. Two kinds of depth-cueing are available: Surface Depth-Cueing and Interior Depth-Cueing. Surface Depth-Cueing works only on nearest-point projections and the nearest-point component of other projections with opacity turned on. Interior Depth-Cueing works only on brightest-point projections. For both kinds, depth-cueing is turned off when set to zero (i.e. 100% of intensity in back to 100% of intensity in front) and is on when set at $0 < n < 100$ (i.e. $(100-n)%$ of intensity in back to 100% intensity in front). Having independent depth-cueing for surface (nearest-point) and interior (brightest-point) allows for more visualization possibilities.

**Interpolate** Check Interpolate to generate a temporary z-scaled stack that is used to generate the projections. Z-scaling eliminates the gaps seen in projections of volumes with slice spacing greater than 1.0 pixels. This option is equivalent to using the Scale plugin from the TransformJ package to scale the stack in the z-dimension by the slice spacing (in pixels). This checkbox is ignored if the slice spacing is less than or equal to 1.0 pixels.

See also: Orthogonal Views [H], Z Project…, Grouped Z Project… and 3D Viewer [9], Volume Viewer plugins
25.6.13 Plot Z-axis Profile...

Plots the ROI selection mean gray value versus slice number. Requires a point or area selection.

Coordinates of the upper left corner of the selection (or the bounding rectangle for non-rectangular selections) are displayed in the graph title.

See also: Profile Plot Options..., Plot Profile [k]

25.6.14 Label...

Adds a sequence of numbers (e.g., timestamps) and/or a label to a stack or hyperstack. Numbers and label are drawn in the current foreground color (cf. Image> Colors> Color Picker... [K]).

The initial X, Y location, and Font size of the label are based on the existing rectangular selection, if any. Slices outside the Range are not affected.

**Format** Specifies the structure of the label. 0: Unpadded sequence; 0000: Pads each number with leading zero(s); 00:00: Converts the label into a minutes:seconds timestamp; 00:00:00 Converts the label into a hours:minutes:seconds timestamp; Text: Stamps only the contents of the Text field.

**Starting value and Interval** Specify the first value and the numeric steps to be applied. Note that with timestamps, metric time values must be used, e.g., an Interval of 3600 will create 1 hour increments.

**Text** The string to be drawn after each number when the Format chosen is either 0 or Text (label without numeric sequence).

**Use overlay** If checked, labels will be created as non-destructive image overlays. Note that previously added overlays will be removed.


See also: Make Montage, Stacks> Tools> Insert...
25.6.15  Tools

25.6.15.1  Combine...

Combines two stacks \([Width \times Height \times Depth]\) \((W_1 \times H_1 \times D_1 \text{ and } W_2 \times H_2 \times D_2)\) to create a new \(W_1+W_2 \times \max(H_1,H_2) \times \max(D_1,D_2)\) stack. E.g., a \(256 \times 256 \times 40\) and a \(256 \times 256 \times 30\) stack would be combined to create one \(512 \times 256 \times 40\) stack.

If Combine vertically is enabled, creates a new \(\max(W_1+W_2) \times (H_1+H_2) \times \max(D_1,D_2)\) stack.

Unused areas in the combined stack are filled with background color (cf. Color Picker... [K]).

See also: Concatenate...

25.6.15.2  Concatenate...

Concatenates two images or stacks that have the same width, height and data type.

See also: Combine...

25.6.15.3  Reduce...

Reduces the size of stacks and hyperstacks by the specified Reduction Factor. E.g., For a 30 slices stack and a Reduction Factor of 2, the reduced stack will be composed of 15 slices with every second slice being removed. Virtual stacks/hyperstacks are supported.

With Hyperstacks, the default reduction is performed in the T-Dimension, but a choice is available to Reduce in Z-Dimension instead.

See also: Hyperstacks\>Reduce Dimensionality...

25.6.15.4  Reverse

Alias for the Image\>Transform\>Flip Z command.
25.6.15.5 Insert...

Inserts an image or stack into a stack at the specified X and Y Location. The Source Image or Stack must be of the same type as the Destination Stack.

See also: Image→Stacks→Label...

25.6.15.6 Montage to Stack...

Converts a montage image to an image stack based on the specified number of rows and columns, taking into account a Border width. This is the opposite of what the Image→Stacks→Make Montage command does.

See also: Demontager plugin

25.6.15.7 Make Substack...

Extracts selected images from the active stack copying them to a new stack in the order of listing or ranging [18].

It takes one of three types of input: 1) A range of images (e.g. 2–14); 2) A range of images with increment (e.g. 2–14–2) or 3) a list of images (e.g. 2, 4, 7, 9, 14).

Currently, it does not work with hyperstacks.

See also: Image→Duplicate... [D]

25.6.15.8 Grouped Z Project...

Creates a substack of Stack size/Group size slices with each slice being the result of a Z Projection performed over the range of Group size. Note that Group size must divide evenly into the stack size.

See also: Image→Stacks→Z Project...
25.6.15.9  Start Animation

Animates the active stack by repeatedly displaying its slices (frames) in sequence. It is run more easily by clicking on the play icon preceding stack sliders (see Stacks). To stop the animation, click on the slider pause icon, click on the image or use Stop Animation, evoked by the same shortcut. As such, stacks animation can be toggled using . The frame rate is displayed in the status bar. Open the Animation Options... dialog box to specify the animation speed (pressing or right-clicking on the on the slider play/pause icon opens the Animation Options... dialog). Note that more than one stack can be animated at a time.

25.6.15.10  Stop Animation

Terminates animation of the active stack (see Start Animation).

25.6.15.11  Animation Options...  [Alt /]

Use this dialog to set the animation speed in frames per second, the starting and ending frame, or to enable ‘oscillating’ animations. Selecting Start Animation animates the stack as soon as the dialog is dismissed.

Note that with IJ.43 and later, setting the Frame Interval in Image Properties... sets the animation speed as long as the unit used is ‘sec’.

This dialog can also be accessed by right-clicking on the play/pause icon that precedes stack sliders and hyperstack slice sliders (see Stacks).

See also:  File  Save As  Gif..., AVI...

25.7  Hyperstacks

This submenu contains commands that work with hyperstacks, images that have four (4D) or five (5D) dimensions (see Stacks).
25.7.1 New Hyperstack...

Creates a new hyperstack. Hyperstacks have Width, Height, Channels (c dimension), Slices (z dimension) and time Frames (t dimension).

Image Type (see Image Type) and Display Mode (see Channels... [Z]) can be specified.

Checking Label Images will draw the channel number, slice number and frame number on each image in the hyperstack.

File > New > Hyperstack... is an alias of this command.

SEE ALSO: Hyperstacks

25.7.2 Stack to Hyperstack...

Converts a stack into a hyperstack. RGB stacks are converted into 3 channel hyperstacks.

Order is the order of the channels (c), slices (z) and frames (t) within the stack. ImageJ hyperstacks are always in czt order. Stacks not in czt order will be shuffled to be in czt order. The channel Display Mode can be Composite, Color or Grayscale (cf. Channels... [Z]).

SEE ALSO: Hyperstack to Stack

25.7.3 Hyperstack to Stack

Converts a hyperstack into a stack (in czt order).

SEE ALSO: Stack to Hyperstack...
25.7.4 Reduce Dimensionality...

This command reduces the dimensionality of an hyperstack by creating a new hyperstack with, for example, all the channels and time points at a given z position or all the z slices for the current channel and time point.

Uncheck Channels(n) to delete all but the current channel, Slices(n) to delete all but the current z slice and Frames(n) to delete all but the current time point. Check Keep Source and the original stack will not be deleted.

The expected dimensions and size of the reduced stack are displayed in the dialog.

See also: Hyperstack to Stack

25.7.5 Channels... [Z]

Opens the ‘Channels’ window, or brings it to the front if it is already open. Shift Z is the keyboard shortcut for this command. This tool allows to select the Display mode of composite images. In addition, several commands hosted in the Image ⊿ Color ⊿ submenu can easily be accessed through the More≫ drop-down menu. The same drop-down menu also provides a convenient list of primary colors (additive: red, green and blue, subtractive: cyan, magenta, yellow) that can be used to pseudocolor composite channels. Composite images are discussed with more detail in Color Composites.

25.8 Crop [X]

Crops the image or stack based on the current rectangular selection.
25.9  **Duplicate... [D]**

Creates a new window containing a copy of the active image or rectangular selection. For stacks and hyperstacks it is possible to specify the range of **Channels (c)**, **Slices (z)** and **Frames (t)** to be duplicated.

With single images, hold `Alt` to skip the dialog box.

25.10  **Rename...**

Renames the active image.

25.11  **Scale... [E]**

Resizes the image or current area selection by scale factors entered into a dialog box. As with **Image Size...**, two resampling methods are possible: **Bilinear** and **Bicubic** interpolation.

For the best looking results, particularly with graphics and text, use integer scale factors (2, 3, 5, etc.) and check **Average when downsizing** with scale factors less than 1.0 [13]. Also, when downsizing, smoothing the source image prior to scaling may produce better looking results.

Scaled image/selection are copied to a new image named **Title** if **Create new window** is checked. If scaling a selection that will not be copied to a new image check **Fill with Background Color** to fill with the background color instead of zero.

Entire stacks (or hyperstacks in the Z Dimension) will be scaled if **Process entire stack** is checked.
25.12 Transform

This submenu contains commands that perform geometrical image transformation on the active image or stack.

25.12.1 Flip Horizontally

Replaces the image or selection with a x-mirror image of the original.

25.12.2 Flip Vertically

Turns the image or selection upside down (y-mirror).

25.12.3 Flip Z

Reverses the order of the slices in a stack (z-mirror).

25.12.4 Rotate 90 Degrees Right

Rotates the entire image or stack clockwise 90°.

25.12.5 Rotate 90 Degrees Left

Rotates the entire image or stack counter-clockwise 90°.

25.12.6 Rotate... see

Use this dialog to rotate the active image or selection clockwise the specified number of degrees.

Set Grid Lines to a value greater than zero to superimpose a grid on the image in Preview mode. Two resampling methods are possible: Bilinear and Bicubic interpolation (cf. Image Size...).

With 8-bit and RGB images, check Fill with Background Color to fill with the background color instead of zero (cf. Color Picker... [K]). Check Enlarge to Fit Result and the image will be enlarged as needed to avoid clipping.
25.12.7 Translate...

Translates (moves) the image in the x and y directions by a specified number of pixels. With stacks, you can translate either the current image or all the images in the stack. Two resampling methods are possible: Bilinear and Bicubic interpolation (cf. Image Size...).

Check Preview to see how the translation will affect the image. The background at the edges of the image will be set to 0.

See also: Align_Slice and Align_RGB_planes plugins

25.13 Zoom

This submenu contains commands that control how the current image is displayed. The + and − or ↑ and ↓ keys are the preferred way to use the In and Out commands. When a selection exists, zooming with the arrow keys requires holding down either Shift or Ctrl.

25.13.1 In [+] - Improved in IJ 1.44

Zooms in to next higher magnification level and, if possible, enlarges the window. There are 21 possible levels (shown in the title bar): 3.1, 4.2, 6.3, 8.3, 12.5, 16.7, 25, 33.3, 50, 75, 100, 150, 200, 300, 400, 600, 800, 1200, 1600, 2400 and 3200%.

XV Scrolling Zoomed Images

Hold down the space bar and drag to scroll a zoomed image.

25.13.2 Out [−] - Improved in IJ 1.44

Zooms out to next lower magnification level and, if needed, shrinks the window.

25.13.3 Original Scale [4]

Displays the image at the magnification used when the image was first opened. As a shortcut, double click on the magnifying glass tool.
25.13.4 View 100% [5]

Displays the image using 100% magnification (1 image pixel = 1 screen pixel). Enable Open Images at 100% in the Edit > Options > Appearance... dialog to have images automatically opened at 100% magnification.

25.13.5 To Selection

Zooms in based on the current selection. Note that in the absence of a selection, this command zooms the image to a ‘Fit to Screen’ level.

25.13.6 Set... 

Sets an exact zoom to any open image beyond predefined zoom levels, e.g. 37.4% [20].

25.14 Overlay

This submenu contains commands for creating and working with non-destructive image overlays. An overlay consists of one or more selections (arrows, lines, points, shapes and text). Press B (Add Selection... [b]) to add the current selection to the overlay. Press Shift F (Flatten [F]) to create an RGB image with the overlay embedded in it. The overlay is preserved when an image is saved in TIFF format (cf. II).

Non-destructive image overlays. Outputs from Grid_Overlay, MakeOverlay and ROI Color Coder, macros that exemplify the usage of most Image > Overlay > submenu commands.
25.14.1 Add Selection... [b]

Adds the current selection to the overlay, displaying the dialog box depicted on the left. Stroke Color, Stroke Width and Fill Color to be set. Except for text selections, the stroke (line) color and width are ignored if a fill color is specified.

Hold [Alt] to skip the Add to Overlay dialog.

Colors are specified by the name of one of the eight default colors (black, blue, cyan, green, magenta, red, white and yellow) or using hex notation.

Hex color codes must be given as either a 6-digit hexadecimal number in the form #RRGGBB (opaque colors), or a 8-digit number in the form #AARRGGBB where AA specifies the alpha blending value, RR the intensity of red, GG the intensity of green and BB the intensity of blue. The table below provides the conversion of some RGB color triplets into hex notation.

Previously added overlays are removed if New Overlay is checked.

See also: Selection Properties... [y], ROI Manager..., XVI, ROI Color Coder and RGBtoHEX macros

XVI Working With HEX Colors

Hexadecimal notation (hex) is frequently used in computing because it can summarize binary code in a human-friendly manner. For example, RGB colors that typically range from 0 to 255 can be succinctly represented as two hexadecimal digits (ranging from 00 through FF). ImageJ’s built-in macro function toHex() returns hexadecimal representations of decimal numbers and can be used to convert RGB color values into hex color notation (see RGBtoHEX macro).

The following table exemplifies some decimal / hexadecimal equivalents:

| Dec | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | ... | 30 | 40 | 50 | 60 | 70 | 80 | 90 | ... | 100 | ... | 255 |
| Hex | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | A | B | C | D | E | F | 10 | 11 | 12 | 13 | 14 | 15 | ... | 1E | 28 | 32 | 3C | 46 | 50 | 5A | ... | 64 | ... | FF |
**Hexadecimal notation of RGB colors.** As with RGB triplets, alpha values range from 0 (fully transparent) to 255 (solid color). Opacity values (%) are thus obtained using $100 \times (255 - \alpha)/255$. Alpha values can be omitted for fully opaque colors.

<table>
<thead>
<tr>
<th>Opacity (%)</th>
<th>RGB Color (R, G, B)</th>
<th>Blue</th>
<th>Cyan</th>
<th>Green</th>
<th>Magenta</th>
<th>Red</th>
<th>Orange</th>
<th>Yellow</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>#0000FF</td>
<td>#00FFFF</td>
<td>#00FF00</td>
<td>#FF00FF</td>
<td>#FF0000</td>
<td>#FFC800</td>
<td>#FFFF00</td>
<td></td>
</tr>
<tr>
<td>75</td>
<td>#BF0000FF</td>
<td>#BF00FFFF</td>
<td>#BF00FF00</td>
<td>#BFFFF0FF</td>
<td>#BFFFF0000</td>
<td>#BFFFFC800</td>
<td>#BFFFFF00</td>
<td></td>
</tr>
<tr>
<td>50</td>
<td>#7F0000FF</td>
<td>#7F00FFFF</td>
<td>#7F00FF00</td>
<td>#7FFFF0FF</td>
<td>#7FFFF0000</td>
<td>#7FFC800</td>
<td>#7FFFFF00</td>
<td></td>
</tr>
<tr>
<td>25</td>
<td>#3F0000FF</td>
<td>#3F00FFFF</td>
<td>#3F00FF00</td>
<td>#3FFFF0FF</td>
<td>#3FFFF0000</td>
<td>#3FFC800</td>
<td>#3FFFFF00</td>
<td></td>
</tr>
</tbody>
</table>

List generated by the RGBtoHEX macro using the default selection colors of ImageJ

### 25.14.2 Add Image...

Adds an image to the overlay. A blending alpha value can be specified in the Opacity (0–100%) field. The initial X,Y location are based on the existing rectangular selection, if any.

Select *Create image selection* to create overlay images that can be moved around the image. Opacity of image selections can be adjusted using *Edit* > *Selection* > *Properties...* [y].

Image selections behave only partially as regular selections (e.g., can be added to the ROI Manager list but cannot be resized or rotated). In addition, image selections are not saved in the TIFF header.

**See also:** Paste Control..., ROI Manager...

### 25.14.3 Hide Overlay

Causes ImageJ to stop displaying the overlay displayed by Show Overlay.

### 25.14.4 Show Overlay

Displays an overlay that was hidden by Hide Overlay.

### 25.14.5 From ROI Manager

Creates an overlay from the selections on the ROI Manager list (see ROI Manager...). Note that previously added overlays will be removed.
25.14.6 To ROI Manager

Copies the selections and images in the current overlay to the ROI Manager, where they can be edited (moved, resized or re-colored) (see ROI Manager...). Note that previous items in the ROI Manager list will be deleted.

25.14.7 Remove Overlay

Permanently clears the overlay so that it cannot be restored using Show Overlay.

25.14.8 Flatten [F]

Creates a new RGB image that has the overlay rendered as pixel data. The RGB image is the same size as the active image, unlike Plugins Utilities Capture Image, which creates a WYSIWYG (What You See Is What You Get) image that is the same size as its window.

25.15 Lookup Tables

This submenu contains a selection of color lookup tables that can be applied to grayscale images to produce false-color images. If no image is open, a $256 \times 32$ ramp image is created to display the color table. More than 100 additional lookup tables are available at imagej.nih.gov/ij/download/luts/ or, as a ZIP archive, at http://imagej.nih.gov/ij/download/luts/luts.zip.

See also: Macro Toolset Switcher

25.15.1 Invert LUT

Inverts the current lookup table. For 8–bit images, the value ($v$) of each entry in the table is replaced by $255 - v$. With inverted LUTs, pixels with a value of zero are white and pixels with a value 255 are black. Unlike the Edit Invert [I] command, pixels values are not altered, only the way the image is displayed on the screen.

25.15.2 Apply LUT

Applies the current lookup table function to each pixel in the image or selection and restores the default identity function. This modifies the gray values so that when the image is viewed using the default grayscale lookup table it will look the same as it did before. This command is equivalent to clicking on Apply in Image Adjust Brightness/Contrast... [C]. For thresholded images, it is equivalent to clicking on Apply in Image Adjust Threshold... [T].
26 Process

This menu lists all commands related to image processing, including point operations, filters, and arithmetic operations between multiple images [17]. The File > Open Samples > Blobs (25K) [B] image will be used in most of the illustrations of this section.

Process submenu: Smooth [S], Sharpen, Find Edges and Enhance Contrast

26.1 Smooth [S]

Blurs the active image or selection. This filter replaces each pixel with the average of its 3×3 neighborhood.

26.2 Sharpen

Increases contrast and accentuates detail in the image or selection, but may also accentuate noise. This filter uses the following weighting factors to replace each pixel with a weighted average of the 3×3 neighborhood:

\[
\begin{bmatrix}
-1 & -1 & -1 \\
-1 & 12 & -1 \\
-1 & -1 & -1 \\
\end{bmatrix}
\]

26.3 Find Edges

Uses a Sobel edge detector to highlight sharp changes in intensity in the active image or selection. Two 3×3 convolution kernels (shown below) are used to generate vertical and horizontal derivatives. The final image is produced by combining the two derivatives using the square root of the sum of the squares.

\[
\begin{bmatrix}
1 & 2 & 1 \\
0 & 0 & 0 \\
-1 & -2 & -1 \\
\end{bmatrix}
\]

\[
\begin{bmatrix}
1 & 0 & -1 \\
2 & 0 & -2 \\
1 & 0 & -1 \\
\end{bmatrix}
\]
26.4 Find Maxima...

Determines the local maxima in an image and creates a binary (mask-like) image of the same size with the maxima, or one segmented particle per maximum, marked [21].

Analysis is performed on the existing rectangular selection or on the entire image if no selection is present.

For RGB images, maxima of luminance are selected, with the luminance defined as weighted or unweighted average of the colors depending on how *Weighted RGB to Grayscale Conversion* is set in *Edit > Options > Conversions*.

*Noise Tolerance*  Maxima are ignored if they do not stand out from the surroundings by more than this value (calibrated units for calibrated images). In other words, a threshold is set at the maximum value minus noise tolerance and the contiguous area around the maximum above the threshold is analyzed. For accepting a maximum, this area must not contain any point with a value higher at than the maximum. Only one maximum within this area is accepted.

*Output Type* Can be (see *Process > Find Maxima* outputs):

- **Single Points**  Results in one single point per maximum.
- **Maxima Within Tolerance**  All points within the *Noise Tolerance* for each maximum.
- **Segmented Particles**  Assumes that each maximum belongs to a particle and segments the image by a watershed algorithm applied to the values of the image (in contrast to *Process > Binary > Watershed*, which uses the Euclidian distance map).
- **Point Selection**  Displays a multi-point selection with a point at each maximum.
- **List**  Displays the XY coordinates of each maximum in the Results window.
- **Count**  Displays the number of maxima in the Results window.

*Exclude Edge Maxima* Excludes maxima if the area within the noise tolerance surrounding a maximum touches the edge of the image (edge of the selection does not matter).
Process ▶ Find Maxima... (ImageJ 1.43s). Six outputs are possible: Single Points, Maxima Within Tolerance, Segmented Particles, Point Selection, List and Count.

Above Lower Threshold (Thresholded images only) Finds maxima above the lower threshold only. The upper threshold of the image is ignored. If Segmented Particles is selected as Output Type, the area below the lower threshold is considered a background. This option cannot be used when finding minima (image with light background and inverted LUT).

Light Background To be checked if the image background is brighter than the objects to be found, as it is in the Cell Colony image in the illustration below.


Output is a binary image, with foreground 255 and background 0, using an inverted or normal LUT depending on the Black Background option in Process ▶ Binary ▶ Options...

The number of particles (as obtained by Analyze ▶ Analyze Particles...) in the output image does not depend on the selected Output Type. Note that Segmented Particles will usually result in particles touching the edge if Exclude Edge Maxima is selected. Exclude Edge Maxima applies to the maximum, not to the particle.

Find Maxima... does not work on stacks, but the FindStackMaxima macro runs it on all the images in a stack and creates a second stack containing the output images. The FindMaximaRoiManager macro demonstrates how to add particles found by Find Maxima... to the ROI Manager...
26.5 Enhance Contrast

Enhances image contrast by using either histogram stretching or histogram equalization. Both methods are described in detail in the Hypermedia Image Processing Reference – Contrast Stretching and Histogram Equalization.

This command does not alter pixel values as long as Normalize, Equalize Histogram or Normalize All n Slices (in the case of stacks) are not checked.

**Saturated Pixels** Determines the number of pixels in the image that are allowed to become saturated. Increasing this value will increase contrast. This value should be greater than zero to prevent a few outlying pixel from causing the histogram stretch to not work as intended.

**Normalize** If checked, ImageJ will recalculate the pixel values of the image so the range is equal to the maximum range for the data type, or 0–1.0 for float images. The contrast stretch performed on the image is similar to the ‘Auto’ option in the Brightness/Contrast... [C] window, except that with stacks, each slice in the stack is adjusted independently, according to the optimal for that slice alone (if Use Stack Histogram is unchecked). The maximum range is 0–255 for 8–bit images and 0–65535 for 16–bit images.

With stacks another checkbox, Normalize All n Slices, is displayed. If checked, normalization will be applied to all slices in the stack. Note that normalization of RGB images is not supported, and thus this option will not be available on RGB images.

**Equalize Histogram** If checked, ImageJ will enhance the image using histogram equalization [22]. Create a selection and the equalization will be based on the histogram of the selection. Uses a modified algorithm that takes the square root of the histogram values. Hold \( \text{Alt} \) to use the standard histogram equalization algorithm. The Saturated Pixels and Normalize parameters are ignored when Equalize Histogram is checked.

**Use Stack Histogram** If checked, ImageJ will use the overall stack histogram instead of individual slice histograms, that allow optimal adjustments for each slice alone. This option may be specially relevant when performing enhancements based on a ROI.

**See also:** Brightness/Contrast... [C] , XI

26.6 Noise

Use the commands in this submenu to add noise to images or remove it.
Process > Noise: Salt and Pepper, Despeckle, Add Noise and Remove Outliers...

See also: RandomJ (Binomial, Exponential, Gamma, Gaussian, Poisson and Uniform) a Java package for image randomization by Erik Meijering

26.6.1 Add Noise

Adds random noise to the image or selection. The noise is Gaussian (normally) distributed with a mean of zero and standard deviation of 25.

26.6.2 Add Specified Noise...

Add Gaussian noise with a mean of zero and a chosen standard deviation.

26.6.3 Salt and Pepper

Adds salt and pepper noise to the image or selection by randomly replacing 2.5% of the pixels with black pixels and 2.5% with white pixels. This command only works with 8-bit images.

26.6.4 Despeckle

This is a median filter. It replaces each pixel with the median value in its $3 \times 3$ neighborhood. This is a time consuming operation because, for each pixel in the selection, the nine pixels in the $3 \times 3$ neighborhood must be sorted and the center pixel replaced with the median value (the fifth). Median filters are good at removing *salt and pepper* noise.
26.6.5 Remove Outliers...

Replaces a pixel by the median of the pixels in the surrounding if it deviates from the median by more than a certain value (the threshold). Useful for correcting, e.g., hot pixels or dead pixels of a CCD camera.

**Radius** Determines the area (uncalibrated, i.e., in pixels) used for calculating the median. Run Process > Filters > Show Circular Masks... to see how radius translates into an area.

**Threshold** Determines by how much the pixel must deviate from the median to get replaced, in raw (uncalibrated) units.

**Which Outliers** Determines whether pixels brighter or darker than the surrounding (the median) should be replaced.

See also: Despeckle

26.7 Shadows

Commands in this submenu produce a shadow effect, with light appearing to come from a direction corresponding to the command name (East, North, Northeast, Northwest, South, Southeast, Southwest and West). The commands use Convolve $3 \times 3$, ImageJ’s $3 \times 3$ convolution function. The Shadows Demo command uses all eight kernels to demonstrate the speed of Convolve $3 \times 3$. The illustration below shows four of the Shadows convolution kernels.

![Convolution Kernels](image)

Shadows ➤: North, South, East, and West kernels.

26.8 Binary

This submenu contains commands that create or process binary (black and white) images. They assume that objects are black and background is white unless unless Black Background is checked in the Process ➤ Binary ➤ Options... dialog box.
Summary of morphological operators (Process ▶ Binary ▶ submenu).

<table>
<thead>
<tr>
<th>Original</th>
<th>Make Binary</th>
<th>Erode</th>
<th>Dilate</th>
<th>Open</th>
<th>Close–</th>
<th>Outline</th>
<th>Skeletonize</th>
</tr>
</thead>
</table>


Adjust ▶ Threshold... [T]  
Minimum...  
(grayscale)  
Maximum...  
(grayscale)  
Erode then  
Dilate  
Dilate then  
Erode  
1 pixel wide  
outline  
1 pixel wide  
skeleton

### 26.8.1 Make Binary

Converts an image to black and white. If a threshold has been set using the Image ▶ Adjust ▶ Threshold... [T] tool, the depicted dialog is displayed. The value of the Black foreground, white background checkbox reflects and sets the global Black Background value of Process ▶ Binary ▶ Options...

If a threshold has not been set, Make Binary will analyze the histogram of the current selection, or of the entire image if there is no selection is present and set an automatic threshold level to create the binary image (‘Auto-thresholding’ is displayed in the Status bar, cf. Threshold... [T]).

With stacks the Convert to Mask dialog box is displayed. Note that for non-thresholded images and stacks Make Binary and Convert to Mask behave similarly.

**See also:** Edit ▶ Selection ▶ Convert to Mask, XVII

### 26.8.2 Convert to Mask

Converts an image to black and white. The mask will have an inverting LUT (white is 0 and black is 255) unless Black Background is checked in the Process ▶ Binary ▶ Options... dialog box. If a threshold has not been set, automatic threshold levels will be calculated (cf. Make Binary). Note that for non-thresholded images and stacks Make Binary and Convert to Mask behave similarly.

With stacks, the depicted dialog is displayed.

**Calculate Threshold for Each Image** If checked, threshold levels will be calculated for each individual slice, otherwise the calculated threshold of the currently displayed slice will be used for all slices.
Black Background  Defines whether the background is black and the foreground is white. Note that the value of this checkbox reflects and sets the global Black Background value of Process > Binary > Options.

See also: Make Binary, Edit > Selection > Convert to Mask, XVII

XVII  Creating Binary Masks

Four ImageJ commands can be used to create binary masks:

1. Edit > Selection > Create Mask
2. Process > Binary > Make Binary
3. Process > Binary > Convert to Mask
4. Image > Adjust > Threshold... [T] (Apply)

By default these commands will produce binary images with inverted LUTs, so that black is 255 and white is 0 (cf. Invert LUT). This behavior can be reversed by checking Black Background in Process > Binary > Options... before running the above commands (i.e., an inverting LUT will not be used: black will be 0 and white 255). This choice can be confirmed when running Make Binary and Convert to Mask on thresholded images. It can also be imposed at startup (see Settings and Preferences).

26.8.3  Erode

Removes pixels from the edges of black objects. Use Filters > Minimum... to perform grayscale erosion.

See also: Binary > Options...

26.8.4  Dilate

Adds pixels to the edges of black objects. Use Filters > Maximum... to perform grayscale dilation.

See also: Binary > Options...
26.8.5 Open

Performs an erosion operation, followed by dilation. This smooths objects and removes isolated pixels.

See also: Binary ➤ Options...

26.8.6 Close–

Performs a dilation operation, followed by erosion. This smooths objects and fills in small holes. The command has a tailing hyphen to differentiate it from File ➤ Close [w].

See also: Binary ➤ Options...

26.8.7 Outline

Generates a one pixel wide outline of foreground objects in a binary image. The line is drawn inside the object, i.e., on previous foreground pixels.

26.8.8 Fill Holes

This command fills holes (4-connected background elements) in objects by filling the background [25].

26.8.9 Skeletonize

Repeatably removes pixels from the edges of objects in a binary image until they are reduced to single pixel wide skeletons (topological skeletons).

See also: Skeletonize3D plugin

26.8.10 Distance Map

Generates a Euclidian distance map (EDM). Each foreground pixel in the binary image is replaced with a gray value equal to that pixel’s distance from the nearest background pixel. The output type (Overwrite, 8-bit, 16-bit or 32-bit) of this command can be set in the Binary ➤ Options... dialog box. Note that when selecting ‘Overwrite’ or ‘8-bit output’, distances larger than 255 are labelled as 255.
26.8.11 Ultimate Points

Generates the ultimate eroded points (UEPs) of the EDM. Requires a binary image as input. The UEPs represent the centers of particles that would be separated by segmentation. The UEP’s gray value is equal to the radius of the inscribed circle of the corresponding particle. The output type (Overwrite, 8-bit, 16-bit or 32-bit) of this command can be set in the Binary▸Options… dialog box.

26.8.12 Watershed

Watershed segmentation is a way of automatically separating or cutting apart particles that touch. It first calculates the Euclidian distance map (EDM) and finds the ultimate eroded points (UEPs). It then dilates each of the UEPs (the peaks or local maxima of the EDM) as far as possible – either until the edge of the particle is reached, or the edge of the region of another (growing) UEP. Watershed segmentation works best for smooth convex objects that don’t overlap too much.

Enable debugging in Edit▸Options▸Misc… and the Watershed command will create an animation that shows how the watershed algorithm works (cf. online example).

![Original Segmentation Movie Watershed running in Debug mode.](image)

SEE ALSO: Find Maxima…

26.8.13 Voronoi

Splits the image by lines of points having equal distance to the borders of the two nearest particles. Thus, the Voronoi cell of each particle includes all points that are nearer to this particle than any other particle. When particles are single points a Voronoi tessellation (also known as Dirichlet tessellation) is performed.

The output type (Overwrite, 8-bit, 16-bit or 32-bit) of this command can be set in the Process▸Binary▸Options… dialog box. In the output, the value inside the Voronoi cells is zero; the pixel values of the dividing lines between the cells are equal to the distance to the two nearest particles. This is similar to a medial axis transform of the background, but there are no lines in inner holes of particles.

112
See also: Delaunay_Voronoi plugin

<table>
<thead>
<tr>
<th>Original</th>
<th>Distance Map</th>
<th>Ultimate Points</th>
<th>Watershed</th>
<th>Voronoi</th>
<th>Original + Voronoi + Ultimate Points</th>
</tr>
</thead>
</table>

Process▸Binary▸ commands.

26.8.14 Options...

Specifies several settings used by Binary▸ commands.

**Iterations** Specifies the number of times erosion, dilation, opening, and closing are performed. Iterations can be aborted by pressing [ESC].

**Count** Specifies the number of adjacent background pixels necessary before a pixel is removed from the edge of an object during erosion and the number of adjacent foreground pixels necessary before a pixel is added to the edge of an object during dilation.

**Black background** If checked, binary images will be created without using an inverted LUT (cf. XVII) and commands in the Process▸Binary▸ submenu will assume that images contain white objects on a black background. Macros can set this option using the `setOption("BlackBackground", true)` macro function (cf. Settings and Preferences).

**Pad edges when eroding** If checked, Binary▸ Erode does not erode from the edges of the image. This setting also affects Binary▸ Close−, which erodes from the edges unless this checkbox is selected.

**EDM output** Determines the output type for the Binary▸ Distance Map, Ultimate Points and Voronoi commands. Set it to ’Overwrite’ for 8–bit output that overwrites the input image; ’8–bit’, ’16–bit’ or ’32–bit’ for separate output images. 32–bit output has floating point (subpixel) distance resolution.

113
Do  This drop-down menu allows to test the chosen settings by previewing each binary operation (Binary ⊳ Erode, Dilate, Open, Close−) on the active image. This option is only available when the active image is binary.


26.9  Math ⊳

The commands in this submenu add (subtract, multiply, etc.) a constant to each pixel in the active image or selection. A ‘Preview’ option is available for most operations. With stacks, the dialog depicted on the left is displayed. Choose ‘Yes’ to process entire stack or ‘No’ to process only the active slice. The dialog is not displayed if Hide "Process Stack?" dialog is checked in Edit ⊳ Options ⊳ Misc.

See also: Memory & Threads...

26.9.1  Add...

Adds a constant to the image or selection. With 8–bit images, results greater than 255 are set to 255. With 16–bit signed images, results greater than 65,535 are set to 65,535.

26.9.2  Subtract...

Subtracts a constant from the image or selection. With 8–bit and 16–bit images, results less than 0 are set to 0.

26.9.3  Multiply...

Multiplies the image or selection by the specified real constant. With 8–bit images, results greater than 255 are set to 255. With 16–bit signed images, results greater than 65,535 are set to 65,535.

26.9.4  Divide...

Divides the image or selection by the specified real constant. Except for 32–bit (float) images, attempts to divide by zero are ignored. With 32–bit images, dividing by zero results in Infinity, -Infinity or NaN (0/0) pixels when the source pixels are positive, negative or zero. The divide-by-zero value can be redefined using Edit ⊳ Options ⊳ Misc.

114
26.9.5 **AND**...  
Does a bitwise AND of the image and the specified binary constant.

26.9.6 **OR**...  
Does a bitwise OR of the image and the specified binary constant.

26.9.7 **XOR**...  
Does a bitwise XOR of the image and the specified binary constant.

26.9.8 **Min**...  
Pixels in the image with a value less than the specified constant are replaced by the constant.

26.9.9 **Max**...  
Pixels in the image with a value greater than the specified constant are replaced by the constant.

26.9.10 **Gamma**...  
Applies the function $f(p) = (p/255)^\gamma \times 255$ to each pixel $(p)$ in the image or selection, where $0.1 \leq \gamma \geq 5.0$. For RGB images, this function is applied to all three color channels. For 16–bit images, the image min and max are used for scaling instead of 255.

**See also:** GammaCorrectionTool macro

26.9.11 **Set**...  
Fills the image or selection with the specified value.

26.9.12 **Log**  
For 8–bit images, applies the function $f(p) = \ln(p) \times 255/\ln(255)$ to each pixel $(p)$ in the image or selection. For RGB images, this function is applied to all three color channels. For 16–bit images, the image min and max are used for scaling instead of 255. For float images, no scaling is done. To calculate $\log_{10}$ of the image, multiply the result of this operation by 0.4343 $(1/\ln(10))$.  

115
26.9.13 **Exp**

Performs an exponential transform on the active image or selection.

26.9.14 **Square**

Performs a square transform on the active image or selection.

26.9.15 **Square Root**

Performs a square root transform on the active image or selection.

26.9.16 **Reciprocal**

Generates the reciprocal of the active image or selection. Only works with 32-bit float images.

26.9.17 **NaN Background**

Sets non-thresholded pixels in 32-bit float images to the *NaN* (Not a Number) value. For float images, the *Apply* option in *Image* $\Rightarrow$ *Adjust* $\Rightarrow$ *Threshold...* [$T$] runs this command. Pixels with a value of Float.NaN (0f/0f), Float.POSITIVE_INFINITY (1f/0f) or Float.NEGATIVE_INFINITY (-1f/0f) are ignored when making measurements on 32-bit float images.

26.9.18 **Abs**

Generates the absolute value of the active image or selection. Works only with 32-bit float or signed 16-bit image images.

26.9.19 **Macro...**

This command performs image arithmetic using an expression specified by the user [23]. It can be used to create fully-synthetic images or to perform precise pixel manipulations on existing images. The MathMacroDemo macro demonstrates the usage of this command.

**See also:** Expression plugin
26.10 FFT

The commands in this submenu support frequency domain display, editing and processing. They are based on an implementation of the 2D Fast Hartley Transform (FHT) contributed by Arlo Reeves, the author of the ImageFFT spinoff of NIH Image.\(^1\)

The frequency domain image is stored as 32–bit float FHT attached to the 8–bit image that displays the power spectrum. Commands in this submenu, such as Inverse FFT, operate on the 32–bit FHT, not on the 8–bit power spectrum. All other ImageJ commands only ‘see’ the power spectrum.

Two FFT dedicated tutorials are available on the ImageJ website: FFT Measurements and FFT Filtering.

26.10.1 FFT

Computes the Fourier transform and displays the power spectrum. Polar coordinates of measured point selections are recorded by Analyze\(\Rightarrow\)Measure... [m].

If the mouse is over an active frequency domain (FFT) window, its location is displayed in polar coordinates. The angle is expressed in degrees, while the radius is expressed in pixels per cycle (p/c). The radius is expressed in [units] per cycle (e.g. mm/c) if the spatial scale of the image was defined using Image\(\Rightarrow\)Properties... [P] or Analyze\(\Rightarrow\)Set Scale... .

26.10.2 Inverse FFT

Computes the inverse Fourier transform. You can filter or mask spots on the transformed (frequency domain) image and do an inverse transform to produce an image which only contains the frequencies selected or which suppresses the frequencies selected. Use ImageJ’s selection tools and fill / clear commands to draw black or white areas that mask portions of the transformed image. Black areas (pixel value = 0) cause the corresponding frequencies to be filtered (removed) and white areas (pixel value = 255) cause the corresponding frequencies to be passed. It is not, however, possible to both filter and pass during the same inverse transform.

Note that areas to be filtered in the frequency domain image must be zero filled and areas to be passed must be filled with 255. You can verify that this is the case by moving the cursor over a filled area and observing that the values displayed in the status bar are either 0 or 255.

With off-center selections, the same spatial frequency appears twice in the power spectrum, at points opposite from the center. It is sufficient to fill / clear only one of these.

---

\(^1\)Bob Dougherty’s 3D Fast Hartley Transform plugin performs 3D FHTs
26.10.3 Redisplay Power Spectrum

Recomputes the power spectrum from the frequency domain image (32–bit FHT). This command allows you to start over after mis-editing the 8–bit power spectrum image.

26.10.4 FFT Options...

Displays the FFT Options dialog box. The first group of checkboxes specifies which image(s) are created by the FFT command:

Display FFT Window The standard output. It consists of an 8–bit image of the power spectrum and the actual data, which remain invisible for the user. The power spectrum image is displayed with logarithmic scaling, enhancing the visibility of components that are weakly visible. The actual data are used for the Inverse FFT command.

Display Raw Power Spectrum The power spectrum without logarithmic scaling.

Display Fast Hartley Transform The internal format used by the command, which is based on a Hartley transform rather than Fourier transform.
**Display Complex Fourier Transform**  A stack with two slices for the real and imaginary parts of the FFT.

**Do Forward Transform**  If checked, the current image is transformed immediately when closing the FFT Options dialog.

### 26.10.5 Bandpass Filter...

Removes high spatial frequencies (blurring the image) and low spatial frequencies (similar to subtracting a blurred image). It can also suppress horizontal or vertical stripes that were created by scanning an image line by line [24].

The Bandpass Filter uses a special algorithm to reduce edge artifacts (before the Fourier transform, the image is extended in size by attaching mirrored copies of image parts outside the original image, thus no jumps occur at the edges).

**Filter Large Structures Down to**  Smooth variations of the image with typical sizes of bright or dark patches larger than this value are suppressed (background).

**Filter Large Structures Up to**  Determines the amount of smoothing. Objects in the image smaller than this size are strongly attenuated. Note that these values are both half the spatial frequencies of the actual cutoff. The cutoff is very soft, so the bandpass will noticeably attenuate even spatial frequencies in the center of the bandpass unless the difference of the two values is large (say, more than a factor of 5 or so).

**Suppress Stripes**  Select whether to eliminate *Horizontal* or *Vertical* stripes. Removal of horizontal stripes is similar to subtracting an image that is only blurred in the horizontal direction from the original.

**Tolerance of Direction**  This is for *Suppress Stripes*; higher values remove shorter stripes and/or stripes that are running under an angle with respect to the horizontal (vertical) direction.

**Autoscale After Filtering**  If checked, puts the lowest intensity to 0 and the highest intensity to 255, preserving all intensities.

**Saturate Image when Autoscaling**  If checked, allows some intensities to go into saturation, and produces a better visual contrast. *Saturate Image when Autoscaling* only has an effect when *Autoscale After Filtering* is enabled.
Display Filter If checked, shows the filter generated. Note that this disables Undo of the filter operation on the original image.

26.10.6 Custom Filter...

This command does Fourier space filtering of the active image using a user-supplied spatial domain (non-FFT) image as the filter.

This image will be converted to 8-bit. For pixels that have a value of 0, the corresponding spatial frequencies will be blocked. Pixel with values of 255 should be used for passing the respective spatial frequencies without attenuation. Note that the filter should be symmetric with respect to inversion of the center: Points that are opposite of the center point (defined as \(x = \text{width}/2, y = \text{height}/2\)) should have the same value. Otherwise, artifacts can occur. For some examples, see the FFTCustomFilterDemo and FFTRemoveStreaks macros.

26.10.7 FD Math...

This command correlates, convolves or deconvolves two images.

It does this by converting Image1 and Image2 to the frequency domain, performing conjugate multiplication or division, then converting the result back to the space domain. These three operations in the frequency domain are equivalent to correlation, convolution and deconvolution in the space domain.

Refer to the DeconvolutionDemo and MotionBlurRemoval macros for examples.
26.10.8 Swap Quadrants

This command transforms between the ‘user friendly’ display of Fourier transforms with the lowest frequencies at the center and the ‘native’ form with the lowest frequencies at the four corners.

Swap Quadrants swaps quadrants I with III and II with IV (counter-clockwise starting from ‘Northeast’) so that points near the center are moved towards the edge and vice versa. Another way to see this command is to imagine that the image is periodically repeated and the origin is shifted by \( \frac{\text{width}}{2} \) in x and by \( \frac{\text{height}}{2} \) in y direction.

For Fourier transforms, Swap Quadrants affects only the image displayed, not the actual FHT data. Therefore, editing an image with swapped quadrants for filtering or masking may lead to undesired results.

26.11 Filters

This submenu contains miscellaneous filters (including those installed by the Plugins Utilities Install Plugin... command).

More information on image filters can be obtained by looking up related keywords (convolution, Gaussian, median, mean, erode, dilate, unsharp, etc.) on the Hypermedia Image Processing Reference index.

See also: Memory & Threads...

26.11.1 Convolve...

Does spatial convolution using a kernel entered into a text area.

A kernel is a matrix whose center corresponds to the source pixel and the other elements correspond to neighboring pixels. The destination pixel is calculated by multiplying each source pixel by its corresponding kernel coefficient and adding the results. If needed, the input image is effectively extended by duplicating edge pixels outward. There is no arbitrary limit to the size of the kernel but it must be square and have an odd width.
Rows in the text area must all have the same number of coefficients, the rows must be terminated with a carriage return, and the coefficients must be separated by one or more spaces. Kernels can be pasted into the text area using $\text{Ctrl+V}$. Checking Normalize Kernel causes each coefficient to be divided by the sum of the coefficients, preserving image brightness.

The kernel shown is a $9 \times 9$ “Mexican hat”, which does both smoothing and edge detection in one operation. Note that kernels can be saved as a text file by clicking on the ‘Save’ button, displayed as an image using File $\rightarrow$ Import $\rightarrow$ Text Image..., scaled to a reasonable size using Image $\rightarrow$ Adjust $\rightarrow$ Size... and plotted using Analyze $\rightarrow$ Surface Plot...

See also: ConvolutionDemo macro

26.11.2 Gaussian Blur...

This filter uses convolution with a Gaussian function for smoothing [26].

$\text{Sigma}$ is the radius of decay to $e^{-0.5}$ ($\approx 61\%$), i.e., the standard deviation ($\sigma$) of the Gaussian (this is the same as in Adobe® Photoshop®, but different from ImageJ versions till 1.38q, in which radius was $2.5 \times \sigma$ (cf. GaussianBlur.java).

Like all ImageJ convolution operations, it assumes that out-of-image pixels have a value equal to the nearest edge pixel. This gives higher weight to edge pixels than pixels inside the image, and higher weight to corner pixels than non-corner pixels at the edge. Thus, when smoothing with very high blur radius, the output will be dominated by the edge pixels and especially the corner pixels (in the extreme case, with a blur radius of e.g. $10^{20}$, the image will be replaced by the average of the four corner pixels).

For increased speed, except for small blur radii, the lines (rows or columns of the image) are downsampled before convolution and upsampled to their original length thereafter.

See also: Accurate Gaussian Blur plugin, AnimatedGaussianBlur macro

26.11.3 Median...

Reduces noise in the active image by replacing each pixel with the median of the neighboring pixel values.

26.11.4 Mean...

Smoothes the current image by replacing each pixel with the neighborhood mean.
26.11.5 Minimum...

This filter does grayscale erosion by replacing each pixel in the image with the smallest pixel value in that pixel’s neighborhood.

Binary ► Erode

26.11.6 Maximum...

This filter does grayscale dilation by replacing each pixel in the image with the largest pixel value in that pixel’s neighborhood.

Binary ► Dilate

26.11.7 Unsharp Mask...

Sharpens and enhances edges by subtracting a blurred version of the image (the unsharp mask) from the original.

Unsharp masking subtracts a blurred copy of the image and rescales the image to obtain the same contrast of large (low-frequency) structures as in the input image. This is equivalent to adding a high-pass filtered image and thus sharpens the image.

Radius The standard deviation (σ blur radius, cf. Gaussian Blur...) of the Gaussian blur that is subtracted. Increasing the Gaussian blur radius will increase contrast.

Mask Weight Determines the strength of filtering, whereby MaskWeight = 1 would be an infinite weight of the high-pass filtered image that is added. Increasing the Mask Weight value will provide additional edge enhancement.

26.11.8 Variance...

Highlights edges in the image by replacing each pixel with the neighborhood variance.

26.11.9 Show Circular Masks...

Generates a stack containing examples of the circular masks used by the Median..., Mean..., Minimum..., Maximum..., and Variance... filters for various neighborhood sizes.
26.12 Batch

This submenu allows the execution of commands in a series of images without manual intervention.

Batch commands are non-recursive, i.e., they are applied to all the images of the chosen Input folder but not its subfolders. Nevertheless a directory hierarchy can be traversed using ImageJ macro language (cf. BatchProcessFolders macro).

Three critical aspects to keep in mind when performing batch operations that modify processed images:

- Files can be easily overwritten since the batch processor will silently override existing files with the same name.
- The destination Output folder should have adequate disk space to receive the created images.
- In the case of non-native formats, batch operations will be influenced by the behavior of the reader plugin or library (cf. Non-native Formats).

26.12.1 Measure...

This command measures all the images in a user-specified folder, by running the Analyze Measure... [m] command in all images of the chosen directory.

Note that measurements are performed on non thresholded images. In the case of TIFF images saved with active selections measurements are performed on the ROI and not the whole image.

See also: Analyze Set Measurements..., Batch Macro...

26.12.2 Convert...

Batch converts and/or resizes multiple images from a specified folder.

Input... Selects the source folder containing the images to be processed.

Output... Selects the destination folder where the processed images will be stored.
Output Format  Specifies the output format that can be set to TIFF, 8-bit TIFF, JPEG, GIF, PNG, PGM, BMP, FITS, Text Image, ZIP or Raw (cf. Image Types and Image Formats and File>$Save As$ submenu).

Interpolation  The resampling method to be used in case Scale Factor is not 1.00 (cf. Image$Size...$ and Image$Scale...$ [E]).

Scale Factor  Specifies if images should be resized (cf. Image$Scale...$ [E]).

26.12.3 Macro...

Runs a macro over all the images in a specified folder.

Input... Selects the source folder containing the images to be processed.

Output... Selects the destination folder where the processed images will be stored.

Output Format Specifies the output format that can be set to TIFF, 8-bit TIFF, JPEG, GIF, PNG, PGM, BMP, FITS, Text Image, ZIP or Raw (cf. Image Types and Image Formats and File>$Save As$ submenu).

Add Macro Code  This drop-down menu contains macro snippets that can be combined to create the processing macro. Other statements can be pasted from the macro recorder or ImageJ’s editor while the dialog box is opened [27]. Previously written macros can be imported using Open... When editing the macro beware of any statements that may interfere with the normal operation of the batch processor (such as Close() or Open() calls).

Test  Tests the macro on the first image of the Input... folder (the processed image will be displayed).

Open... Imports previously written macros.

Save... Saves the assembled macro.

See also: Plugins ▶ Macros ▶ Record... ▶ Batch ▶ Virtual Stack...

26.12.4 Virtual Stack...

This command, that shares the same interface of Batch ▶ Macro... (cf. BatchProcessor.java), allows virtual stack manipulations. E.g., Cropping a virtual stack can be performed by executing the following steps:

1. Open a virtual stack
2. Run Process ▶ Batch ▶ Virtual Stack...
3. Select an Output folder and Output format
4. Select ‘Crop’ from the Add Macro Code drop-down menu
5. Edit the macro code as needed and press the Test button to verify the macro
6. Click Process to create the cropped virtual stack

Note that cropped images are not loaded into memory but are saved to disk as they are cropped (see Virtual Stacks).

26.13 Image Calculator...

Performs arithmetic and logical operations between two images selected from popup menus.

Image1 or both Image1 and Image2 can be stacks. If both are stacks, they must have the same number of slices. Image1 and Image2 do not have to be the same data type or the same size.

With 32-bit (float) images, pixels resulting from division by zero are set to Infinity, or to NaN (Not a Number) if a zero pixel is divided by zero. The divide-by-zero value can be redefined in Edit ▶ Options ▶ Misc...

Operation Selects one of the thirteen available operators (see Image Calculator... operations).

Create New Window If checked, a new image or stack will be created to hold the result. Otherwise, the result of the operation replaces some or all of Image1.
### 32-bit (float) Result
If checked, the source images will be converted to 32-bit floating point before the specified operation is performed.


Image Calculator... operations. On these examples source and destination images (8-bit grayscale) are displayed with inverted LUTs (White= 0; Black= 255) (cf. Lookup Tables... sub-menu). Note that calculations between images can also be performed using copy and paste and the **Edit>Paste Control...** command.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Result</th>
<th>Operator</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Add:</strong></td>
<td><img src="image" alt="image" /></td>
<td><strong>Min:</strong></td>
<td><img src="image" alt="image" /></td>
</tr>
<tr>
<td>$img1 = img1 + img2$</td>
<td><img src="image" alt="image" /></td>
<td>$img1 = \min(img1, img2)$</td>
<td><img src="image" alt="image" /></td>
</tr>
<tr>
<td><strong>Subtract:</strong></td>
<td><img src="image" alt="image" /></td>
<td><strong>Max:</strong></td>
<td><img src="image" alt="image" /></td>
</tr>
<tr>
<td>$img1 = img1 - img2$</td>
<td><img src="image" alt="image" /></td>
<td>$img1 = \max(img1, img2)$</td>
<td><img src="image" alt="image" /></td>
</tr>
<tr>
<td><strong>Multiply:</strong></td>
<td><img src="image" alt="image" /></td>
<td><strong>Average:</strong></td>
<td><img src="image" alt="image" /></td>
</tr>
<tr>
<td>$img1 = img1 \times img2$</td>
<td><img src="image" alt="image" /></td>
<td>$img1 = (img1 + img2)/2$</td>
<td><img src="image" alt="image" /></td>
</tr>
<tr>
<td><strong>Divide:</strong></td>
<td><img src="image" alt="image" /></td>
<td><strong>Difference:</strong></td>
<td><img src="image" alt="image" /></td>
</tr>
<tr>
<td>$img1 = img1 \div img2$</td>
<td><img src="image" alt="image" /></td>
<td>$img1 =</td>
<td>img1 - img2</td>
</tr>
<tr>
<td><strong>AND:</strong></td>
<td><img src="image" alt="image" /></td>
<td><strong>Copy:</strong></td>
<td><img src="image" alt="image" /></td>
</tr>
<tr>
<td>$img1 = img1 \wedge img2$</td>
<td><img src="image" alt="image" /></td>
<td>$img1 = img2$</td>
<td><img src="image" alt="image" /></td>
</tr>
<tr>
<td><strong>OR:</strong></td>
<td><img src="image" alt="image" /></td>
<td><strong>Transparent–zero</strong></td>
<td><img src="image" alt="image" /></td>
</tr>
<tr>
<td>$img1 = img1 \lor img2$</td>
<td><img src="image" alt="image" /></td>
<td></td>
<td><img src="image" alt="image" /></td>
</tr>
<tr>
<td><strong>XOR:</strong></td>
<td><img src="image" alt="image" /></td>
<td></td>
<td><img src="image" alt="image" /></td>
</tr>
<tr>
<td>$img1 = img1 \oplus img2$</td>
<td><img src="image" alt="image" /></td>
<td></td>
<td><img src="image" alt="image" /></td>
</tr>
</tbody>
</table>
26.14 Subtract Background...

Removes smooth continuous backgrounds from gels and other images.

Based on the ‘rolling ball’ algorithm by Stanley Sternberg (see Sternberg S, Biomedical image processing, *IEEE Computer*, Jan 1983). Imagine a 3D surface with the pixel values of the image being the height, then a ball rolling over the back side of the surface creates the background. If Sliding Paraboloid is checked, the command will use a more robust implementation of the algorithm that uses an approximation of a paraboloid of rotation instead of a ball.

**Rolling Ball Radius** The radius of curvature of the paraboloid. As a rule of thumb, for 8-bit or RGB images it should be at least as large as the radius of the largest object in the image that is not part of the background. Larger values will also work unless the background of the image is too uneven. For 16-bit and 32-bit images with pixel value ranges different from 0–255, the radius should be inversely proportional to the pixel value range (e.g., for 16-bit images (pixel values 0–65535), typical values of the radius are around 0.2 to 5).

**Light Background** Allows the processing of images with bright background and dark objects.

**Separate Colors** (RGB images only) If unchecked, the operation will only affect the brightness, leaving the hue and saturation untouched.

**Create Background (Don’t Subtract)** If checked, the output is not the image with the background subtracted but rather the background itself. This option is useful for examining the background created (in conjunction with the Preview option). Create Background can be also used for custom background subtraction algorithms where the image is duplicated and filtered (e.g., removing ‘holes’ in the background) before creating the background and finally subtracting it with Process Image Calculator...

**Sliding Paraboloid** If checked, the ‘rolling ball’ is replaced by a paraboloid that has the same curvature at the apex as a ball of that radius. This option allows any value of the radius > 0.0001 (The ‘rolling ball’ algorithm requires a radius of at least 1). The ‘sliding paraboloid’ typically produces more reliable corrections since the ‘rolling ball’, a legacy algorithm, is prone to edge artifacts. E.g., to reduce the computing time the ‘rolling ball’ algorithm downscales the image in a way that is not really consistent. The ‘sliding paraboloid’ algorithm does not use downscaling and thus produces no downscaling artifacts. Nevertheless, the ‘sliding paraboloid’ is also an approximation, since it does not really use a paraboloid (an exact implementation
would require a great computing effort) but it rather slides parabolae in different
directions over the image.

**Disable Smoothing** For calculating the background (‘rolling the ball’), images are
maximum-filtered (3×3 pixels) to remove outliers such as dust and then smoothed
to reduce noise (average over (3×3 pixels). With **Disable Smoothing** checked, the
unmodified image data are used for creating the background. Check this option to
make sure that the image data after subtraction will never be below the background.


**See also:** How to correct background illumination in brightfield microscopy by G. Lan-
dini, Auto Local Threshold, Background subtractor, Rolling Ball Background
Subtraction (the plugin that implemented this command in versions up to
1.39e)

---

**Process** Subtract Background... **command.** This command uses a ‘sliding paraboloid’ or a
legacy ‘rolling ball’ algorithm that can be used to correct for uneven illuminated background as
shown in the profiles (**Analyze** Plot Profile [k]) below each image. The radius should be set to
at least the size of the largest object that is not part of the background.

### 26.15 Repeat Command [R]

Reruns the previous command. The **Edit** Undo and **File** Open commands are skipped.

**See also:** Undo and Redo
27 Analyze

This menu contains commands related to statistical measurements on image data, profile and histogram plotting and plugins related to image analysis.

27.1 Measure... [m]

Based on the selection type, calculates and displays on the Results table either area statistics, line lengths and angles, or point coordinates. Performed measurements can be specified in the Set Measurements... dialog box.

Area statistics are calculated for the complete image if there is no selection or for a selected subregion defined by one of the first four tools in the toolbar (cf. Tools). For linear selections (Straight, Segmented and Freehand lines, cf. Line Selection Tools) length and angle (straight lines only) are also calculated. For Point selections (cf. Point Tool and Multi-point Tool), the X and Y coordinates are recorded. Note that Measure... [m] will paint (invasively) a mark over the measured point in foreground color unless Mark Width in the Point Tool options dialog box is set to zero (cf. Point Tool).

With RGB images, results are calculated using brightness values. RGB pixels are converted to brightness values using the formula value = \( \frac{(\text{red} + \text{green} + \text{blue})}{3} \) or value = \( 0.299 \times \text{red} + 0.587 \times \text{green} + 0.114 \times \text{blue} \) if Weighted RGB Conversions is checked in Edit>Options>Conversions...

Intensity statistics (Mean, Modal, Median, Min. & Max. Gray Value, Standard Deviation and Integrated Density) can be performed on area, line and multi-point selections.

With area selections, the following parameters can be recorded: Area, Center of Mass, Centroid, Perimeter, Bounding Rectangle, Shape Descriptors, Fitted Ellipse, Feret’s Diameter, Skewness, Kurtosis and Area Fraction.

With line selections, the following parameters can be recorded: Length, Angle (straight lines only), and Bounding Rectangle. The mean, standard deviation, etc. are calculated from the values of the pixels along the line.

See also: The Results Table, Analyze Particles..., Summarize, Distribution..., Set Measurements..., Batch>Measure...
27.2 Analyze Particles...

This command counts and measures objects in binary or thresholded images (Image>Adjust>Threshold... [T] or Color Threshold...). Analysis is performed on the existing area selection or on the entire image if no selection is present.

It works by scanning the image or selection until it finds the edge of an object. It then outlines the object using the Wand Tool, measures it using the Measure... command, fills it to make it invisible, then resumes scanning until it reaches the end of the image or selection. Press Esc to abort this process.

Particle Analyzer (Analyze>Analyze Particles...). Features of thresholded images can be extracted by specifying suitable Size and Circularity ranges and/or by choosing if particles should be traced by their outer edge or by flood filling (Include Holes checkbox).

Size Particles with size (area) outside the range specified in this field are ignored. Values may range between 0 and 'Infinity'. For spatial scaled images (cf. Set Scale...
values are expressed in physical size square units or in pixels if *Pixel Units* is checked. Enter a single value and particles smaller than that value will be ignored.

**Circularity**  Particles with size circularity values outside the range specified in this field are also ignored. Circularity \(4\pi \times \frac{\text{Area}}{\text{Perimeter}^2}\), cf. Set Measurements...\) ranges from 0 (infinitely elongated polygon) to 1 (perfect circle).

**Show**  This drop-down menu specifies which image (or overlay) should ImageJ display after the analysis. Note that with IJ1.44e and later, the particle analyzer will display a blank image when the count of detected particles is zero and *Show* is not *Nothing*.

**Nothing**  Neither images nor overlays will be displayed.

**Outlines**  8–bit image containing numbered outlines of the measured particles (graylevels: Outlines: 0; Labels: 1; Background: 255). If *In situ Show* is checked, the original image will be replaced by this image.

**Bare Outlines**  8–bit image containing simple outlines of the measured particles without labels (graylevels: Outlines: 0; Background: 255). If *In situ Show* is checked, the original image will be replaced by this image.

**Masks**  8–bit binary image containing filled outlines of the measured particles (graylevels: Masks: 0; Background: 255). If *In situ Show* is checked, the original image will be replaced by this image.

**Ellipses**  8–bit binary image containing the best fit ellipse (cf. Edit►Selection►Fit Ellipse) of each measured particle (graylevels: Ellipses: 0; Background: 255). If *In situ Show* is checked, the original image will be replaced by this image.

**Count Masks**  16–bit image containing filled outlines of the measured particles painted with a grayscale value corresponding to the particle number. If *In situ Show* is checked, the original image will be replaced by this image.

**Overlay Outlines**  Displays outlines of the measured particles in the image overlay. Note that previously added overlays will be removed.

**Overlay Masks**  Displays filled outlines of the measured particles in the image overlay. Note that previously added overlays will be removed.

**Display Results**  If checked, the measurements for each particle will be displayed in the Results table.

**Clear Results**  If checked, any previous measurements listed in the Results table will be cleared.

**Summarize**  If checked, the particle count, total particle area, average particle size, area fraction and the mean of all parameters listed in the Set Measurements... dialog box will be displayed in a separate *Summary* table. Note that while single images ‘Summaries’ are output to the same *Summary* table, stack Summaries are printed...
in dedicated tables (named Summary of [stack title]). Also, note that descriptive statistics on Results measurements can be obtained at any time using the Summarize command.

**Add to Manager** If checked, the measured particles will be added to the ROI Manager...

**Exclude on Edges** If checked, particles touching the edge of the image (or selection) will be ignored.

**Include Holes** If checked, interior holes will be included. Disable this option to exclude interior holes and to measure particles enclosed by other particles. When this option is enabled, ImageJ finds the extent of each particle by tracing the outer edge. When it is disabled, ImageJ finds the extent by flood filling.

**Record Starts** This option allows plugins and macros to recreate particle outlines using the `doWand(x,y)` macro function. The CircularParticles macro demonstrates how to use this feature.

**In situ Show** If checked, the original image will be replaced by the binary mask specified in the Show drop-down menu. Note that this option does not apply to Overlay Outlines and Overlay Masks that are always displayed as non-destructive image overlays on the measured image.


See also: Particle Remover plugin, 4/8-Connected Particle Analysis

### 27.3 Summarize

For each column in the results table, calculates and displays the mean, standard deviation, minimum and maximum of the values in that column. This command is also available by right-clicking on The Results Table.

<table>
<thead>
<tr>
<th>Label</th>
<th>Area</th>
<th>Mean</th>
<th>Mode</th>
<th>Min</th>
<th>Max</th>
<th>Perim</th>
<th>Circ.</th>
<th>Feret</th>
<th>IntDen</th>
<th>Median</th>
<th>#Area</th>
</tr>
</thead>
<tbody>
<tr>
<td>63</td>
<td>bblobs.gif</td>
<td>5.30E+1</td>
<td>1.84E+2</td>
<td>1.16E+2</td>
<td>1.28E+2</td>
<td>2.48E+2</td>
<td>3.55E+1</td>
<td>5.26E-1</td>
<td>1.60E1</td>
<td>9.02E1</td>
<td>1.84E0</td>
</tr>
<tr>
<td>64</td>
<td>bblobs.gif</td>
<td>4.99E+1</td>
<td>1.72E+2</td>
<td>1.76E+2</td>
<td>1.28E+2</td>
<td>2.24E+2</td>
<td>3.67E+1</td>
<td>4.55E-1</td>
<td>1.70E1</td>
<td>8.41E1</td>
<td>1.76E0</td>
</tr>
</tbody>
</table>

**Mean** 347.547 187.727 203.375 128 230.375 67.902 0.834 24.875 67786.2500 93.500 100

**SD** 217.766 190.422 32.933 0 26.096 26.562 0.144 9.516 44012.2500 111 0

**Min** 1 128 128 128 128 2.928 0.406 1.414 128 128 128 100

**Max** 902 219.915 248 128 248 132.225 1 52.202 178720 240 100

See also: Analyze Particles..., Distribution...
27.4 Distribution...

Produces a relative frequency histogram from the data of a chosen column of the Results table [28].

Use the List or Copy buttons to save the histogram data. Mouse over the histogram bars to read the counts for each bin on the window’s lower right corner. Analyze\(\triangleright\)Histogram \([h]\) describes in more detail ImageJ’s histogram window.

This command is also available by right-clicking on The Results Table.

**Parameter** Specifies the parameter in the Results table to be analyzed.

**Data points** The number of rows that will be analyzed (informative)

**Automatic binning** If checked, ImageJ will use the method described by David Scott to assess the optimal histogram bin width (see Scott DW, Optimal and data-based
histograms. *Biometrika*, 66(3):605–610, Jan 1979). If unchecked, the number of bins can be set with Specify bins and the starting and ending limits of the histogram with range.

**See also:** Distribution Plotter, a macro that plots relative and cumulative frequencies on a double Y-axis graph

### 27.5 Label

This command labels the active selection with the current measurement counter value, i.e., the number of rows present in the Results table. Selection outline and label (at the selection centroid) are drawn invasively using current foreground/background colors. As for Edit\>Draw [d], Use the Edit\>Options\>Line Width... command, or double click on the line tool, to change the width of selection’s outline.

Selections can be labelled if they were previously analyzed (Analyze Particles... or Measure... [m] commands) and the parameter Centroid (cf. Set Measurements...) extracted in the Results table.

**See also:** Color Picker, XIV

### 27.6 Clear Results

Erases the results table and resets the measurement counter. This command is also available by right-clicking on The Results Table.

### 27.7 Set Measurements...

Use this dialog box to specify which measurements are recorded by Analyze\>Measure... [m], ROI Manager’s Measure command (cf. ROI Manager...) and Analyze\>Analyze Particles... Measurements are performed on the current selection, the entire active image if no selection is present. For thresholded images, measurements can be restricted to highlighted pixels if Limit to Threshold is checked.

This command is also available by right-clicking on The Results Table.

The dialog contains two groups of checkboxes: The first group controls the type of measurements that are printed to the Results table. The second group controls measurement settings.
The eighteen checkboxes of the first group are:

**Area**  Area of selection in square pixels or in calibrated square units (e.g., mm\(^2\), µm\(^2\), etc.) if Analyze\(\Rightarrow\)Set Scale... was used to spatially calibrate the image.

**Mean Gray Value**  Average gray value within the selection. This is the sum of the gray values of all the pixels in the selection divided by the number of pixels. Reported in calibrated units (e.g., optical density) if Analyze\(\Rightarrow\)Calibrate... was used to calibrate the image. For RGB images, the mean is calculated by converting each pixel to grayscale using the formula \(\text{gray} = (\text{red} + \text{green} + \text{blue})/3\) or gray = 0.299 × red + 0.587 × green + 0.114 × blue if Weighted RGB Conversions is checked in Edit\(\Rightarrow\)Options\(\Rightarrow\)Conversions...

**Standard Deviation**  Standard deviation of the gray values used to generate the mean gray value. Uses the Results table heading StdDev.

**Modal Gray Value**  Most frequently occurring gray value within the selection. Corresponds to the highest peak in the histogram. Uses the heading Mode.

**Min & Max Gray Level**  Minimum and maximum gray values within the selection.

**Centroid**  The center point of the selection. This is the average of the x and y coordinates of all of the pixels in the image or selection. Uses the X and Y headings.

**Center of Mass**  This is the brightness-weighted average of the x and y coordinates all pixels in the image or selection. Uses the XM and YM headings. These coordinates are the first order spatial moments.

**Perimeter**  The length of the outside boundary of the selection. Uses the heading Perim.. With IJ 1.44f and later, the perimeter of a composite selection is calculated by decomposing it into individual selections. Note that the composite perimeter and the sum of the individual perimeters may be different due to use of different calculation methods.

**Bounding Rectangle**  The smallest rectangle enclosing the selection. Uses the headings BX, BY, Width and Height, where BX and BY are the coordinates of the upper left corner of the rectangle.

**Fit Ellipse**  Fits an ellipse to the selection. Uses the headings Major, Minor and Angle. Major and Minor are the primary and secondary axis of the best fitting ellipse. Angle is the angle between the primary axis and a line parallel to the X-axis of the image. The coordinates of the center of the ellipse are displayed as X and Y if Centroid is checked. Note that ImageJ cannot calculate the major and minor axis lengths if Pixel Aspect Ratio in the Analyze\(\Rightarrow\)Set Scale... dialog is not 1.0. There are several ways to view the fitted ellipse:
1. The **Edit ▶ Selection ▶ Fit Ellipse** command replaces an area selection with the best fit ellipse.

2. The **DrawEllipse** macro draws (destructively) the best fit ellipse and the major and minor axis.

3. Select **Ellipses** from the **Show:** drop-down menu in the particle analyzer (**Analyze ▶ Analyze Particles...**) and it will draw the ellipse for each particle in a separate window.

**Shape Descriptors** Calculates and displays the following shape descriptors:

- **Circularity** \(4\pi \times \frac{\text{Area}}{\text{Perimeter}^2}\) with a value of 1.0 indicating a perfect circle. As the value approaches 0.0, it indicates an increasingly elongated shape. Values may not be valid for very small particles. Uses the heading **Circ**.

- **Aspect Ratio** The aspect ratio of the particle’s fitted ellipse, i.e., \(\frac{\text{Major Axis}}{\text{Minor Axis}}\). If **Fit Ellipse** is selected the **Major** and **Minor** axis are displayed. Uses the heading **AR**.

- **Roundness** \(4 \times \frac{\text{Area}}{\pi \times (\text{Major axis})^2}\) or the inverse of **Aspect Ratio**. Uses the heading **Round**.

- **Solidity** \(\frac{\text{Area}}{\text{Convex area}}\); Note that the **Edit ▶ Selection ▶ Convex Hull** command makes an area selection convex.

- **Feret’s Diameter** The longest distance between any two points along the selection boundary, also known as maximum caliper. Uses the heading **Feret**. The angle (0–180 degrees) of the Feret’s diameter is displayed as **FeretAngle**, as well as the minimum caliper diameter (**MinFeret**). The length of the object’s projection in the X (**FeretX**) and Y (**FeretY**) direction is also displayed.

- **Integrated Density** The sum of the values of the pixels in the image or selection. This is equivalent to the product of **Area** and **Mean Gray Value**. With IJ 1.44c and later, **Raw integrated density** (sum of pixel values) is displayed under the heading **RawIntDen** when **Integrated density** is enabled. The Dot Blot Analysis tutorial demonstrates how to use this option to analyze a dot blot assay.

- **Median** The median value of the pixels in the image or selection.

- **Skewness** The third order moment about the mean. The documentation for the **Moment Calculator plugin** explains how to interpret spatial moments. Uses the heading **Skew**.

- **Kurtosis** The fourth order moment about the mean. Uses the heading **Kurt**.

- **Area Fraction** For thresholded images is the percentage of pixels in the image or selection that have been highlighted in red using **Image ▶ Adjust ▶ Threshold...**. For non-thresholded images is the percentage of non-zero pixels. Uses the heading **%Area**.
Stack Position The position (slice, channel and frame) in the stack or hyperstack of the selection. Uses the headings Slice, Ch and Frame.

N.B.: For line selections the heading Length is created. For straight line selections, Angle is recorded even if Fit Ellipse is unchecked. Also, note that measurements that do not apply to certain selection types may be listed as NaN, Infinity or −Infinity.

The second part of the dialog controls measurement settings:

Limit to Threshold If checked, only thresholded pixels are included in measurement calculations. Use Image Adjust Threshold... [T] to set the threshold limits. This setting affects only thresholded images (see Settings and Preferences).

Display Label If checked, the image name and slice number (for stacks) are recorded in the first column of the results table, e.g., mri-stack.tif:9. For renamed selections (Edit Selection Properties... [y]) or selections measured via ROI Manager’s measure command (see ROI Manager...), the selection label is appended, e.g., blobs.gif:0339-0163 or blobs.gif:mySelection.

Invert Y Coordinates If checked, the XY origin is assumed to be the lower left corner of the image window instead of the upper left corner (see also Image Properties... [P]).

Scientific Notation If checked, measurements are displayed in scientific notation, e.g., 1.48E2.

Redirect To The image selected from this popup menu will be used as the target for statistical calculations done by Analyze Measure... [m] and Analyze Analyze Particles... commands. This feature allows you to outline a structure on one image and measure the intensity of the corresponding region in another image.

Decimal Places This is the number of digits to the right of the decimal point in real numbers displayed in the Results table and in Histogram windows.

See also: Feret’s Diameter macro
27.8 Set Scale...  

Use this dialog to define the spatial scale of the active image so measurement results can be presented in calibrated units, such as mm or µm.

Before using this command, use the straight line selection tool to make a line selection that corresponds to a known distance. Then, bring up the Set Scale... dialog, enter the Known Distance and unit of measurement, then click ‘OK’.

ImageJ will have automatically filled in the Distance in Pixels field based on the length of the line selection.

Setting Pixel Aspect Ratio to a value other than 1.0 enables support for different horizontal and vertical spatial scales, e.g., 100 pixels/cm horizontally and 95 pixels/cm vertically. To set the Pixel Aspect Ratio:

1. Measure the width and height (in pixels) of a digitized object with a known 1:1 aspect ratio.
2. Enter the measured width (in pixels) in Distance in Pixels. Enter the known width in Known Distance.
3. Calculate the aspect ratio by dividing the width by the height and enter it in Pixel Aspect Ratio.

When Global is checked, the scale defined in this dialog is used for all opened images during the current session instead of just the active image, see XVIII.

Click to Remove Scale resets Distance in Pixels field and Known Distance to zero and the Unit of Length to ‘pixel’.

See also: Three tutorials showing how to use this command: Examples of Image Analysis Using ImageJ by Larry Reinking, Measuring DNA Contour Lengths and Spatial Calibration (Fiji). The Copy_Pixel_Size plugin

27.9 Calibrate...  

Use this dialog box to calibrate an image to a set of density standards, for example radioactive isotope standards or a calibrated optical density step tablet.

Note that to create a calibration curve, the left column must contain a list of measured mean pixel values and the right column must contain the same number of calibration standard values.

The ImageJ web site has a tutorial on Optical Density Calibration explaining how to calibrate an image to an optical density step tablet.
Calibration settings related to spatial (pixel width, height and voxel depth), temporal (frame interval) and luminance (brightness) information can be set globally, i.e., can be applied to all images opened during the current session instead of just the active image. The Global flag can be set in three dialog prompts:

1. Image Properties... (pixel width, height, voxel depth, frame interval)
2. Analyze Set Scale... (pixel width and height)
3. Analyze Calibrate... (pixel intensity)

Once Global calibration is set, a ‘(G)’ is displayed in all image titles until ImageJ is closed. A warning message is displayed when a calibrated image with conflicting calibration is opened and the Global option is enabled.

Choose Disable Global Calibration to stop using global settings or Disable these Messages to keep respecting global settings, ignoring the calibration of the newly open image.

1. Before using this command, use Analyze Clear Results to reset the measurement counter and use one of the selection tools and Analyze Measure... [m] to record the mean gray value of each of the standards.

2. When finished making the measurements, select Analyze Curve Fitting... to display the Calibrate dialog box. To calibrate the image, enter the known standard values in the right column. The left column will be already populated with the measured mean gray values. Select a curve fitting method from the popup menu, enter the unit of measurement, and click ‘OK’. ImageJ will then display the calibration function on a separate window.

3. If the calibration function is not satisfactory, bring up the Calibrate... dialog box again and select a different curve fitting method.

In addition to the fourteen functions that can be chosen from the drop-down menu (described in Curve Fitting...) two other functions are available that do not require any measurement of OD standards:

**Uncalibrated OD** Causes ImageJ to convert gray values from 8–bit images to uncalibrated optical density values using the function Unc. OD = log_{10}(255/Pixel value).

**Pixel Inverter** Linear function defined by Inverted pixel = Bit-depth – 1 – Pixel value, with Bit-depth being 255 for 8–bit images or 65535 for 16–bit images.
27.10 Histogram [h]

Calculates and displays a histogram of the distribution of gray values in the active image or selection. **H** is a convenient shortcut for this command. The **H** shortcut is not listed on Mac OSX since it conflicts with the system wide shortcut for the 'Hide' command. It is shown on Windows and Linux and the **H** shortcut (without holding down **Cmd**) does work on OSX.

The X-axis represents the possible gray values and the Y-axis shows the number of pixels found for each gray value. The total pixel **Count** is also calculated and displayed, as well as the **Mean**, standard deviation (**StdDev**), minimum (**Min**), maximum (**Max**) and modal (**Mode**) gray value.

The horizontal LUT bar is scaled to reflect the display range of the image. **List** or **Copy** buttons to save the histogram data. Click on **Log** to display a log-scaled version of the histogram (overlaid in gray).

**Value / Count** pairs (i.e., grayscale value corresponding to the X-axis cursor position / the number of pixels that have that intensity) are displayed on...
the bottom right while mousing over the histogram window.

With RGB images, the histogram is calculated by converting each pixel to
grayscale using the formula \(\text{gray} = (\text{red} + \text{green} + \text{blue})/3\) or \(\text{gray} = 0.299 \times \text{red} + 0.587 \times \text{green} + 0.114 \times \text{blue}\) if \textit{Weighted RGB Conversions} is checked in \textit{Edit} \(\Rightarrow\) \textit{Options} \(\Rightarrow\) Conversions. . . . With 16–bit images, the range of gray values between the \textit{Min} and \textit{Max} values is divided into 256 bins. With 32–bit images, the number of bins is specified in the depicted dialog box.

With any image type, this dialog can be called with \texttt{Alt F} or by holding \texttt{Alt} while clicking on Histogram [h].

![Histogram Dialog Box](image)

\textbf{Bins} Specifies the number of bins.

\textbf{Use min/max} If checked, the X-axis range is determined by the minimum and maximum values in the image or selection. If unchecked, \textit{X Min} and \textit{X Max} values can be or specified to fix the X-axis range.

\textbf{Y Max} Fixes the Y-axis range. Type ‘Auto’ to have the range determined by the largest bin count.

The \texttt{getHistogram()} and \texttt{Plot.getValues()} macro functions can be used to get the ‘value’ and ‘Count’ data displayed when you click the \textit{List} button (cf. Obtaining Histogram Lists).

The getHistogram() and Plot.getValues() macro functions can be used to get the ‘value’ and ‘Count’ data displayed when you click the List button (cf. Obtaining Histogram Lists).

Listing 6 Obtaining Histogram Lists with getHistogram() and Plot.getValues().

```java
// 1. Single images:
run("Blobs (25K) ");
getHistogram(values, counts, 256);
for (i=0; i<values.length; i++)
    print(values[i], counts[i]);

// 2. Entire stacks:
run("T1 Head (2.4M, 16-bits) ");
run("Histogram", "stack ");
Plot.getValues(values, counts);
for (i=0; i<values.length; i++)
    print(values[i], counts[i]);
```

27.11 Plot Profile [k]
Displays a two-dimensional graph of the intensities of pixels along a line within the image. The X-axis represents distance along the line and the Y-axis is the pixel intensity.

Use the List, Save... or Copy... buttons to view and save the profile data. Use Edit > Options > Profile Plot Options... to adjust how plots are generated.

For rectangular selections (or line selections wider than one pixel), displays a 'column average plot', where the X-axis represents the horizontal distance through the selection and the Y-axis the vertically averaged pixel intensity. To average horizontally, hold down Alt or check Vertical Profile in the Edit > Options > Profile Plot Options... dialog box.

See also: Plot Z-axis Profile..., Surface Plot..., Dynamic Profiler, Oval Profile Plot, Radial Profile Plot, Radial Profile Extended plugins, StackProfilePlot macro

27.12 Surface Plot

Displays a three-dimensional graph of the intensities of pixels in a grayscale or pseudo color image (non-RGB images). The plot is based on the existing rectangular selection or on the entire image if no selection is present. A stack of plots can be produced when the source image is a stack or hyperstack. In this case, closing the plot stack window will abort the plotting process.

Polygon Multiplier Adjusts the number of profiles used to generate the plot.

Draw Wireframe If checked, the outline of each profile will be drawn in black.

Shade If checked, a shaded plot will be generated using the LUT of source image.

Draw Axis If checked, the three axis will be drawn and labeled.

Source Background is Lighter If checked, lighter areas in the source image will represent lower elevations (valleys) while darker areas will represent higher elevations (peaks).

Fill Plot Background with Black If checked, the plot is drawn with a black background, otherwise white will be used.
One Polygon Per Line If checked, all polygons will be drawn.

Smooth If checked, sharp fluctuations will be smoothed. Note that some plots can be further improved by adjusting the contrast of the source image or smoothing it.

See also: Plot Profile [k], Interactive 3D Surface Plot plugin (it works with all image types and viewing angle, perspective, scale, lighting and smoothing can be interactively adjusted), 3D Color Inspector/Color Histogram

27.13 Gels

Use the commands in this submenu to analyze one-dimensional electrophoretic gels. These commands use a simple graphical method that involves generating lane profile plots, drawing lines to enclose peaks of interest, and then measuring peak areas (i.e., definite integrals) using the Wand Tool. . . . Note that this technique cannot be used to compare bands on different gels unless gels are calibrated to known standards.

The commands listed in the this submenu are:

Select First Lane Requires a rectangular selection. Note that lanes are assumed to be vertical unless the width of the initial selection is at least twice its height.

Select Next Lane To be used after the first rectangular ROI is moved over the adjacent lanes. Note that all selections must have the same dimensions.
Plot Lanes Generates the lane profile plots. ImageJ assumes that only one plot is created per analysis. As a consequence, re-running this command more than once within the same analysis will cause an error message: “You must first use the ‘Select First Lane’ command”. To recreate plotted profiles use the Re-plot Lanes command.

Re-plot Lanes Recreates the lane profile plots. If Plot Lanes has not yet been run an error message is displayed: “The data needed to re-plot the lanes is not available”.

Reset Resets the analysis.

Label Peaks Uses the area measurements obtained with the Wand Tool to label lane peaks (see Gel Analyzer Options...).

Gel Analyzer Options... Use this dialog to control the behavior of the Gel Analyzer.

Vertical / Horizontal scale factor Specify the scale factor at which the lane profile plots are displayed.

Uncalibrated OD If checked, ImageJ will convert gray values to uncalibrated optical density values using the function: $\text{Unc. OD} = \log_{10}\left(\frac{255}{\text{pixel value}}\right)$. Note that images can be calibrated to, e.g., a calibrated optical density step tablet using the Analyze >> Calibrate... command.

Label With Percentages If checked, the Label Peaks command will print to the Results table the ‘peak percentage’ and use it to label the plot. The percentage value is obtained by dividing the area of each peak by the sum of all measured peaks from all lanes.

Invert Peaks If checked, peaks will be inverted, i.e., bands darker than background will have positive peaks, bands lighter than background will have negative peaks. This setting does not change the analysis (see Image >> Lookup Tables >> Invert LUT).
For practice, refer to the video tutorial on the ImageJ wiki page and use the File>Open Samples>Gel sample image (1-D gel) to perform the following steps. Note that a copy of the gel image with the lane outlines can be created at any point using the Image>Overlay>Flatten [F] command.

1. Use the rectangular selection tool to outline the first lane. This should be the left most lane if the lanes are vertical or the top lane if the lanes are horizontal.

2. Select Gels>Select First Lane ( ) and the lane will be outlined and ‘Lane 1 selected’ displayed in the status bar.

3. Move the rectangular selection right to the next lane (or down if the lanes are horizontal) and select Gels>Select Next Lane ( ). The selected lane is outlined and labeled, and ‘Lane n selected’ is displayed in the status bar.

4. Repeat the previous step for each remaining lane.

5. Select Gels>Plot Lanes ( ) to generate the lane profile plots.

6. Use the Straight Line Selection Tool to draw base lines and/or drop lines so that each peak of interest defines a closed area (ImageJ will automatically switch to the Straight Line tool). Note that you can hold [Shift] to constrain lines to be either horizontal or vertical. To access to all the lanes, it may be necessary to scroll the image vertically using the Scrolling Tool (Hold down the space bar to temporarily switch to this tool).

7. For each peak, measure the size by clicking inside the peak with the Wand Tool. If necessary, scroll the image vertically by holding down the space bar and dragging.

8. Select Gels>Label Peaks to label each measured peak with its size as a percent of the total size of the measured peaks.

See also: Calibrate..., SinglePanelGelAnalyzer macro, Video tutorial on ImageJ wiki, Luke Miller’s tutorial, Dot Blot Analysis, Dot Blot Analyzer toolset

27.14 Tools ▷

This submenu provides access to various image analysis plugins.
27.14.1 Save XY Coordinates...

Writes to a text file the XY coordinates and pixel value of all non-background pixels in the active image. Background is assumed to be the value of the pixel at the upper left corner of the image. For grayscale images, writes three values per line (x, y, and value), separated by spaces. For RGB images, writes five values per line (x, y, red, green and blue). The origin of the coordinate system is at the lower left corner of the image.

The number and percentage of non-background pixels is printed to the Log window if Suppress Log output is not checked.

27.14.2 Fractal Box Count...

This command is used to estimate the fractal dimension \( D \) of a binary image. \( D \) can be used as a measure of pattern complexity (cell shape, vascularization, textures, etc.) and is specially relevant in cases in which Euclidean measures such as diameter or length are not good descriptors of complexity.

The command counts the number of boxes of an increasing size needed to cover a one pixel binary object boundary and implements the method described in T. G. Smith, Jr., G. D. Lange and W. B. Marks, Fractal Methods and Results in Cellular Morphology, *J Neurosci Methods*, 69:1123–126, 1996.

A plot is generated with the log of size on the X-axis and the log of count on the Y-axis and the data is fitted with a straight line. The slope (S) of the line is the negative of the fractal dimension, i.e., \( D = -\text{slope} \). ‘Size’ (S) and ‘count’ (C) are printed to the Results table. Refer to the source code for additional information.

See also: Fractal Dimension and Lacunarity plugin

147
27.14.3 Analyze Line Graph

ImageJ can be used to recover numeric coordinate data from scanned line graphs using the following procedure. Steps 2 and 3 are not necessary for binary (black and white) graphs. For practice, use the File ▶ Open Samples ▶ Line Graph sample image.

1. Open the image containing the graph.
2. Open the Threshold... [T] tool (Shift T). Adjust the threshold so the graph is highlighted in red.
3. Click on Apply (make sure foreground is black and background is white).
4. Use the Elliptical Selection Tool as an eraser (press Backspace to erase) to isolate a single curve (NB: background color must be white, cf. Color Picker... [K]).
5. Select the curve by clicking to the left of it with the Wand Tool.
6. Use Edit ▶ Clear Outside to erase everything but the curve.
7. Use Analyze ▶ Tools ▶ Analyze Line Graph to get the XY coordinates.

27.14.4 Curve Fitting...

ImageJ’s curve fitter (Analyze ▶ Tools ▶ Curve Fitting...) – ImageJ 1.44i.

ImageJ’s curve fitter provides a very simple tool for fitting various functions to X- and Y-data. The typical usage of this command is listed below.
1. Tabular data is entered or copied in the input window or alternatively, a two column text file is opened by clicking on the *Open* button. Values may be separated by spaces, tabs, commas or semicolons.

2. The function to be fit is selected from the drop-down menu. 14 built-in functions are available. User defined functions with up to six parameters are also possible by choosing *User-defined*. In this case, *Formula* and *Fitting Options* must be specified by the user.

3. Once the *Fit* button is pressed, ImageJ displays a graph of the data with the fitted curve as well as a log window containing information about the fit and the values of the fitted parameters if *Show Settings* is checked.

4. Click *Apply* to create a 32–bit copy of the current image transformed with the chosen function.

See also: Profile Plot Options..., CurveFittingDemo, RodbardSigmoidFit and PlotSigmoidDerivatives macros

27.14.5 ROI Manager...

The ROI (Region of Interest) Manager is a tool for working with multiple selections. The selections can be from different locations on an image, from different slices of a stack or from different images. All selection types, including points, lines and text, are supported.

*Add* Click *Add* to add the current selection to the list, or press $\text{[t]}$, the keyboard shortcut for the *Edit* $\rightarrow$ *Selection* $\rightarrow$ *Add to Manager* $\text{[t]}$ command. The ROI manager creates a three part label. The first part (stacks only) is the slice number, the second is the Y-coordinate of the selection and the third is the X-coordinate. Click on a label to restore the associated selection to the current image. With stacks, the selection is restored to the slice it came from. Hold down $\text{[Shift]}$ while clicking *Add* to ‘Add and Draw’. Hold down $\text{[Ctrl]}$ while clicking *Add* to ‘Add and Rename’.

Install the ROIManagerMacros macro set and you will be able to add a selection by pressing $\text{[1]}$, ‘add and rename’ by pressing $\text{[2]}$, ‘add and draw’ by pressing $\text{[3]}$ and ‘add and advance to the next slice’ by pressing $\text{[4]}$.

*Update* Replaces the selected ROI on the list with the current selection. This is usually a modified version of a selection from the ROI Manager list.

*Delete* Deletes the selected ROIs from the list. Deletes all the ROIs if none is selected.

*Rename*... Renames the selected ROI.

<table>
<thead>
<tr>
<th>Function</th>
<th>Formula</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Straight Line</td>
<td>$y = a + bx$</td>
<td>cf. Pixel Inverter (Calibrate...)</td>
</tr>
<tr>
<td>2(^{nd}) Degree Polynomial</td>
<td>$y = a + bx + cx^2$</td>
<td></td>
</tr>
<tr>
<td>3(^{rd}) Degree Polynomial</td>
<td>$y = a + bx + cx^2 + dx^3$</td>
<td></td>
</tr>
<tr>
<td>4(^{th}) Degree Polynomial</td>
<td>$y = a + bx + cx^2 + dx^3 + ex^4$</td>
<td></td>
</tr>
<tr>
<td>5(^{th}) Degree Polynomial</td>
<td>$y = a + bx + cx^2 + dx^3 + ex^4 + fx^5$</td>
<td>Via the <em>User-defined</em> option</td>
</tr>
<tr>
<td>Exponential</td>
<td>$y = a \times e^{bx}$</td>
<td></td>
</tr>
<tr>
<td>Power</td>
<td>$y = ax^b$</td>
<td></td>
</tr>
<tr>
<td>Log</td>
<td>$y = a \times \ln(bx)$</td>
<td></td>
</tr>
<tr>
<td>Gamma Variate</td>
<td>$y = a \times (x - b)^c \times e^{-(\frac{x}{b})}$</td>
<td></td>
</tr>
<tr>
<td>Rodboard</td>
<td>$y = \frac{d+(a-d)}{1+(\frac{x}{f})^b}$</td>
<td>[30]</td>
</tr>
<tr>
<td>Exponential with Offset</td>
<td>$y = a \times e^{-bx} + c$</td>
<td></td>
</tr>
<tr>
<td>Gaussian</td>
<td>$y = a + (b - a) \times e^{-\frac{(x-a)^2}{2\sigma^2}}$</td>
<td>[30]</td>
</tr>
<tr>
<td>Exponential Recovery</td>
<td>$y = a \times (1 - e^{(-bx)}) + c$</td>
<td>cf. FRAP_Profiler plugin</td>
</tr>
</tbody>
</table>

**Measure** Measures the selected ROIs, or if none is selected, all ROIs on the list. Use **Analyze\(\text{\raise0.5ex\hbox{$\triangleright$}}\) Set Measurements\(\text{\raise0.5ex\hbox{$\triangleright$}}\)\) to specify the parameters to measure. With a stack, you will be given the option to measure all the slices if all ROIs are associated with the first slice (have labels like 0001-xxxx-yyyy) or all have labels in the form xxxx-yyyy.

**Deselect** Deselects any selected ROIs on the list. **Delete, Measure, More\(\text{\raise0.5ex\hbox{$\triangleright$}}\)Save..., and More\(\text{\raise0.5ex\hbox{$\triangleright$}}\)Combine** work with all ROIs on the list when none are selected.

**Properties...** See **Edit\(\text{\raise0.5ex\hbox{$\triangleright$}}\)Selection\(\text{\raise0.5ex\hbox{$\triangleright$}}\)Properties... \(\text{[y]}\).**

**Flatten [F]** See **Image\(\text{\raise0.5ex\hbox{$\triangleright$}}\)Overlay\(\text{\raise0.5ex\hbox{$\triangleright$}}\)Flatten [F].**

**Show All** Displays a non-destructive overlay that outlines and labels all ROI Manager selections. Click **Show All** a second time to remove the overlay. Click on a label (selection number) in the overlay to activate the corresponding selection. That selection can then be moved or edited and the overlay will be dynamically up-
The ROI Manager (Analyze → Tools → ROI Manager...) – ImageJ 1.44l.

dated. The color and behavior of the Show All overlay can be changed in the More » Options dialog box.

**Edit Mode** Disables / enables selection labels

**More** » Displays a drop-down menu with several additional commands (this drop-down menu is also available when right-clicking on any listed ROI):

*Open...* Opens a .roi file and adds it to the list or opens a ZIP archive (.zip file) and adds all the selections contained in it to the list. Use the Open All macro to add all the .roi files in a folder.

*Save...* Saves the selected ROI as an .roi file. If no ROIs are selected, saves all the ROI Manager selections as a ZIP archive.

*Fill* Alias for Edit → Fill [f].

*Draw* Alias for Edit → Draw [d].

*AND* Uses the conjunction operator on the selected ROIs to create a composite selection. All ROIs are considered if none is selected.

*OR (Combine)* Uses the union operator on the selected ROIs to create a composite selection. Combines all the ROIs if none is selected.

*XOR* Uses the exclusive or operator on the selected ROIs to create a composite selection [31]. All ROIs are considered if none is selected.
**Split** Splits the current selection (it must be a composite selection) into its component parts and adds them to the ROI Manager.

**Add Particles** Adds objects segmented by the particle analyzer to the ROI Manager. Requires that *Record Starts* be checked in the **Analyze** > **Analyze Particles…** dialog box. Particle analyzer objects can also be added to the ROI Manager by checking *Add to Manager* in the Analyze Particles dialog box.

**Multi Measure** Measures all the ROIs on all images in the stack, creating a Results table with either one row per image (if *One Row Per Slice* is checked in the dialog) or one row per measurement [32].

**Sort** Sorts the list in alphanumeric order.

**Specify…** See **Edit** > **Selection** > **Specify…**

**Remove Slice Info** Removes the information in the ROI names that associates them with particular stack slices

**Help** Opens http://imagej.nih.gov/ij/docs/menus/analyze.html#manager

**Options…** Displays a dialog box that allows you to set the *Show All* color, to associate *Show All* ROIs with the stack slices, and to have the ROI Manager restore ROIs to the center of the image.

![Logical operations using the ROI Manager (Analyze > Tools > ROI Manager…).](image)

**See also:** **Selection** > **Properties…** [y], **Add Selection…** [b], XVI, **ROI Color Coder** macro

---

**XIX** **Selecting Multiple ROIs in the ROI Manager**

For most ROI Manager operations *Deselect* works as a *Select All* button, e.g., to measure all ROIs in manager one would press *Deselect* then *Measure*. In addition, it is possible to select contiguous ROIs with a single Shift–click. Non-contiguous ROIs can be selected by Ctrl–click (Command-click on Mac OS X).
27.14.6 Scale Bar...

Draws a labeled spatial calibration bar.

**Width** Length of the bar in calibrated units.

**Height** Height of the bar in pixels.

**Font Size** Adjusts the labels’ font size.

**Color** Adjusts the text color (cf. XIV).

**Background** Adjusts the filling color of the label text box.

**Location** Adjusts the position of the calibration bar. If there is a selection, the bar is initially drawn at the selection.

**Bold Text / Serif Font** Specify if label should be typeset in boldface / serif typeface.

**Hide Text** If checked the bar is drawn without label.

**See also:** Set Scale..., XVIII

27.14.7 Calibration Bar...

Creates an RGB copy of the current image and displays a labeled calibration bar on it.


**Location** Defines the position of the bar. If there is a selection, the bar is initially drawn at the selection.

**Fill Color** Defines the bar’s background color.

**Label** Adjusts the text color.

**Number of Labels** Adjusts the total number of values displayed.

**Decimal Places** Adjust the number of decimal places present in the labels.

**Font Size** Adjusts labels’ font size (labels are drawn bold if *Bold Text* is checked)

**Zoom Scale** Zooms the entire calibration bar.

The Calibration Bar Macros can be used to add a calibration bar to a stack or to all the images and stacks in a folder.

**See also:** Calibrate..., XVIII
28 Plugins ▷

28.1 Macros ▷

This submenu contains commands for installing, running and recording macros, as well as any macro commands added by Plugins ▷ Macros ▷ Install... Macros contained in a file named StartupMacros.txt, in the macros folder, are automatically added to this submenu when ImageJ starts up.

28.1.1 Install... 

Adds one or more macros contained in a file to the bottom of this submenu. To install a set of macros, and at the same time view their source code, open the macro file with File ▷ Open and use The ImageJ Editor’s Macros ▷ Install Macros command. Macros in the file ImageJ/macros/StartupMacros.txt are automatically installed when ImageJ starts up. Similarly, with ImageJ 1.44f and later, newly opened macro sets with two or more macros are also automatically installed in this menu.

28.1.2 Run... 

Loads and runs a macro without opening it in The ImageJ Editor. To run a macro, and at the same time view its source code, open it with File ▷ Open and use the editor’s Macros ▷ Run Macro command.

28.1.3 Startup Macros... 

Opens ImageJ/macros/StartupMacros.txt. The same file can be opened by holding [Shift] while selecting Startup Macros from the [ ]] drop-down menu.

28.1.4 Record... 

Opens the ImageJ command recorder. To create a macro, open the recorder, use one or more ImageJ commands, then click Create. When the recorder is open, each menu command you use generates a macro run() function call. The run() function has one or two string arguments. The first is the command name. The optional second argument contains dialog box parameters. Examples:

- Create a rectangular, oval or line selection and the recorder will generate a make-Rectangle(), makeOval() or makeLine() function call.

- Click on Auto or Set in the Image ▷ Adjust ▷ Threshold... [T] window to generate a setThreshold() call, and on Reset to generate a resetThreshold() call.
– Select an image from the Window menu to generate a `selectWindow()` call.

– Click in the `Image ⊿ Color ⊿ Color Picker... [K]` window to generate `setForegroundColor()` and `setBackgroundcolor()` calls.

Note that you can interact with the recorder window by deleting or commenting lines of code or pasting text from The ImageJ Editor. This may be specially useful when writing your own macros or to generate simple ‘Session Logs’. In this case, you would start the Recorder and let ImageJ keep track of the performed actions by generating macro code.

**See also:** The ImageJ Editor, Extending ImageJ, The ImageJ Macro Language — Programmer’s Reference Guide

### 28.2 Shortcuts

This submenu contains commands for creating keyboard shortcuts and for installing and removing plugins.

#### 28.2.1 List Shortcuts...

This command generates a table with the ImageJ keyboard shortcuts in one column and the commands they call in another. Commands prefixed by ‘*’ refer to shortcuts created with Create Shortcuts... Commands prefixed by ‘~’ refer to installed macros (listed in Plugins ⊿ Macros ⊿ submenu) and override default ImageJ hot-keys.

Note that, as mentioned previously, you do not have to hold down `Ctrl` to use a keyboard shortcut. E.g., to open an image press `Ctrl` (File ⊿ Open...).

**See also:** Keyboard Shortcuts, Create Shortcuts...
28.2.2 Create Shortcuts...

Assigns a keyboard shortcut to an ImageJ menu command and lists the shortcut in the Shortcuts submenu.

Select the command from the popup menu and enter the shortcut in the text field. A shortcut can be a lower or uppercase letter or ‘F1’ through ‘F12’. Use Plugins ⊂ Utilities ⊂ List Shortcuts... to get a list of shortcuts that are already being used.

28.2.3 Install Plugin...

Installs a plugin in a user-specified submenu. Plugins with a showAbout() method are also automatically added to the Help ⊂ About Plugins ⊂ submenu.

Use the first popup menu to select the plugin and the second to select the submenu it is to installed in. The command must be different from any existing ImageJ command. Shortcut (optional) must be a single letter or ‘F1’ through ‘F12’. Argument (optional) is the string that will passed to the plugin’s run method.

28.2.4 Remove...

Removes commands added to the Shortcuts submenu by Create Shortcuts... Also removes commands added by Install Plugin... and removes plugins installed in the Plugins menu. The menus are not updated until ImageJ is restarted.
28.3 Utilities

28.3.1 Control Panel... [U]

This command [33] opens a window containing ImageJ commands in a hierarchical tree structure. Click on a leaf node to launch the corresponding ImageJ command (or plugin). Double click on a tree branch node (folder) to expand or collapse it. Click and drag on a tree branch node (folder) to display its descendants in a separate (child) window. In a child window, click on ‘Show Parent’ to re-open the parent window.

See also: Command Finder

28.3.2 ImageJ Properties...

This command displays various ImageJ properties (Java version, OS name and version, path separator, location of directories, screen size, etc.) in a text window. Holding \texttt{Alt} lists all Java properties.

See also: Status bar, Help▷About ImageJ...

28.3.3 Threads...

This command lists, in a text window, the currently running threads and their priorities.

28.3.4 Benchmark

Runs 62 image processing operations on the current image and displays the elapsed time in the ImageJ status bar. Additional benchmarks, test results, and source code are available in the Benchmarks package of plugins.

See also: FAQ’s on the ImageJ Documentation Wiki

28.3.5 Reset...

Use this command to unlock a locked Image, or to reclaim memory used by the clipboard and undo buffers (cf. Undo and Redo).
28.3.6 Monitor Memory...

Displays a continuously updated graph of ImageJ’s memory utilization, which can be useful for detecting memory leaks. Ideally you should be able to open several images, process them, close them, and the amount of memory used will be the same as when you started.

Clicking on ImageJ's status bar, which forces the Java garbage collector run, may help reclaim unused memory (cf. Status bar).

Starting the memory monitor holding down \texttt{Alt} will have it use a 640×480 window that simulates how a frame grabber plugin would work.

28.3.7 Search...

Described in Finding Commands.

28.3.8 Capture Screen [g]

Copies the screen to an RGB image and displays that image a new window. Holding \texttt{Ctrl Shift G} will capture the screen while a modal dialog box is active if the dialog is based on ImageJ’s GenericDialog class.

28.3.9 Capture Image

Copies a WYSIWYG version of active image to an RGB image and displays that image a new window.

\textbf{See also:} Flatten [F]

28.3.10 Find Commands... [l]

Described in Command Finder.

28.4 New

This submenu contains commands opening editor windows that can be used to edit and run macros, scripts and plugins. It also has a command that opens a text window of a specified size and a command that opens a table that macros can write to. The editor windows opened by Plugin, Plugin Filter and Plugin Frame contain prototype Java code for the three types of plugins supported by ImageJ.

\textbf{See also:} The ImageJ Editor, Extending ImageJ
28.4.1 Macro

Opens a blank editor window with the title ‘Macro.txt’.

See also: Macros, The ImageJ Editor, Text Window..., File New Text Window [N]

28.4.2 JavaScript

Opens a blank editor window with the title ‘Script.js’.

See also: Scripts, The ImageJ Editor

28.4.3 Plugin

Opens an editor window containing a prototype plugin that implements the PlugIn interface. Plugins of this type open, capture or generate images. The prototype displays "Hello world!" in the ImageJ window. Press Ctrl R (File Run Macro) to compile and run it. Note that the name you choose for the plugin should include at least one underscore. Another example is the Step Maker plugin.

28.4.4 Plugin Filter

Opens an editor window containing a prototype plugin that implements the PlugInFilter interface. Plugins of this type process the active image. The prototype inverts the active image twice. Another example is the Image Inverter.

28.4.5 Plugin Frame

Opens an editor window containing a prototype plugin that extends the PlugInFrame class. Plugins of this type displays a window containing controls such as buttons and sliders. The prototype opens a window containing a text area. Another example is the IP Demo plugin.

28.4.6 Text Window...

Opens a text window of a specified size that macros can write to. PrintToTextWindow, Clock and ProgressBar are examples of macros that write to a text window.

See also: Plugins New Macro, File New Text Window [N]

160
28.4.7 Table...

Opens a blank table, similar to the Results table, that macros can write to. SineCosineTable2 (http://imagej.nih.gov/ij/macros/SineCosineTable2.txt) is an example of such a macro.

See also: Plugins► New► Text Window...

28.5 Compile and Run...

Compiles and runs a plugin. Runs a plugin if the name of the selected file ends in .class. Requires that ImageJ be running on a Java Virtual Machine that includes the javac compiler, which is contained in the Tools.jar archive. Tools.jar is included with the Windows and Linux versions of ImageJ bundled with Java, and it is pre-installed on Mac OS X. Troubleshooting information can be found under ‘Compiling Plugins’ in the Linux and Windows release notes.

The Edit► Options► Compiler... command can be used to configure the javac compiler. Since ImageJ 1.44c and later, Compile and Run... adds the Bio-Formats plugin (loci_tools.jar) to the Java compiler’s classpath.
29 Window

This menu contains four commands plus a list of open ImageJ windows. The currently active image will have a checkmark next to its name. To activate a window, pull down this menu and select the window by name.

29.1 Show All [ ]

Makes all the windows associated with ImageJ visible.

29.2 Put Behind [tab]

Displays the next open image. Repeatedly press the tab key to cycle through all open images. Note that pressing [Enter] on any image will bring the ImageJ window to the foreground.

See also: I

29.3 Cascade

Moves all open images to the left side of the screen, slightly offset from each other, and displayed in the order they are listed at the bottom of this menu.

29.4 Tile

Shrinks all open image windows and repositions them to fit on the screen without overlapping.
30  Help

Many of the commands in this menu use ImageJ’s BrowserLauncher to open a Web page using the user’s default browser. On Linux, BrowserLauncher looks for 'netscape', 'firefox', 'konqueror', 'mozilla', 'opera', 'epiphany' or 'lynx' and uses the first one it finds.

30.1  ImageJ Website. . .

Opens the ImageJ home page.

30.2  ImageJ News. . .

Opens the News section of the ImageJ website.

30.3  Documentation. . .

Opens the Documentation section of the ImageJ website.

30.4  Installation. . .

Opens the Installation section of the ImageJ website specifically dedicated to the OS in which ImageJ is running, i.e either Linux, Mac OS 9, Mac OS X or Windows. Worth reading are the sections Known Problems and Troubleshooting.

30.5  Search Website. . .

Opens the Search page on the ImageJ website. Use this page to find plugins, macros, or messages that have been posted to the ImageJ mailing list.

30.6  List Archives. . .

Opens the ImageJ Interest Group page on the NIH LISTSERV facility. Here you can search the mailing list archives, post a message to the list, join or leave the list, or update options.

30.7  Dev. Resources. . .

Opens the Developer Resources section of the ImageJ website.
30.8 Plugins...

Opens the Plugins page on the ImageJ website, which lists more than 500 ImageJ plugins.

30.9 Macros...

Opens the macros directory on the ImageJ website, which contains more than 400 ImageJ macros.

30.10 Macro Functions...

Opens the Macro Functions reference page, an indispensable guide to the built in functions that can be called from the ImageJ macro language.

See also: Macros

30.11 Update ImageJ...


See also: Maintaining ImageJ

30.12 Refresh Menus

Use this command to update ImageJ’s menus after adding (or removing) plugins or macros to the plugins folder. Prior to ImageJ 1.44b this command was named ‘Update Menus’.

30.13 About Plugins

This submenu displays information about some of the plugins in the ImageJ plugins folder. To be included in this submenu, a plugin must be packaged as a JAR file. There is an example at rsb.info.nih.gov/ij/plugins/jar-demo.html.
30.14 About ImageJ...

Opens an image containing information about the ImageJ version, the author, the website, Java version and memory available. Note that clicking in the status bar is a quicker way to show this information.

See also: Plugins Utilities ImageJ Properties..., Status bar
Part VI

Keyboard Shortcuts

The following table summarizes the keyboard shortcuts built into ImageJ. You can create additional shortcuts, or override built-in ones, by creating simple macros and adding them to the `StartupMacros.txt`. You can also assign a function key to a menu command using `Plugins\Shortcuts\Create Shortcuts...`.

Except when using the text tool, you do not need to hold down the control key to use a keyboard shortcut (cf. `Edit\Options\Misc...`).

A similar list can be obtained using ImageJ `Plugins\Shortcuts\List Shortcuts...` command. This table is also available at [http://imagej.nih.gov/ij/docs/shortcuts.html](http://imagej.nih.gov/ij/docs/shortcuts.html).

See also: Shortcuts and Modifier Keys, Finding Commands, Macro Tools

**List of ImageJ 1.44 built-in shortcuts.** This table can be obtained within ImageJ using the `Plugins\Shortcuts\List Shortcuts...` command.

<table>
<thead>
<tr>
<th>Command / Operation</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td></td>
<td></td>
</tr>
<tr>
<td>New</td>
<td>N</td>
<td>Create new image or stack</td>
</tr>
<tr>
<td>Text Window</td>
<td>Shift N</td>
<td>Create new text window</td>
</tr>
<tr>
<td>System Clipboard</td>
<td>Shift V</td>
<td>Create image from system clipboard</td>
</tr>
<tr>
<td>Open...</td>
<td>O</td>
<td>Open file (any format recognized by ImageJ)</td>
</tr>
<tr>
<td>Open Next</td>
<td>Shift O</td>
<td>Open next image in folder</td>
</tr>
<tr>
<td>Open Samples</td>
<td>Shift B</td>
<td>Opens the <code>Blobs.gif</code> example image</td>
</tr>
<tr>
<td>Close</td>
<td>W</td>
<td>Close the active window</td>
</tr>
<tr>
<td>Save</td>
<td>S</td>
<td>Save active image in Tiff format</td>
</tr>
<tr>
<td>Revert</td>
<td>R</td>
<td>Revert to saved version of image</td>
</tr>
<tr>
<td>Print...</td>
<td>F</td>
<td>Print active image</td>
</tr>
<tr>
<td>Edit</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Z</td>
<td>Undo last operation</td>
</tr>
<tr>
<td>Cut</td>
<td>X</td>
<td>Copy selection to internal clipboard and clear</td>
</tr>
<tr>
<td>Copy</td>
<td>C</td>
<td>Copy selection to internal clipboard</td>
</tr>
<tr>
<td>Paste</td>
<td>V</td>
<td>Paste contents of internal clipboard</td>
</tr>
<tr>
<td>Clear</td>
<td>Backspace</td>
<td>Erase selection to background color</td>
</tr>
<tr>
<td>Fill</td>
<td>F</td>
<td>Fill selection in foreground color</td>
</tr>
<tr>
<td>Draw</td>
<td>D</td>
<td>Draw selection</td>
</tr>
<tr>
<td>Invert</td>
<td>Shift L</td>
<td>Invert image or selection</td>
</tr>
<tr>
<td>Selection</td>
<td>A</td>
<td>Select entire image</td>
</tr>
<tr>
<td>Select All</td>
<td>A</td>
<td>Select entire image</td>
</tr>
</tbody>
</table>
List of ImageJ 1.44 built-in shortcuts. This table can be obtained within ImageJ using the Plugins ➤ Shortcuts ➤ List Shortcuts... command.

<table>
<thead>
<tr>
<th>Command / Operation</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection ➤ Select None [A]</td>
<td>Shift A</td>
<td>Remove selection</td>
</tr>
<tr>
<td>Selection ➤ Restore Selection [E]</td>
<td>Shift E</td>
<td>Restore previous selection</td>
</tr>
<tr>
<td>Selection ➤ Properties... [y]</td>
<td>Y</td>
<td>Defines selection properties</td>
</tr>
<tr>
<td>Selection ➤ Add to Manager [t]</td>
<td>T</td>
<td>Add selection to ROI Manager</td>
</tr>
<tr>
<td>Adjust ➤ Brightness/Contrast... [C]</td>
<td>Shift C</td>
<td>Adjust brightness and contrast</td>
</tr>
<tr>
<td>Adjust ➤ Threshold... [T]</td>
<td>Shift T</td>
<td>Adjust threshold levels</td>
</tr>
<tr>
<td>Show Info... [i]</td>
<td>I</td>
<td>Display information about active image</td>
</tr>
<tr>
<td>Properties... [P]</td>
<td>Shift P</td>
<td>Display image properties</td>
</tr>
<tr>
<td>Color ➤ Color Picker... [K]</td>
<td>Shift K</td>
<td>Open Color Picker</td>
</tr>
<tr>
<td>Stacks ➤ Next Slice [&gt;]</td>
<td>&gt; or →</td>
<td>Go to next stack slice</td>
</tr>
<tr>
<td>Stacks ➤ Previous Slice [&lt;]</td>
<td>&lt; or ←</td>
<td>Go to previous stack slice</td>
</tr>
<tr>
<td>Stacks ➤ Reslice... [/]</td>
<td>/</td>
<td>Reslice stack</td>
</tr>
<tr>
<td>Stacks ➤ Orthogonal Views [H]</td>
<td>Shift H</td>
<td>Toggle orthogonal view display</td>
</tr>
<tr>
<td>Stacks ➤ Tools ➤ Start Animation []</td>
<td>\</td>
<td>Start/stop stack animation</td>
</tr>
<tr>
<td>Hyperstacks ➤ Channels... [Z]</td>
<td>Shift Z</td>
<td>Open the ‘Channels’ tool</td>
</tr>
<tr>
<td>Hyperstacks</td>
<td>&gt; or ‹</td>
<td>Next hyperstack channel</td>
</tr>
<tr>
<td>Hyperstacks</td>
<td>&lt; or ‹</td>
<td>Previous hyperstack channel</td>
</tr>
<tr>
<td>Hyperstacks</td>
<td>Ctrl ‹</td>
<td>Next hyperstack slice</td>
</tr>
<tr>
<td>Hyperstacks</td>
<td>Ctrl ‹</td>
<td>Previous hyperstack slice</td>
</tr>
<tr>
<td>Hyperstacks</td>
<td>Alt ‹</td>
<td>Next hyperstack frame</td>
</tr>
<tr>
<td>Hyperstacks</td>
<td>Alt ‹</td>
<td>Previous hyperstack frame</td>
</tr>
<tr>
<td>Crop [X]</td>
<td>Shift X</td>
<td>Crop active image or selection</td>
</tr>
<tr>
<td>Duplicate... [D]</td>
<td>Shift D</td>
<td>Duplicate active image or selection</td>
</tr>
<tr>
<td>Scale... [E]</td>
<td>E</td>
<td>Scale image or selection</td>
</tr>
<tr>
<td>Zoom ➤ In [+ ]</td>
<td>+ or ↑</td>
<td>Make image larger</td>
</tr>
<tr>
<td>Zoom ➤ Out [− ]</td>
<td>− or ↓</td>
<td>Make image smaller</td>
</tr>
<tr>
<td>Zoom ➤ Original Scale [4]</td>
<td>4</td>
<td>Revert to original zoom level</td>
</tr>
<tr>
<td>Zoom ➤ View 100% [5]</td>
<td>5</td>
<td>Zoom to 1:1</td>
</tr>
<tr>
<td>Process ➤ Smooth [S]</td>
<td>Shift S</td>
<td>3×3 unweighted smoothing</td>
</tr>
<tr>
<td>Process ➤ Repeat Command [R]</td>
<td>Shift R</td>
<td>Repeat previous command</td>
</tr>
<tr>
<td>Analyze ➤ Measure... [m]</td>
<td>M</td>
<td>Display statistics of active image / selection</td>
</tr>
<tr>
<td>Analyze ➤ Histogram [h]</td>
<td>H</td>
<td>Display histogram of active image / selection</td>
</tr>
<tr>
<td>Analyze ➤ Plot Profile [k]</td>
<td>K</td>
<td>Display density profile plot of active selection</td>
</tr>
<tr>
<td>Analyze ➤ Gels ➤ Select First Lane</td>
<td>L</td>
<td>Select first gel lane</td>
</tr>
</tbody>
</table>
### List of ImageJ 1.44 built-in shortcuts

This table can be obtained within ImageJ using the `Plugins\Shortcuts\List Shortcuts...` command.

<table>
<thead>
<tr>
<th>Command / Operation</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gels Select Next Lane</td>
<td><code>2</code></td>
<td>Select next gel lane</td>
</tr>
<tr>
<td>Gels Plot Lanes</td>
<td><code>3</code></td>
<td>Plot gel lanes</td>
</tr>
<tr>
<td>Plugins Control Panel...</td>
<td><code>Shift U</code></td>
<td>Open Control Panel</td>
</tr>
<tr>
<td>Utilities Capture Screen [g]</td>
<td><code>Shift G</code></td>
<td>Grab screenshot</td>
</tr>
<tr>
<td>Utilities Find Commands...</td>
<td><code>L</code></td>
<td>List, find and launch commands</td>
</tr>
<tr>
<td>Window Show All</td>
<td><code>T</code></td>
<td>Make all windows visible</td>
</tr>
<tr>
<td>Put Behind</td>
<td><code>Tab</code></td>
<td>Switch to next image window</td>
</tr>
<tr>
<td>ImageJ</td>
<td><code>Enter</code></td>
<td>Bring ImageJ window to front</td>
</tr>
</tbody>
</table>

# 31 Alt Key Modifications

- **File/Open Next** Open Previous
- **File/Revert** Don’t show dialog
- **Edit/Copy** Copy to system clipboard
- **Image/Color/Split Channels** Keep original image
- **Image/Stacks/Add Slice** Insert before current slice
- **Image/Stacks/Next Slice** Skip nine slices
- **Image/Stacks/Previous Slice** Skip nine slices
- **Image/Stacks/Start Animation** Show options dialog
- **Image/Duplicate** Don’t show dialog
- **Image/Overlay/Add Selection** Don’t show dialog
- **Process/Equalize** Do classic histogram equalization
- **Analyze/Histogram** Show dialog
- **Analyze/Plot Profile** For rectangular selections, generate row average plot
- **Analyze/Plot Profile** For wide straight lines, display rotated contents
- **Analyze/Gels/Select First Lane** Assume lanes are horizontal
- **Analyze/Tools/Analyze Line Graph** Show intermediate image
- **Analyze/Tools/Roi Manager(Add)** Name and add selection
- **Plugins/Utilities/ImageJ Properties** List all Java properties
Plugins ➤ Utilities ➤ Monitor Memory  Simulate 640×480 frame grabber

Any user plugin  Load using new class loader

Area selection tools  Subtract this selection from the previous one

Rectangle and Oval selection tools  Current aspect ratio is maintained while resizing

Polygon selection tool  Alt-click on a node to delete it

Straight line tool  Keeps the line length fixed while moving either end of the line. Forces the two points that define the line to have integer coordinate values when creating a line on a zoomed image

Segmented line tool  Alt-click on a node to delete it

Point tool  Alt-click on a point to delete it

Color picker tool  Alt-click to ‘pick-up’ background color

All tools  Show location and size in pixels

32  Shift Key Modifications

Image ➤ Adjust ➤ Threshold  Adjusting Min also adjusts Max

Image ➤ Adjust ➤ Brightness/Contrast  Apply adjustments to all channels of a composite image

Installed Macros and Scripts  Open instead of run

Rectangle and Oval selection tools  Forces 1:1 aspect ratio

Area selection tool  Add this selection to previous one

Polygon selection tool  Shift-click on a node to duplicate it

Straight line tool  Forces line to be horizontal or vertical

Segmented line selection tool  Shift-click on a node to duplicate it

Point selection tool  Shift-click to add a point

33  Ctrl Key (or Cmd Key on Macs) Modifications

Rectangle and Oval selection tools  (With Alt) Current aspect ratio is maintained while resizing

Rectangle and Oval selection tools  Selection is resized around the center

Straight line tool  Rotate/resize the line about its center

34  Space Bar

Any Tool  Switch to the hand tool
35 Arrow Keys

Moving Selections The four arrow keys move selection outlines one pixel at a time.

Resizing Selections Rectangular and oval selections are resized by holding \textit{Alt} while using the arrow keys.

Stacks Navigation The \textit{←} and \textit{→} keys substitute for \textit{<} and \textit{>} for moving through a stack. If there is a selection, you must also hold \textit{Shift}.

Hyperstacks Navigation The \textit{←} and \textit{→} keys change the channel. Hold \textit{Ctrl} to move through the slices and \textit{Alt} to move through the frames.

Zooming The \textit{↑} and \textit{↓} keys zoom the image in and out. If there is a selection, you must also hold either \textit{Shift} or \textit{Ctrl}.

36 Keyboard Shortcuts for ImageJ Tools

Keyboard shortcuts cannot be used directly to activate tools in the ImageJ toolbar (with the exception of the Magnifying Glass and the Scrolling Tool). However, shortcuts can be assigned to macros that use the \texttt{setTool()} function. Once copied to the to the \texttt{ImageJ/macros/StartupMacros.txt} file ImageJ will automatically install them at start-up.

The set of macros listed below (taken from the Rename and Save ROI Sets toolset) exemplify the use of the \texttt{setTool()} function by assigning the numeric keys 1–4 to the first four area selection Tools. The macro ‘Refine selection’ activates temporarily the brush selection tool when \texttt{5} is pressed. Once the mouse is released the previously selected tool is restored.

\begin{verbatim}
/* This set of macros exemplifies how to use the setTool() function to assign hotkeys to ImageJ tools. */
macro "Rectangle [1]" { setTool("rectangle");}
macro "Ellipse [2]" { setTool("elliptical");}
macro "Polygon [3]" { setTool("polygon");}
macro "Freehand [4]" { setTool("freehand");}
macro "Refine Area Selection [5]" {
tool = IJ.getToolName;
setTool("brush");
while (true) {
    getCursorLoc(x, y, z, flags);
    if(flags&16!=0){setTool(tool); exit;}
}
}
\end{verbatim}

This approach, however, requires the user to memorize as many shortcuts as the number of tools in the toolbar. In addition, it may be difficult to assign so many hot-keys without
conflicting with previously defined ones (see List Shortcuts...). Probably a more efficient way to control the toolbar using the keyboard is to create macros that can cycle through all the tools in the ImageJ toolbar. The next example demonstrates such an approach. It is composed of two macros activated by $F1$ and $F2$ that iterate through the toolbar items from left to right (forward cycle) and right to left (reverse cycle).

Listing 8 Cycling Through ImageJ Tools Using Keyboard Shortcuts

```java
/* These two macros loop through the tools listed in an array using "F1" and "F2" as keyboard shortcuts (forward and reverse cycling). */

var tIndx = 0;

macro "Cycle Tools Fwd [F1]"{
    setTool (tools[tIndx]);
    tIndx ++;
    if (tIndx == tools.length)
        tIndx = 0;
}

macro "Cycle Tools Rwd [F2]" {
    tIndx --;
    if (tIndx < 0)
        tIndx = tools.length - 1;
    setTool (tools[tIndx]);
}
```
Credits

[C1] The Command Finder was written by Mark Longair.
[C2] The macro editor’s Function Finder (Macros>Find Functions…) was written by Jérôme Mutterer.
[C3] The Elliptical Selection Tool was contributed by Norbert Vischer.
[C4] The Brush Selection Tool is based on the ROI Brush Tool plugin from Tom Larkworthy and Johannes Schindelin.
[C6] The File>Import>Results… command is based on Jérôme Mutterer’s Import_Results_Table macro.
[C8] Karen Collins contributed improvements to the FITS_Writer (File>Save As>FITS… command).
[C9] The Edit>Selection>Fit Circle command, based on a MATLAB script by Nikolai Chernov (http://www.math.uab.edu/~chernov/cl/MATLABcircle.html), was contributed by Michael Doube and Ved Sharma.
[C10] The Edit>Selection>Create Selection command is based on the Threshold_To_Selection plugin written by Johannes Schindelin.
[C12] The 16 different thresholding methods available in the Image>Adjust>Threshold… [T] tool were implemented by Gabriel Landini.
[C13] Michael Schmid contributed improvements to the downsizing kernel used by Image>Adjust>Size… and Image>Scale… [E] as well as undo support for Image>Scale… [E].
[C14] The Image>Adjust>Color Threshold… command implements Gabriel Landini’s Threshold Colour plugin.
[C15] The Reslice and the ZProject plugin (Image>Stacks>Reslice… [/] and Z Project… commands) were contributed by Patrick Kelly and Harvey Karten of the University of California, San Diego.
[C16] The Image>Stacks>Orthogonal Views [H] command is based on Dimiter Prodanov’s StackSlicer plugin and Albert Cardona’s Updater class. Michael Doube added support for XZ and YZ view control as well as mouse wheel control.
[C17] The Image>Stacks>3D Project… was written by Michael Castle and Janice Keller of the University of Michigan Mental Health Research Institute (MHRI). Bill Mohler added support for hyperstacks and 16/32–bit images in IJ 1.44m.
[C19] The Image>Hyperstacks>Reduce Dimensionality… command is based on Jérôme Mutterer’s Reduce HyperStack macro.
The Image ▶ Zoom ▶ Set... command is based on Albert Cardona’s Zoom Exact plugin.

The Process ▶ Find Maxima... command is based on a plugin contributed by Michael Schmid.

The equalization code implemented in Process ▶ Enhance Contrast was contributed by Richard Kirk.

The Process ▶ Math ▶ Macro... command is modeled after Ulf Dittmer’s Expression plugin.

The Process ▶ FFT ▶ Bandpass Filter... is a built in version of Joachim Walter’s FFT Filter plugin.

The Process ▶ Binary ▶ Fill Holes algorithm was contributed by Gabriel Landini.

The faster and more accurate version of Process ▶ Filters ▶ Gaussian Blur... implemented in ImageJ 1.38r and later was contributed by Michael Schmid.

The NonBlockingGenericDialog.class used by the Process ▶ Batch ▶ Macro... command was added by Johannes Schindelin.

The Analyze ▶ Distribution... command was written by Gabriel Landini.

The scaled color bar implemented in Analyze ▶ Histogram [h] was contributed by Bob Dougherty.

The Rodboard and Gaussian functions implemented in (Analyze ▶ Tools ▶ Curve Fitting...) were contributed by David Rodbard (NIH) and Stefan Wörz (DKFZ), respectively.

The ROI Manager(XOR) command (Analyze ▶ Tools ▶ ROI Manager...) was added by Johannes Schindelin.

The ROI Manager(Multi Measure) command (Analyze ▶ Tools ▶ ROI Manager...) is based on Bob Dougherty’s Multi_Measure plugin.

The Control Panel (Plugins ▶ Utilities ▶ Control Panel... [U]) was written by Cezar M. Tigare.

Other additions, improvements and bug fixes have been contributed by: Albert Cardona, Adrian Daerr, Alden Dima, Andreas Maier, Barry DeZonia, Christian Moll, Dimitar Prodanov, Divakar Ramachandran, Duncan Mak, Erik Meijering, Frederic Hessman, Gabriel Landini, Jan Funke, Jay Unruh, Joachim Wesner, Johannes Hermen, Johannes Schindelin, Juan Grande, Julian Cooper, Kai Uwe Barthel, Karen Collins, Kevin Moll, Mark Longair, Matthew Smith, Michael Doube, Michael Ellis, Michael Schmid, Nico Stuurman, Norbert Vischer, Olaf Freyer, Reinhard Mayr, Robert Dougherty, Shannon Stewman, Stephan Saalfeld, Stefan Starke, Tiago Ferreira, Tseng Qingzong, Ulf Dittmer, Uwe Walschus, Ved Sharma, Wilhelm Burger.

Macro Toolsets distributed with ImageJ have been contributed by: Gilles Carpentier (Arrow Labelling Tools.txt, Scale Bar Tools for Microscopes.txt), Jérôme Mutterer (Example Icons.txt, Magic Montage.txt), Tiago Ferreira (Toolset Creator.txt).
ImageJ Related Publications

The following references are a small sample of the bibliography directly related to ImageJ, the standard in scientific image analysis. These publications include: 1) technical articles and books describing routines implemented in ImageJ, 2) research articles that have made extensive use of ImageJ as a scientific tool or 3) reviews that discuss ImageJ pertinently. This list appears in chronological order rather than alphabetical and is particularly biased towards the life sciences.


List of Abbreviations and Acronyms

<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt</td>
<td>Alt, Option or Meta key;</td>
</tr>
<tr>
<td>API</td>
<td>Application Programming Interface;</td>
</tr>
<tr>
<td>ASCII</td>
<td>American Standard Code for Information Interchange;</td>
</tr>
<tr>
<td>AVI</td>
<td>Audio Video Interleave;</td>
</tr>
<tr>
<td>bit</td>
<td>Binary digit;</td>
</tr>
<tr>
<td>bpp</td>
<td>Bits per pixel;</td>
</tr>
<tr>
<td>CCD</td>
<td>Charge-Coupled Device;</td>
</tr>
<tr>
<td>CP</td>
<td>Color Picker;</td>
</tr>
<tr>
<td>CSV</td>
<td>Comma-Separated Values;</td>
</tr>
<tr>
<td>CT</td>
<td>Computed Tomography;</td>
</tr>
<tr>
<td>Ctrl</td>
<td>Control key. In this guide also the Command key in Apple keyboards;</td>
</tr>
<tr>
<td>DICOM</td>
<td>Digital Imaging and Communications in Medicine;</td>
</tr>
<tr>
<td>DPI</td>
<td>Dots Per Inch;</td>
</tr>
<tr>
<td>EDM</td>
<td>Euclidian Distance Map;</td>
</tr>
<tr>
<td>FAQ</td>
<td>Frequently Asked Questions;</td>
</tr>
<tr>
<td>FFT</td>
<td>Fast Fourier Transform;</td>
</tr>
<tr>
<td>FHT</td>
<td>Fast Hartley Transform;</td>
</tr>
<tr>
<td>FITS</td>
<td>Flexible Image Transport System;</td>
</tr>
<tr>
<td>fps</td>
<td>Frames Per Second;</td>
</tr>
<tr>
<td>GIF</td>
<td>Graphics Interchange Format;</td>
</tr>
<tr>
<td>GUI</td>
<td>Graphical User Interface;</td>
</tr>
<tr>
<td>HDR</td>
<td>High Dynamic Range;</td>
</tr>
<tr>
<td>HEX</td>
<td>Hexadecimal;</td>
</tr>
<tr>
<td>HSB</td>
<td>Hue Saturation Brightness;</td>
</tr>
<tr>
<td>HTML</td>
<td>HyperText Markup Language;</td>
</tr>
<tr>
<td>IJ</td>
<td>ImageJ;</td>
</tr>
<tr>
<td>JAR</td>
<td>Java ARchive;</td>
</tr>
<tr>
<td>JPEG</td>
<td>Joint Photographic Experts Group;</td>
</tr>
<tr>
<td>LUT</td>
<td>Lookup table;</td>
</tr>
<tr>
<td>LZW</td>
<td>Lempel-Ziv-Welch;</td>
</tr>
<tr>
<td>MIP</td>
<td>Maximum Intensity Projection;</td>
</tr>
<tr>
<td>MJPG</td>
<td>Motion-JPEG;</td>
</tr>
<tr>
<td>NaN</td>
<td>Not a Number;</td>
</tr>
<tr>
<td>OS</td>
<td>Operating System;</td>
</tr>
<tr>
<td>p/c</td>
<td>Pixels per cycle;</td>
</tr>
<tr>
<td>PBM</td>
<td>Portable BitMap;</td>
</tr>
<tr>
<td>PGM</td>
<td>Portable GrayMap;</td>
</tr>
<tr>
<td>pixel</td>
<td>Picture element;</td>
</tr>
<tr>
<td>PNG</td>
<td>Portable Network Graphics;</td>
</tr>
<tr>
<td>ppi</td>
<td>Pixels per inch;</td>
</tr>
<tr>
<td>PPM</td>
<td>Portable PixMap;</td>
</tr>
<tr>
<td>RAM</td>
<td>Random-Access Memory;</td>
</tr>
<tr>
<td>regex</td>
<td>Regular expression;</td>
</tr>
<tr>
<td>RGB</td>
<td>Red Green Blue;</td>
</tr>
<tr>
<td>ROI</td>
<td>Region Of Interest;</td>
</tr>
<tr>
<td>Shift</td>
<td>Shift key;</td>
</tr>
<tr>
<td>TIFF</td>
<td>Tagged Image File Format;</td>
</tr>
<tr>
<td>UEPs</td>
<td>Ultimate Eroded Points;</td>
</tr>
<tr>
<td>URL</td>
<td>Uniform Resource Locator;</td>
</tr>
<tr>
<td>voxel</td>
<td>Volumetric pixel;</td>
</tr>
<tr>
<td>WYSIWYG</td>
<td>What You See Is What You Get;</td>
</tr>
</tbody>
</table>
Exponential transformation, 116
Eye dropper, 34

F
Fast Fourier transform, 117
Fast Hartley Transform, 117
Feret, 137
Fiji, 2–4, 15, 21–23, 43
Filters, 119, 121–123
Find see Search, 7
Fit
Circle, 58
Cubic spline, 58, 61
Curve see Curve fitting, 148
Ellipse, 59, 136
FITs, 10, 53
Flatten, 102
Fractal box count, 147
Frame interval, 79
Freehand area selection, 29
Freehand line selection, 31
Frequency domain, 117

G
Gamma correction, 115
Gaussian Blur, 122
1–D Gel analysis, 144
GIF, 50
Transparency, 62
Global calibration see Calibration, 140
Graph, 63, 143, 148
Grayscale morphology, 110
Grouped Z Projection, 92

H
HandleExtraFileTypes, 44
Heat-maps, 99
Heckbert’s median cut algorithm see Color quantization, 70
Help resources, 4, 5, 163
Hexadecimal (Hex colors), 100, 101
Histogram, 141, 142
Histogram (measurements), 134
Holes, 111, 133
Hot pixels, 108
HSV, 14, 71, 76, 77
Huang see Threshold, 75
Hyperstacks, 93

I
Image calculator, 126
Image formats
Native, 9
Non-native, 10
Image sequence, 44, 52
Image types, 8, 13, 70
ImageJ for Microscopy see MBF ImageJ, 3
Import, 44
Installation, 164
Integrated density, 137
Interoperability, 25
Interpolation, 78
IsoData see Threshold, 75

J
Java, 2, 20, 22, 63, 66, 158
JavaScript, 20, 21
JFileChooser, 63
JPEG, 10, 12, 50
Quality, 62
JPEG2000, 11
Jython see Python, 23

K
Kurtosis, 137

L
Lanes see 1–D Gel analysis, 144
Layers see Image overlays, 101
Levels see Brightness & Contrast, 72, 73
Li see Threshold, 75
Linear regression see Curve fitting, 148
LOCI Bio-Formats, 3, 10
Log, 115
Logical operations
Images, 127
ROIs, 151
Lossless compression see LZW and PackBits, 9
Lossy compression, 11, 50
LUT, 13, 47, 53, 102
LZW compression, 9

M
Macro functions, 39, 164
Macro recorder, 155
Macro Tools, 35
Macro Toolset Switcher, 35
Macros, 20, 116, 125, 155
Install, 155
Magenta Green Blue (MGB), 15
Magnifying Glass Tool, 34
Mailing lists see Help resources, 4
Mask, 59, 108–110, 123
Math, 114
MATLAB see Interoperability, 25
Max, 115
MaxEntropy see Threshold, 75
Maxima, 104
MBF ImageJ, 3, 4, 13
Measure, 124, 130
Measurements, 135
Median cut algorithm see Color quantization, 70
Memory, 27, 66, 159
Metadata, 11, 79
μManager, 2
MIJ see Interoperability, 25
Min, 115
MinError see Threshold, 75
Minima, 105
MIP see Projection, 87

184
MJPEG, 10
Modifier Keys, xi, 6, 166
Modifier keys, 166
Moments see Threshold, 75
Montage see Stacks
(Montage), 84
Morphological operators, 108
Multiply see Math, 114
Multiply images see Image calculator, 126
Multi-point tool, 33

N
NaN, 116
Noise, 103, 104, 106, 122, 128
Non-background pixels, 147

O
Optical density see Calibration (Optical density), 139
Options see Settings, 18, 62
OR see Logical operations, 127, 151
Orthogonal views, 86
Otsu see Threshold, 75
Outliers, 108
Outline, 111
Oval selection, 28
Overlay, 99

P
PackBits compression, 9
Panel figures see Stacks (Montage), 84
Paste, 55, 56
Performance see Memory, 27, 66, 159
Perimeter, 136
PGM, 10
Pixel size, 79
Planar views see Orthogonal views, 86
Plot profile, 63, 64, 87, 90, 129, 142–144, 149, 167
Plugins, 3, 20, 22, 164
PNG, 10, 53
Transparency, 62
Point tool, 32
Polar coordinates, 117
Polygon selection, 29
Polynomial regression see Curve fitting, 148
Pop-up menu see Contextual menu, 36
Power spectrum, 118
PPI, 54
Precision, 138
Preferences see Settings, 18, 62
Print, 54
Processing, 103
Progress bar, 27
Projection, 86–88, 92
Proxy, 67
Python, 23
Quit, 54

R
R (GNU S) see Interoperability, 25
RAM see Memory, 27, 66
Raw, 51, 63
Raw density, 137
Reciprocal, 116
Record see Macro recorder, 155
Rectangular selection, 28
Redo, 8
Reduce, 91, 95
Reflex angles, 32
Regex, 45
Renyi see Threshold, 75
Resampling see Interpolation, 78
Reset, 158
Results table, 37
Revert, 53
RGB, 14, 70, 76, 77
ROI see Selection, 16, 17
ROI Manager, 101
Rolling ball, 128
Rotate, 97
Round rectangle, 28
Roundness, 137
Ruby, 23

S
Sagittal see Orthogonal views, 86
SalsaJ, 2
Sample Images, 43
Scale, 96
Scale bar, 153
Scientific notation, 138
Screenshot, 159
Scrolling, 34
Search, 7
Segmented Line selection, 31
Selection, 16
Composite, 18, 60
Properties, 17, 59, 100, 101, 138, 150, 152, 167
Refine, 29
Restore, 58
ROI Manager, 149
Settings, 18, 62, 65, 68, 99, 113, 118
Shadows, 108
Shanbhag see Threshold, 75
Shape descriptors, 137
Sharpen, 103
Shortcuts, xi, 6, 156, 166
64-bit, 66
Skeleton, 111
Skewness, 137
Sliding paraboloid see Rolling ball, 128
Smooth, 103
Sobel edge, 103
Solidity, 137
Spatial scale, 139
Square root transformation, 116
Square transformation, 116
Stacks, 11
  Brightness/Contrast, 71
  Export, 52
  From List, 12, 48
  Hyperstacks, 13, 93
  Labeling, 90, 92
  Montage, 84, 92
  Profile, 63, 87, 90, 143
  Projection see
    Projection, 86, 87, 92
  Reduce, 91, 92, 95
  Substacks, 92
  Tools, 91
    Virtual, 11, 48, 126
StartupMacros, 35, 43, 155
Statistics, 132–134
Status bar, 27
Straight line selection, 31
Straighten, 61
Subtract see Math, 114
Subtract Background, 128
Subtract images see
  Image calculator, 126
Surface, 143
Syntax highlighting, xi
Synthetic images, 116

T
  Tessellation see Voronoi, 112
  Text, 33
Threads, 158
3D Projection, 88
3D viewer, 86
Threshold, 75, 116, 138
  Binary images, 108
  Color, 76
TIFF, 9, 49
Time stamper, 90
Tolerance (Wand Tool), 30
Toolbar, 26
Tools
  Angle, 32
  Area Selection
    Brush, 29
  Ellipse, 29
  Freehand, 29
  Oval, 28
  Polygon, 29
  Rectangle, 28
  Round Rectangle, 28
  Wand, 30
  Color Picker, 34
Line Selection
  Arrow, 31
  Freehand Line, 31
  Segmented Line, 31
  Straight Line, 31
Macro Tools, 35
Macro Toolset Switcher, 35
Magnifying Glass, 34
Multi-point, 33
Point, 32
Scrolling, 34
Text, 33
Toolset, 35
Tracing see Wand tool, 30
Transform, 60, 97
Translate, 98

U
  Undo, 8, 53
  Unsharp mask, 123
Updates, 2, 3, 164

V
  Variance, 123
  Virtual stacks see
    Stacks (Virtual), 11
  Voronoi, 112
  Voxel depth, 79

W
  Wand tool, 30
  Watershed, 112
  Web browser, 163
  Window management, 162

X
  XOR see Logical
    operations, 127, 151

Y
  Yen see Threshold, 75
  YUV, 10, 14, 76, 77

Z
  Z Projection see
    Projection, 86, 87, 92
  ZIP, 42, 51, 151
    Compressed TIFF, 9, 51
  Zoom, 34, 98
    Fit to Screen, 99
  Z–Profile, 63, 87, 90, 143

186
About This Guide

The contents of this guide have been retrieved (using html2text) from the ImageJ website and updated where necessary using either information posted on the ImageJ mailing list, ImageJ Documentation Portal, Fiji webpage or Tony Collins ImageJ for Microscopy manual. Nevertheless, because there has never been accompanying documentation for some of the 300+ described commands, some parts of this guide were written from scratch based on the relevant ImageJ source code and/or authors own experience. Legacy nomenclature that became obsolete with version 1.44 has been intentionally omitted.

This is a free content guide. Thanks to Johannes Schindelin, the \LaTeX{} and LYX source files of this document are available through a Git version control repository at http://pacific.mpi-cbg.de/guide.git. Due to ImageJ’s heavy development this guide will always remain incomplete. You are encouraged to contribute to the ImageJ documentation resources, preferentially by maturing the ImageJ Documentation Portal or by committing changes directly to the Git repository.

As explained on the ImageJ web site, there are two possible ways to reference ImageJ:


To reference this document:


About the Cover

The Hartnack microscope (ca. 1870) depicted on the front page inspired the ImageJ icon for Mac OS X. More information about the original picture can be found on the ImageJ website.

All other images in the guide were created with Apple® Grab 1.5 and ImageJ 1.42q–1.45b, loaded with G. Landini’s LJ Robot and J. Schindelin’s Tutorial Maker plugins. The HTML version may use icons from the Tango Desktop Project under a Creative Commons license.

Comments and Suggestions:

Tiago A. Ferreira
Centre for Research in Neuroscience
McGill University, Montreal, QC, Canada
tiago.ferreira@mail.mcgill.ca